Forums

Sound laggy and scratchy in the applications

Auteur Réponses
Jump to the page: 1 - 2
LamerTex Dimanche 28 Avril 2013 à 16:06
LamerTexAnonymous

It's all running good, both steam (with dota2 and l4d2) and league of legends, but in every game the sound is very bad, laggy and scratchy. In the P4L log of steam i've find one error that's relative to the sound I think (here the complete log http://pastebin.com/EexxtFxU):
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred

What can I do? I've find some topic about this error (like this one https://bbs.archlinux.org/viewtopic.php?id=145570) , but I don't know how works ALSA with wine (or ALSA in general xD)...

Sometimes after a while the sounds get back normally, now i'm trying to find some log for this if it will appen again.

Someone have some idea of what's happening? I hadn't this problem on the same computer before now.

-Ubuntu 13.04
-PlayOnLinux 4.2.1
-wine: 1.5.25 for steam and 1.5.24LeagueOfLegendsShop for LoL
-Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

If I can post something else helpfull I'm always here :)


EDIT: ok after a while the sound return normal, but in the log there's nothing :(

Edité par LamerTex

petch Dimanche 28 Avril 2013 à 18:56
petch
Développeur

That means the game doesn't get control back often enough to keep audio buffers filled.
Could be heavy swapping (memory shortage), high cpu utilisation (non accelerated drivers, other apps hogging the cpu,...).
I wonder if PulseAudio could be the problem, too: http://www.playonmac.com/en/issue-1314.html

Edité par petch

LamerTex Mercredi 1 Mai 2013 à 10:17
LamerTexAnonymous

I tryed to monitor the cpu and memory usage, but it's always under the 50% for both so I don't think it's the problem...
I'm trying to understand the problem with PulseAudio and if I can do anything with it, without succes for now >.
Ronin DUSETTE Mercredi 1 Mai 2013 à 18:06
Ronin DUSETTE
Admin

That virtual drive should be set to use ALSO, not Pulse, if I am not mistaken, though.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Mercredi 1 Mai 2013 à 20:28
booman

How do you set the Virtual Drive to ALSA instead of Pulseaudio?
I've read that several time and still don't know how to do it...

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Mercredi 1 Mai 2013 à 20:38
Ronin DUSETTE
Admin

You have to edit the registry (or do it from the POL Shell or script)

Its listed in here:

http://wiki.winehq.org/UsefulRegistryKeys

sorry. Im at work, and a little busy. But you can do it like that with the reg key (use that link) or you can do it from the POL shell, if I am not mistaken.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Mercredi 1 Mai 2013 à 20:44
booman

registry? Oh No.... not in Linux.... please Nooooooooooo!!!

I'll check it out, Thanks

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Mercredi 1 Mai 2013 à 22:35
Ronin DUSETTE
Admin

hahahahaha. No fear. Its not as bad as you think for doing small things like this (luckily, we have POL functions that take care of most of this stuff for us. Thanks devs! )

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Mercredi 1 Mai 2013 à 22:37
booman

I'm used to messing with the registry, but was making fun at having to do it in Linux psuedo-windows.

I thanks the Devs for everything they do. I actually make a donation too.
And will probably send some more in the future

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Mercredi 1 Mai 2013 à 22:49
Ronin DUSETTE
Admin

I know. hahaha. Thats whats funny about it. :)

I hope to donate more, as well. Hence learning OOP. lol

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
LamerTex Jeudi 2 Mai 2013 à 16:12
LamerTexAnonymous

Hahaha thanks for this you make my day xD

However I tryed with the terrible registry (with the registry editor in playonlinux configuration) and I've add the "+-Drivers | +->Audio" thing, if I put something else instead of alsa the audio didn't work anymore, with the string set to alsa it's just right (in the wine config the audio is set correct with all the different output/input units and the selected driver "winealsa.drv" http://img248.imageshack.us/img248/7545/schermatadel20130502155.png), also in audio configuration of ubuntu it's seems to be set correctly (http://imageshack.us/photo/my-images/835/schermatadel20130502155.png/) but the audio it's again the same :(

I've find an error when I do the "audio test" in the wine config: "err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded" can this be related to the problem?

Thanks for the help :)

Edité par LamerTex

Ronin DUSETTE Jeudi 2 Mai 2013 à 18:40
Ronin DUSETTE
Admin

It should only say ALSA. Not Pulse or anything. Although, if you are running WineASIO this will be different, but that is only for music production programs.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Jeudi 2 Mai 2013 à 19:37
booman

Interesting... I've been meaning to try this for some of my games.
I'll let you know what happens when I mess with it

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
LamerTex Jeudi 2 Mai 2013 à 20:13
LamerTexAnonymous

No I'm not running WineASIO, but now I'm pretty sure that my problem is not related to playonlinux but directly to the alsa and the pulseAudio.
I hadn't see it before, because without the emulation layer of wine the cpu was powerfull enough to keep the audio smooth, but the problem is the same on steam (only because I've found this program that have this problem but it's not alone) for linux and on steam for windows in wine...
It's a problem of stuttering with the ALSA plug-in, that works fine with youtube or other program but not with all, here my video to show what happens:
"http://www.youtu.be/p2W3mnd5s8o"

I'm trying to search for a solution, but for now I've only find thread of 3-4 years ago with older version of linux and no one of the solution worked for me...

If someone know something more on what can I try I'm always here for some help, thanks :)

Edité par LamerTex

Ronin DUSETTE Jeudi 2 Mai 2013 à 20:22
Ronin DUSETTE
Admin

Your distro uses Pulse audio by default, so switching it to ALSA should fix it.

But, you are still basically running a beta of Ubuntu (non LTS version), which uses experimental features, so I dont know what they would have changed on their end, but its always best to run an LTS to make sure everything that is running is a stable, tested version.

PS: WINE is a recursive acronym for "Wine Is Not an Emulator" ;) lol

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
LamerTex Jeudi 2 Mai 2013 à 20:29
LamerTexAnonymous


PS: WINE is a recursive acronym for "Wine Is Not an Emulator" ;) lol

Quote from DJYoshaBYD


Haha yea I know, but every time it catch me with this error :P

And for the version, it's good for me to use a beta, I like to learn new things and problems are the better way to learn new things xD

However thanks for the help here, I'll search if I can find other solution instead of switch completly to ALSA (but I'll try this way too of course ;) ).


Ronin DUSETTE Jeudi 2 Mai 2013 à 20:32
Ronin DUSETTE
Admin

Well, the thing is, Betas arent really good for learning, if nothing wants to work correctly on them. :)

Id say keep betas in virtual machines, and not for every day use, but hey, thats just me. haha

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Vendredi 3 Mai 2013 à 14:34
booman

Ok, I opened the Wine Registry Editor
Searched for software/wine/drivers/audio

I found: winealsa.drv

under it is devices, then a bunch of strangely named devices:
0,default
0,plughw:0,0
0,plughw:0,1
and on and on and on

Nothing about pulseaudio, which probably means Wine isn't using it correct?
So if I delete winealsa.drv apparently Wine is supposed to automatically find the best appropriate choice for the audio.

How do I check to see what my system currently supports?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
LamerTex Vendredi 3 Mai 2013 à 15:27
LamerTexAnonymous

Ok, I opened the Wine Registry Editor
Searched for software/wine/drivers/audio

I found: winealsa.drv

under it is devices, then a bunch of strangely named devices:
0,default
0,plughw:0,0
0,plughw:0,1
and on and on and on

Nothing about pulseaudio, which probably means Wine isn't using it correct?
So if I delete winealsa.drv apparently Wine is supposed to automatically find the best appropriate choice for the audio.

How do I check to see what my system currently supports?

Quote from booman


The correct thing to do here is to add a string value (in the Drivers directory) and call it Audio, then set this string to the value "alsa" or other :)


However I've just manage to resolve my problem (it wasn't a PlayOnLinux problem but a pulseaudio problem but I'll write the answer anyway).
The problem seemed to be related to the configuration file /etc/pulse/default.pa at the line
"load-module module-udev-detect".
In my file this line was originally:
"load-module module-udev-detect use_ucm=0" (I don't know why)
and more than one solution was to modify this line to be:
"load-module module-udev-detect tsched=0"

This solution didn't work for me so I continue to search for other solution, at the end in despair, I just try to delete the option after this line and leave only the original line and this just resolve every problem now the audio with all the PlayOnLinux (and other application that had the same problem) now work fine :)
(only skype with it's notification have some problem but it's not a big deal, when I call there are no problem)

Thanks to all, and when booman agree with me I can set this problem to solved :)
booman Vendredi 3 Mai 2013 à 16:19
booman

Thank you for posting the solution you found.
Please mark this thread as solved.

As for me... I'll check out the "load-module-udev-detec" too...
I'm having problems with "Back to the Future"... every time the dialog starts, the game stutters a lot. I've tried everything video-wise, but have not messed with audio yet.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained