Forums

everquest EQ on Fedora 17 64bit, can't get it installed

Auteur Réponses
eq_fan Samedi 4 Mai 2013 à 1:50
eq_fanAnonymous


running into some problems with getting everquest to run on fedora 17 64 bit

 

I tried to follow the instructions at : http://forums.station.sony.com/eq/index.php?threads/how-i-got-eq-to-run-on-linux-with-playonlinux-pon.1185/

 

I installed the latest playonlinux 32 bit

installed win 1.5.29

installed NVidia drivers and opengl 32

 

I created a virtual partition and I install into is  go to install the eq setup that I got from

 

dxfullsetup

and d3dx11 (there is no dx11 choice like instructions say so I took a guess here).

 

next I get the application that will install everquest.

 

By going to https://www.everquest.com/ and selecting "get started" then clicking the tiny

link that says "Download the Game"  which gives you an executable called EQ_setup.exe

 

next per link instructions I do the following

 

in PoN click Install Program
At bottom click install a non listed program and click ok.
Click next, edit or update an existing application, next.
Check show virtual drive, highlight Games and click next.
Click next again, don't check any option.
Browse to the location of the EQ Install client.
Highlight and open.
Accept default location.
Don t install the DX client, we already did that.
Wait and wait some more and bam the install crashes every time.

 

I can't seem to get beyond this point.

 

anyone been successful with fedora 17 64 bit and everquest?

Ronin DUSETTE Samedi 4 Mai 2013 à 1:56
Ronin DUSETTE
Admin

EverQuest II Sentinel's Fate is listed in the script repository. Maybe you can try using that script for the one you have?

If you click Install, and search for EverQuest, use the one that is there, and see if that gets you any further.

Also, can you run playonlinux from the terminal and try to reinstall it to a fresh virtual drive? Im curious as to what errors it is putting out during the install.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
eq_fan Samedi 4 Mai 2013 à 2:11
eq_fanAnonymous

That was a good idea, I ran the EQ2 script. it seems to mostly work but doesn't install eq2. then I went back and tried installing a non listed app and pointed to the EQ_setup.exe. it still crashes. heres the dump

---------------------------
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x10a44ae2).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:10a44ae2 ESP:0033e710 EBP:00b314d0 EFLAGS:00010212( R- -- I -A- - )
EAX:00000000 EBX:00000074 ECX:00b2cc38 EDX:000000c0
ESI:00000000 EDI:031d6910
Stack dump:
0x0033e710: 00000000 031d6910 108d0922 031d5494
0x0033e720: 031d5494 109b9220 00000000 00000000
0x0033e730: 00b314d0 00000000 00000018 00000000
0x0033e740: 00000006 00000000 00000000 00010100
0x0033e750: 00000000 00000000 010000c4 00000000
0x0033e760: 00000006 031d5494 00000000 00000006
Backtrace:
=>0 0x10a44ae2 in awesomium (+0xa44ae2) (0x00b314d0)
1 0x031d54e0 (0x11167138)
2 0x108b7360 in awesomium (+0x8b735f) (0x109fcc80)
3 0x8528778b (0xf98b5756)
0x10a44ae2: movl     0x0(%esi),%edx
Modules:
Module     Address               Debug info     Name (91 modules)
PE      400000- 473000     Deferred awesomiumprocess
PE     10000000-1153b000     Export awesomium
PE     3cf00000-3cf1d000     Deferred en-us
PE     4ad00000-4b771000     Deferred icudt42
ELF     7b800000-7ba46000     Deferred kernel32
\\-PE     7b810000-7ba46000     \\ kernel32
ELF     7bc00000-7bcd8000     Deferred ntdll
\\-PE     7bc10000-7bcd8000     \\ ntdll
ELF     7bf00000-7bf04000     Deferred
ELF     7d980000-7d992000     Deferred libp11-kit.so.0
ELF     7d992000-7d9a4000     Deferred libtasn1.so.3
ELF     7d9a4000-7d9ba000     Deferred libz.so.1
ELF     7d9ba000-7da3b000     Deferred libgcrypt.so.11
ELF     7da3b000-7dafc000     Deferred libgnutls.so.26
ELF     7db19000-7db50000     Deferred uxtheme
\\-PE     7db20000-7db50000     \\ uxtheme
ELF     7dc50000-7dc56000     Deferred libxfixes.so.3
ELF     7dc56000-7dc61000     Deferred libxcursor.so.1
ELF     7dc61000-7dc71000     Deferred libxi.so.6
ELF     7dc71000-7dc7a000     Deferred libxrandr.so.2
ELF     7dc7a000-7dc84000     Deferred libxrender.so.1
ELF     7dc84000-7dca6000     Deferred libxcb.so.1
ELF     7dca6000-7ddde000     Deferred libx11.so.6
ELF     7ddde000-7de71000     Deferred winex11
\\-PE     7ddf0000-7de71000     \\ winex11
ELF     7deb4000-7deb8000     Deferred libxcomposite.so.1
ELF     7deb8000-7debe000     Deferred libxxf86vm.so.1
ELF     7debe000-7dec2000     Deferred libxinerama.so.1
ELF     7dec2000-7dec6000     Deferred libxau.so.6
ELF     7dec6000-7decc000     Deferred libuuid.so.1
ELF     7decc000-7dede000     Deferred libxext.so.6
ELF     7dede000-7def8000     Deferred libice.so.6
ELF     7def8000-7df01000     Deferred libsm.so.6
ELF     7df02000-7df07000     Deferred libgpg-error.so.0
ELF     7df41000-7df6a000     Deferred libexpat.so.1
ELF     7df6a000-7df9f000     Deferred libfontconfig.so.1
ELF     7df9f000-7e03f000     Deferred libfreetype.so.6
ELF     7e03f000-7e082000     Deferred usp10
\\-PE     7e050000-7e082000     \\ usp10
ELF     7e082000-7e0a7000     Deferred imm32
\\-PE     7e090000-7e0a7000     \\ imm32
ELF     7e0a7000-7e108000     Deferred riched20
\\-PE     7e0b0000-7e108000     \\ riched20
ELF     7e108000-7e128000     Deferred oleacc
\\-PE     7e110000-7e128000     \\ oleacc
ELF     7e128000-7e15e000     Deferred ws2_32
\\-PE     7e130000-7e15e000     \\ ws2_32
ELF     7e15e000-7e177000     Deferred libresolv.so.2
ELF     7e194000-7e1ba000     Deferred iphlpapi
\\-PE     7e1a0000-7e1ba000     \\ iphlpapi
ELF     7e1ba000-7e1e7000     Deferred netapi32
\\-PE     7e1c0000-7e1e7000     \\ netapi32
ELF     7e1e7000-7e219000     Deferred secur32
\\-PE     7e1f0000-7e219000     \\ secur32
ELF     7e219000-7e244000     Deferred msacm32
\\-PE     7e220000-7e244000     \\ msacm32
ELF     7e244000-7e2fa000     Deferred winmm
\\-PE     7e250000-7e2fa000     \\ winmm
ELF     7e2fa000-7e30e000     Deferred psapi
\\-PE     7e300000-7e30e000     \\ psapi
ELF     7e30e000-7e44a000     Deferred oleaut32
\\-PE     7e320000-7e44a000     \\ oleaut32
ELF     7e44a000-7e4cd000     Deferred rpcrt4
\\-PE     7e460000-7e4cd000     \\ rpcrt4
ELF     7e4cd000-7e60b000     Deferred ole32
\\-PE     7e4e0000-7e60b000     \\ ole32
ELF     7e60b000-7e712000     Deferred comctl32
\\-PE     7e610000-7e712000     \\ comctl32
ELF     7e712000-7e78b000     Deferred shlwapi
\\-PE     7e720000-7e78b000     \\ shlwapi
ELF     7e78b000-7e9bc000     Deferred shell32
\\-PE     7e7a0000-7e9bc000     \\ shell32
ELF     7e9bc000-7eb18000     Deferred user32
\\-PE     7e9d0000-7eb18000     \\ user32
ELF     7eb18000-7eb88000     Deferred advapi32
\\-PE     7eb20000-7eb88000     \\ advapi32
ELF     7eb88000-7eca5000     Deferred gdi32
\\-PE     7eb90000-7eca5000     \\ gdi32
ELF     7eca5000-7edab000     Deferred opengl32
\\-PE     7ecc0000-7edab000     \\ opengl32
ELF     7edab000-7edb8000     Deferred libnss_files.so.2
ELF     7efb8000-7efe3000     Deferred libm.so.6
ELF     7efe6000-7f000000     Deferred version
\\-PE     7eff0000-7f000000     \\ version
ELF     f73c8000-f73cd000     Deferred libdl.so.2
ELF     f73cd000-f757f000     Deferred libc.so.6
ELF     f757f000-f7599000     Deferred libpthread.so.0
ELF     f7599000-f76dd000     Dwarf libwine.so.1
ELF     f76f1000-f76fa000     Deferred librt.so.1
ELF     f76fb000-f771c000     Deferred ld-linux.so.2
ELF     f771c000-f771d000     Deferred [vdso].so
Threads:
process tid prio (all id:s are in hex)
0000000c services.exe
     00000036 0
     00000035 0
     0000000e 0
     0000000d 0
00000012 explorer.exe
     00000013 0
00000032 winedevice.exe
     00000039 0
     00000038 0
     00000034 0
     00000033 0
00000025 LaunchPad.exe
     00000042 0
     0000003f 0
     0000003e 0
     00000040 0
     00000009 0
     00000021 0
     00000022 0
     00000023 0
     00000024 0
     00000037 0
     0000003b 0
     00000016 0
     00000017 0
     00000018 0
     00000019 0
     00000014 0
     00000015 0
     00000047 0
     00000046 0
     00000045 0
     00000044 0
     00000043 0
     00000011 0
     0000002b 0
     0000002a 0
     00000028 0
     00000026 0
0000003a AwesomiumProcess.exe
     0000002e 0
     00000030 0
     00000031 0
     0000000b 0
0000002d (D) C:\\games\\EverQuest\\LaunchPad.libs\\AwesomiumProcess.exe
     0000001e 0
     0000001d 0
     0000001c 0
     0000002c 0 <==
0000001f winedbg.exe
     00000020 0
System information:
Wine build: wine-1.5.24
Platform: i386 (WOW64)
Host system: Linux
Host version: 3.8.8-100.fc17.x86_64
-------------------------------------------
Ronin DUSETTE Samedi 4 Mai 2013 à 2:18
Ronin DUSETTE
Admin

Im not so much worried about the dump, but what the terminal puts out when you run playonlinux from a terminal and run it.

Although, even with doing that, this game will probably need a script to be written for it.

If you are somewhat interested and computer savvy, you can read the scripting documentation here:

http://www.playonmac.com/en/documentation.html

If you could, open a terminal, run playonlinux from it. Then, erase the virtual drives from your previous install attempts, and try again, just by creating a new virtual drive and running the installer. The output in the terminal should give us some clues as to what is needed to get it working.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
eq_fan Samedi 4 Mai 2013 à 2:22
eq_fanAnonymous

ok will do. I'm out of time now, but will circle back on this later tonight. Thanks for the help.
Ronin DUSETTE Samedi 4 Mai 2013 à 2:22
Ronin DUSETTE
Admin

No problem.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts