Forums

Lineage 2

Problème XML

Auteur Réponses
L3m4C Mardi 21 Mai 2013 à 14:43
L3m4CAnonymous

Bonjour, 

J'ai utilisé votre logiciel PlayOnMac pour installer Lineage 2 sur mon Macbook Pro Rétina.

Le jeu fonctionne plutôt bien. J'ai eu pas mal de soucis avec la police notamment, mais une fois le problème cerné, j'ai juste eu à ajouter un tahoma.ttf dans Windows/fonts pour que ça fonctionne.
Ensuite avec la résolution quand je minimise la fenêtre, mais en modifiant le Option.ini j'arrive à palier ce problème. Ce qui fait le jeu est très fluide, et j'en suis très content. Donc merci à vous ! :D.

Vous allez donc me demander, pourquoi il ouvre ce post ? eh bien, il me reste un petit bug, qui est vraiment embêtant ^^.

J'ai un crash lorsque je veux acheter ou supprimer des items. J'ai cerné le problème, c'est lié à windows et au parse de l'XML. Dans les forums spécialisés en bug Lineage 2, il conseille de mettre un jour les DLL msxml. (http://www.microsoft.com/en-us/download/details.aspx?id=13631)
Tous les posts que j'ai trouvé parlant de ce bug sont solutionné par l'installation de ce patch, ce que me laisse penser que c'est LA solution dont j'ai besoin.

J'ai donc essayé d'installer ce patch en allant dans Configurer>Divers>Lancer un ".exe" dans ce disque virtuel pour installer mon patch. J'ai aussi essayé de copier mes dlls dans un windows system32. Mais rien n'y fait, le problème persiste.

Je voulais donc savoir si c'est ma façon d'utiliser votre logiciel qui n'est pas bonne, je fais peut-être fausse route dans ma manière d'installer le patch, ou tout simplement si vous avez des idées. J'ai cru comprendre qu'il y a peu de temps, vous avez créé  un installeur pour Age of empire et il me semble qu'il y avait des problèmes du même type (lié à msxml).

Merci pour l'attention que vous m'avez porté en lisant ceci :D


SuperPlumus Mardi 21 Mai 2013 à 16:27
SuperPlumusAnonymous
Admin

Bonjour,

Vous pouvez essayer d'installer les DLLs manquantes de la manière suivante :
Ouvrez PlayOnMac -> Bouton Configurer -> Sélectionner le disque virtuel de votre jeu à gauche -> Onglet Install Components -> msxml3/4/6.

Cela installera les DLLs de msxml (3 versions de msxml sont possibles : 3, 4 ou 6).

Cela configurera également Wine afin de lui dire que les DLLs de msxml doivent être chargées en "native", ce qui signifie prendre les DLLs qui auront été installées.

Mais il faut garder à l'esprit que cela peut parfois introduire d'autres bugs

Vous pouvez également trouver d'autres infos sur la page de WineHQ AppDB :
[url]http://appdb.winehq.org/objectManager.php?sClass=application&iId=2273[/url]

En espérant avoir pu vous aider.

Edité par SuperPlumus

L3m4C Mardi 21 Mai 2013 à 20:48
L3m4CAnonymous

re-bonsoir,

Merci beaucoup pour cette réponse rapide :).

Je vais essayé ça et aller jeter un oeil du côté de winehq !

Je mets en résolue, si je trouve comment debug le jeu, je viendrai poster ma solution !

L3m4C.