Forums

EverQuest via EQW - cursor behaving erratically

Auteur Réponses
rage_311 Jeudi 5 September 2013 à 18:24
rage_311Anonymous

Hey everyone.

I'm trying to troubleshoot an issue I'm having with EverQuest -- I'm using the modified PC version (via EQW) to play on the Mac server.  I had this working perfectly on this same machine in Fedora 17, but I've since reformatted and installed Arch.  The issue I'm having is that the in-game cursor is very sporadic: it hardly reacts to mouse movements until I hit a certain spot, then it flies across the screen with only small movements.  I'm using native dinput8 (otherwise it crashes.)

On my previous Fedora install, I had it working with WINE 1.5.29, dxd9_30, and dinput8, via the steps described here (my own blog post): http://leveluplinux.blogspot.com/2013/05/eqmac-on-linux.html

I've tried that exact combination, as well as many other versions of WINE (including 1.6 and 1.7.1), and with and without the library overrides, but they all behave similarly.  I know that EQ/EQW uses raw input devices, so I don't know if there's something else there that I'm missing.

PoL output is here: https://dpaste.de/VWVO1/

I have no idea what the difference could be between my Arch setup now and my previous Fedora setup that would cause this to not work.  I believe that I was using kernel 3.9.x and KDE 4.10.x in Fedora, and now I'm on kernel 3.10.10 and KDE 4.11.0.

My system:
Intel i7-930 CPU
Nvidia GTX 670 4GB w/proprietary 325.15 binary driver
6GB RAM
Arch Linux 64-bit
Linux kernel 3.10.10
KDE 4.11.0
PoL 4.2.1

Please let me know what other info would be helpful.  Any help would be greatly appreciated.  Thanks!
booman Vendredi 6 September 2013 à 17:57
booman

Did you check the mouse setting in Wine configuration?
Also PlayOnLinux has a Mouse override setting in Configure/Miscellaneous
You could try that too.... I usually have negative results with the override.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
rage_311 Dimanche 8 September 2013 à 7:47
rage_311Anonymous

Did you check the mouse setting in Wine configuration?

Quote from booman
Do you mean the "Automatically capture the mouse in full-screen windows" setting?  I've tried with that setting on and off.  It doesn't seem to make much of a difference.

Also PlayOnLinux has a Mouse override setting in Configure/Miscellaneous
You could try that too.... I usually have negative results with the override.

Quote from booman
The "Mouse warp override" I assume?  I've tried all of the settings on this to on avail.  Though, that reminds me, PlayOnLinux tells me that WINE crashes every time I make a configuration change on one of the virtual drives -- either ANY of the settings under "Display" or the mouse warp override.  I get the "sad face" pop-up that says "Error in POL_Wine.  Wine seems to have crashed.  If your program is running, just ignore this message."  So, to get the mouse/graphics changes to stick, I've had to edit them in the registry directly...  Any insight on that one?  Maybe it's related?


Thanks for the help so far.
rage_311 Dimanche 8 September 2013 à 7:47
rage_311Anonymous

Did you check the mouse setting in Wine configuration?

Quote from booman
Do you mean the "Automatically capture the mouse in full-screen windows" setting?  I've tried with that setting on and off.  It doesn't seem to make much of a difference.

Also PlayOnLinux has a Mouse override setting in Configure/Miscellaneous
You could try that too.... I usually have negative results with the override.

Quote from booman
The "Mouse warp override" I assume?  I've tried all of the settings on this to on avail.  Though, that reminds me, PlayOnLinux tells me that WINE crashes every time I make a configuration change on one of the virtual drives -- either ANY of the settings under "Display" or the mouse warp override.  I get the "sad face" pop-up that says "Error in POL_Wine.  Wine seems to have crashed.  If your program is running, just ignore this message."  So, to get the mouse/graphics changes to stick, I've had to edit them in the registry directly...  Any insight on that one?  Maybe it's related?


Thanks for the help so far.
booman Dimanche 8 September 2013 à 15:45
booman

Hmm, not sure then. I don't use Arch, but maybe its a problem with Arch and not wine?
Can you launch EverQuest by clicking "Debug" instead of "Run" then post the output here so we can see any errors

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
rage_311 Dimanche 8 September 2013 à 17:18
rage_311Anonymous

A few more observations and things I've been trying:
  • Tried enabling/disabling compositing in KDE/KWin
  • Tried turning off mouse acceleration in KDE
  • I can only get the in-game cursor to respond somewhat-consistently if I hold left- or right-click somewhere in the game window the whole time I'm moving the mouse.  The game window never seems to "grab" the mouse otherwise, regardless of my wine configuration for "Allow full screen windows to capture the mouse."  The whole idea of EQW is to allow EverQuest to run in a window, so I'm not sure if it actually counts as a full-screen window...  Unfortunately, EQW is required to run the Windows EverQuest client to connect to the Mac server.  Also, the cursor likes to slide along the left and top sides when I'm doing this.  I can only get it to detach from those sides if I hit a certain spot on the screen with my invisible X cursor...  very strange.
  • I created a new virtual drive and did a fresh install, just to make sure I hadn't accidentally screwed anything else up.  Now, wine doesn't crash when I make config changes in POL.
  • I got to wondering if I'm using a newer version of X where they've changed something about the way the mouse input/cursor works... just a thought.

Here's my debugger output from POL when running on WINE 1.7.1 with dinput8 as the only override -- as I said, it crashes without it.

[09/08/13 08:55:39] - Running wine-1.7.1 eqw.exe (Working directory : /home/matt/.PlayOnLinux/wineprefix/EQMac3/drive_c/EQMac)
fixme:win:EnumDisplayDevicesW ((null),0,0x33eca8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f3d8,0x00000000), stub!
fixme:d3d:wined3d_device_decref Device released with resources still bound, acceptable but unexpected.
fixme:d3d:wined3d_device_decref Leftover resource 0x16e438 with type WINED3D_RTYPE_SURFACE (0x1).
fixme:win:EnumDisplayDevicesW ((null),0,0x33f458,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f478,0x00000000), stub!
fixme:ddraw:ddraw7_WaitForVerticalBlank iface 0x14bf20, flags 0x1, event (nil) stub!
err:winediag:WSASocketW Failed to create a socket of type SOCK_RAW, this requires special permissions.
err:winediag:WSASocketW Failed to create a socket of type SOCK_RAW, this requires special permissions.
fixme:win:EnumDisplayDevicesW ((null),0,0x33f568,0x00000000), stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:win:EnumDisplayDevicesW ((null),0,0x33f3d8,0x00000000), stub!
fixme:d3d:wined3d_device_decref Device released with resources still bound, acceptable but unexpected.
fixme:d3d:wined3d_device_decref Leftover resource 0x216ae0 with type WINED3D_RTYPE_SURFACE (0x1).
fixme:win:EnumDisplayDevicesW ((null),0,0x33f458,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f478,0x00000000), stub!
err:winediag:WSASocketW Failed to create a socket of type SOCK_RAW, this requires special permissions.
fixme:msvcrt:__clean_type_info_names_internal (0x3883c4) stub


Thanks for sticking with me on this.  I'd love to get it fixed.
rage_311 Dimanche 8 September 2013 à 17:42
rage_311Anonymous

Quick update:

If I run it in a fullscreen virtual desktop and pre-set the EQW configuration to an absolute position that makes it cover the whole virtual desktop, I have no problem getting it to capture the mouse (with WINE's "Allow full screen windows to capture the mouse" setting enabled.) The cursor still behaves erratically once captured though.
rage_311 Dimanche 8 September 2013 à 19:36
rage_311Anonymous

Also, one more oddity that I've found: if I Alt+Tab away from EQW, but hold down Alt for 2+ seconds, the cursor in EQW will track my X cursor perfectly. If I try to click anything though, it will just click on whatever other application my X cursor is over, since EQW doesn't really have the mouse focus...
booman Lundi 9 September 2013 à 17:38
booman

Quick update:

If I run it in a fullscreen virtual desktop and pre-set the EQW configuration to an absolute position that makes it cover the whole virtual desktop, I have no problem getting it to capture the mouse (with WINE's "Allow full screen windows to capture the mouse" setting enabled.) The cursor still behaves erratically once captured though.

Quote from rage_311
Ah, now we are getting somewhere.  I use the Wine virtual desktop all the time. Mostly because Games and changing resolutions doesn't get along with X.
Now that  I know the EQW is a "windowed" mod it makes sense.

So if you want to run EQW in a windows, set the virtual desktop to match the resolution of the windowed game.  Then it should work.
Normally what I do is set virtual desktop for 1024x768 and then it resizes when you change in-game resolutions.  I'll basically match my Linux Desktop and the game appears fullscreen.

Yeah, Alt+Tab is buggy with Wine too.  I was having the same problem over the weekend on my Acer Chromebook and running NOX.  Any time I Alt+Tab it would crash the game.  Nox would reset my Linux Desktop resolution to 1024x768 when I really wanted it to be 1366x768.  This can be frustrating at times.  specially with older games that don't support higher resolutions.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained