Forums

World of Warcraft weird sound

Auteur Réponses
max007 Lundi 25 Novembre 2013 à 21:35
max007Anonymous

Hello,

I was using playonlinux with optirun and wine x86: 1.5.x, 1.7.7, 1.7.6, and now 1.7.2 x64 and whatever I do I still have distorted and crackling, not nice sound (see https://www.youtube.com/watch?v=r3FrfZ0a3hw ).

In log while the game is running, this is being spammed:
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred

My config.cfg in WTF folder begins with:

SET gxApi "opengl"
SET ffxDeath "0"
SET SoundOutputSystem "1"
SET SoundBufferSize "150"
SET MasterSoundEffects "0"

I am running ubuntu (x64) 13.10.

$  lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)

My notebook is Aspire 5750G.

Can anyone help me?
Thanks a lot...

Edité par max007

max007 Lundi 25 Novembre 2013 à 21:59
max007Anonymous

It seems that after few days i finally fixed it with  this https://bbs.archlinux.org/viewtopic.php?id=116172&p=1 ! :) 

Edit: NOPE, still bugged
Edit2: Sound works after reboot buts get bugged after a while (needs further testing)
Edit3: After about half an hour sound becomes buggy again and it is needed to reboot. Wheres the problem?
Edit4: I raised up volume and it raised also PCM, so i lowered it back to lower values and the sound works! Is there any way how to tell pulse audio not to raise PCM?
Edit5: Nope, that didn't fix it, sound still doesn't work

Edité par max007

booman Mardi 4 Février 2014 à 19:31
booman

I'm having this exact same problem in Mint 16 (based on Ubuntu 13.10 Saucey)
I'm currently researching this problem as I have seen it pop up in many posts.

Were you ever able to figure it out?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
allenskd Mardi 4 Février 2014 à 19:41
allenskdAnonymous

@booman. I have been trying to pin it down. So far all the indications for me is that it has something to do with pulseaudio.

I've been playing GW2, its really been stable, but when it meets the underrun? the thing starts consuming a lot of CPU.

One of the things I've been meaning to try is this How-To

http://wiki.winehq.org/WineAndPulseaudio

Which forces WINE to use ALSA directly. If it turns out that it solves the issue, it'd be nice if PoL could handle the abstraction (at least on setting variables part)
booman Mardi 4 Février 2014 à 19:50
booman

Great! Thanks for posting.
I'm having the exact same problem with Borderlands 2 and Two Worlds.
I will definitely try forcing Alsa directly with Wine.
At this point anything is better than how its performing.

I'm hoping Mint 17 will have better solutions for pulseaudio.
Honestly with Mint 13 and 14 I never had sounds issues. specially with Wine.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained