Forums

Adobe Flash

Auteur Réponses
nivlop Lundi 2 Décembre 2013 à 23:15
nivlopAnonymous

Salut à tous,

Aucun des scripts d'install des composants Flash ne fonctionne. Les URLs ont toutes changées.

Voici la correction pour POL_Install_flashplayer et POL_Install_Flashplayer_ActiveX, mais pour POL_Install_Flashplayer_Others, pour moi il s'agit de la même version de Flash (celle pour les autres navigateurs que IE) sauf que l'URL est générique. Or, cette URL générique ne semble plus exister.

Bref, voici les 2 scripts :

POL_Install_flashplayer :

#!/bin/bash
# Date : (2010-14-11 21-00)
# Last revision : (2013-12-02 21-09)
# Only For : http://www.playonmac.com
# RealName: Flash Player

# CHANGELOG
# [VV] (2013-12-02 21-09)
#   Update script (link broken)

# [Quentin PÂRIS] (2012-11-21 18-19)
#   Update script (link broken)

# [SuperPlumus] (2012-05-18 06-42)
#   Update script (broken)
 
cd "$POL_USER_ROOT/ressources"
POL_Download_Resource "http://fpdownload.macromedia.com/get/flashplayer/pdc/11.9.900.152/install_flash_player.exe" "a178da64fd1f1031d965175cbbc7f481"

POL_Wine_WaitBefore "Flash Player"
POL_Wine "install_flash_player.exe"
POL_Wine_WaitExit "Flash Player"

Pour POL_Install_Flashplayer_ActiveX, j'ai remplacé POL_Download par POL_Download_Resource et retirer la suppression de l'installeur après l'installation:

#!/bin/bash
# Date : (2011-07-13 21-00)
# Last revision : (2013-12-02 21-09)
# Author : GNU_Raziel
# Only For : http://www.playonmac.com

# CHANGELOG
# [VV] (2013-12-02 21-09)
#   Update script (link broken)

# [SuperPlumus] (2012-05-18 06-31)
#   Update script (broken)
 
# Downloading Flashplayer for ActiveX (Internet Explorer Only)
cd "$POL_USER_ROOT/ressources"
POL_Download_Resource "http://fpdownload.macromedia.com/get/flashplayer/pdc/11.9.900.152/install_flash_player_ax.exe" "8a56647fab4555a90ce51a3b9891c8d8"
 
POL_Wine_WaitBefore "Flash Player"
POL_Wine "install_flash_player_ax_32bit.exe"
POL_Wine_WaitExit "Flash Player"

J'ai testé l'installation, j'avoue que je n'ai pas tester que les plugins fonctionnaient.
Dites moi si ça vous va !

Vincent

PS : Quelle est la balise pour indiquer qu'il s'agit de code source sur ce forum ?

Edité par nivlop

petch Mardi 3 Décembre 2013 à 0:16
petch
Développeur

Bonsoir nivlop, et merci pour le coup de main, j'ai mis à jour les deux scripts.
Je n'ai pas trouvé de mention de POL_Install_Flashplayer_Others dans des scripts (à part dans le script de Safari, où il est commenté), je l'ai donc dés-enregistré.


PS : Quelle est la balise pour indiquer qu'il s'agit de code source sur ce forum ?

Citer


C'est {code language=playonlinux} ... {/code} en remplaçant les accolades par des crochets.

A+,
Pierre.

Vous êtes ici: Index > Vos créations > Adobe Flash