Randomly Started Segfaulting - Please help?

After some normal upgrade, app segfaults wine.lib line 483

Auteur Réponses
Hazey11 Mardi 7 Janvier 2014 à 3:40

Hey all, hopefully someone here can help as I have been fighting with this issue for probably over a month or two now :[ I have provided a bunch of detail and logs as well as what I've tried thus far, it shouldn't matter if you have never heard of/never used/etc the specific program causing the issue - at least I hope ha. Anyways, here we go...

Kayako Desktop, current version has always worked fine under PlayOnLinux, I follow the Wine AppDB and install those 3 libraries, select the setup, install, and seems to all go fine. This worked for months and months and months with NO issue, however somewhere along the line an upgrade or who knows what interfered and now it segfaults whenever I try to go online and I can NOT get it figured out... I have the same distro on my laptop with the same playonlinux and setup the same way and that works fine/no problems. SO it's obliviously something on this computer but I have tried just about everything and cannot get it resolved or figured out... It probably started segfaulting a month or two ago and the install works fine, I can even launch it (if I select do NOT auto login at program startup during install) and all seems good, but as soon as I select "Go Online" or try to log on it crashes (logs below). I have mostly the same software (and not much really) on my laptop + desktop, but there are some differences, however can't really get all those as may be a bit extensive.

I have tried COMPLETELY uninstalling POL + Wine and that includes deleting the ~/.PlayOnLinux dir and everything else I could find anywhere and everywhere else for both POL and Wine, reinstalling from scratch but get the same thing - segfault when it is logging on. up until probably 2-3 weeks ago I was able to get it started and working via starting POL from a terminal, for whatever reason that would not segfault when I tried that way but would when started normally via KDE App launcher - however that apparently stopped working at some point as now nomatter launching via command line or via app launcher it does the same.

Details & Logs:

Terminal Window running POL log (no debug):

WITH DEBUG ON: (terminal and POL debug log)

Full POL Debug Log + Terminal Log (with debug on) from start to finish of a startup (fine) - go online (segfault):

Running Arch Linux x64, up to date.
POL 4.2.2
Kayako Desktop (worked fine prior/no change there)
KDE 4.12 (also affected KDE 4.11 at least)
Kernel 3.12.6 (also affected 3.12.x at least, may have also 3.11.x)

POL VirtualDrive/App Settings:
Wine Version: System (1.7.10 - also tried 1.7.0, 1.6 and others at random)
Debug flags: (none)
Arguments: (none)
Display Config: all default

[edit]Also worth noting winetricks is installed alongside wine but I have not tried wine directly. Furthermore another edit below to list some of the libraries I have installed which were recommended with wine (I've gotten them all lol). I also do have the lib32 graphics drivers/etc

During App Install via POL only selected to install libraries which were: ie8, gdiplus, vcrun2008 (also tried selecting different wine versions as well as configuring and playing with some settings ie setting to Windows 7 and so on but same result).

Laptop is the exact same as above, only hardware differences (laptop is lesser and on an intel integrated graphics). Desktop Specs are:
Core i7 Quad Core 3.something
Nvidia Geforce 660 GTX (4 monitors)
On Intel Fake Raid controller (mobo) for now, Raid 10

[edit]libraries recommended with wine that are installed:
giflib [installed]
                 lib32-giflib [installed]
                 libpng [installed]
                 lib32-libpng [installed]
                 libldap [installed]
                 lib32-libldap [installed]
                 gnutls [installed]
                 lib32-gnutls [installed]
                 lcms [installed]
                 lib32-lcms [installed]
                 libxml2 [installed]
                 lib32-libxml2 [installed]
                 mpg123 [installed]
                 lib32-mpg123 [installed]
                 openal [installed]
                 lib32-openal [installed]
                 v4l-utils [installed]
                 lib32-v4l-utils [installed]
                 libpulse [installed]
                 lib32-libpulse [installed]
                 alsa-lib [installed]
                 lib32-alsa-lib [installed]
                 libjpeg-turbo [installed]
                 lib32-libjpeg-turbo [installed]
                 libxcomposite [installed]
                 lib32-libxcomposite [installed]
                 libxinerama [installed]
                 lib32-libxinerama [installed]
                 ncurses [installed]
                 lib32-ncurses [installed]
                 libcl [installed]
                 lib32-libcl [installed]
The only 2 I do not have is alsa-plugins and lib32-alsa-plugins, never had prior of course and was working fine but I installed most of the libs just to give it a shot.

Laptop is 8GB ram, Core i5 low 2ghz quad, intel integrated (from i5) graphics, software raid, etc.

Please hopefully someone out there has an idea or ANYTHING I could try to get this figured out and resolved :( Finally posting after a LONG TIME of researching and trying various things just can not get it figured as is very very weird. And quite literally have all the same applications for the most part on both desktop/laptop, however drivers/libs/etc vary. 

Last notes: I noticed earlier it said something about wav_player.c /usr/..../wine.lib segmentation fault - maybe it has something to do with wav's (only when debug OFF in terminal) but it's not showing under the termiinal or logs anymore (debug on/off) for some reason? Before trying to do "Go Online" I opened the application and went into settings and unchecked all the sound files/etc (and was that way during all the logs above) however I believe it still initializes the device or something of that sort. Also mentioned I tried configuring wine to use 1.6/1.7.x/etc to no avail, as well as configuring wine to emulate Windows 7/etc but same result. Just reaffirming when removed POL & Wine/Mono/Gecko I used locate to find everything I could find that was left over from the full removal (pacman -Rsn (apps)) and deleted it, .PlayOnLinux in home dir, etc. but no avail either. 
[edit]Last last note is I also noticed a while back (may still be in the logs but think may have resolved after latest wine upgrade or something) it was giving an error about msxml3 not being able to load, I even tried installing manually under the VD but did not seem to make a difference (gave an error) however that seems to be resolved at quick glance through the logs (unless I missed it - so burnt out of these logs lol)

Again ANY IDEAS are VASTLY appreciated, have used POL for many years and never experienced something like this - very very weird. Thanks for your time guys and girls and hopefully someone out there can help me get this figured/looked into/debugged and ideally resolved! Thanks,

Edité par Hazey11

Daerandin Mardi 7 Janvier 2014 à 22:09

First of all, I just want to say that I don't have any basis for my little shot in the dark here, but I'll still throw it out.

You mentioned this started a couple of months ago maybe, and you have an nvidia gpu. With the 331.20 nvidia driver, people started experiencing many different issues, which also seem to vary from system to system. Common issues have been: browsers segfaulting or just crashing without any error and zombie processes cropping up with time. A few rare reports have mentioned display managers failing to start, and certain applications crashing. The only common thing is that downgrading to the previous nvidia driver fixes the problems for everyone.

Like I said, this is just a shot in the dark but I figured I would at least mention it. It just seemed to coincide with your issues starting about 2 months ago, which is when the 331.20 nvidia driver was released in the official arch repos. Nvidia devs have reported on the dev forums that they have solved many of these issues in the next driver which will be available soon.