yWriter hangs after object add

Auteur Réponses
vegivamp Mardi 7 Janvier 2014 à 18:06

Hey there,

I just installed
yWriter, and it installs and starts fine, but when I create a new
project and then add an object (I tried a chapter, character, location
and item), after clicking OK it adds the new object, but then appears to
lock up. All menus are greyed out, and the tab pages don't respond.

the window around and maximise/restore still works. I also note the
window decorations are incomplete after the OK (but there when the
program starts), I only get the max/restore button.

Adding a new
scene, project note does work as expected, and after I kill the program,
when I re-open the project file, the added data was saved OK.

The same behaviour occurs when editing one of the previously added objects.

I've already tried adding comctl32 and comdlg32ocx DLL mappings, as they
are requirements per the yWriter site; and tried switching to the
latest Wine (1.7.10) to no avail.

This is on Linux Mint 15 XFCE 64-bit. I also confirmed this on another computer, same distro, fresh PlayOnLInux install - it shows identical behaviour.

Any help in solving this would be most appreciated. I'll attach the debug log, too.

Thank you,
vegivamp Mardi 7 Janvier 2014 à 18:09

The logfile is rather sizeable, with all my testing :-) I stuck it in Pastebin, to avoid polluting the thread: