Forums

Mortal Online

Auteur Réponses
TheSickining Mardi 21 Janvier 2014 à 1:19
TheSickiningAnonymous

I'm trying to run Mortal Online through PlayOnLinux, as expected I am having trouble getting it to work. Here's a run through of how I am trying to get it to run:

1.) I go through the manual installation

2.) Install a Program in a new virtual drive

3.) Select install some libraries

4.) Here is where I start to get a bit confused, I've tried both 32 and 64 bit installations, and I can't figure out which is better to use. I am running a 64 bit system. For now, I'm going to install 64 bit.

5.) I install "POL_install_mono210" since it doesn't seem to work without Mono for Windows.

6.) I find the MOSetup.exe for installation

7.) It starts up the .exe

8.) The installation goes fine until .NET 3.5 goes to download, I get the error "The program PrintFilterPipelineSvc.exe has encountered a serious problem and needs to close." WINE tells me that this can be caused by a problem in the program, or a deficiency in WINE.

9.) Installation of .NET 3.5 works until the end, where I get another error telling me "Microsoft .NET 3.5 has encountered a problem during setup. Setup did not complete correctly."

10.) Trying to run MO doesn't work, and the debug tell me "- Running wine- Mortal Online Launcher.exe (Working directory : /home/thesickining/.PlayOnLinux/wineprefix/MortalOnline/drive_c/Program Files (x86)/Star Vault/Mortal Online)
fixme:x11drv:sync_window_opacity LWA_COLORKEY not supported"

At this point, I have absolutely no idea what I should do, any help is appreciated.
petch Mardi 21 Janvier 2014 à 13:02
petch
Développeur

Use dotnet35 component to install .NET 3.5
And it does not support 64bit installation.
TheSickining Mardi 21 Janvier 2014 à 18:38
TheSickiningAnonymous

I will check that out, and see I can get it to work. Thanks for the reply.
booman Mardi 21 Janvier 2014 à 19:34
booman

When you install dotnet, make sure to use Wine 1.5.18
I have found that this version of Wine doesn't not crash or error when installing dotnet.
Then you can change the wine version back to the current one.

Also, I always use 32-bit virtual drives. Even if you are using a 64-bit Distro, 32-bit is what most game are compatible with.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
petch Mercredi 22 Janvier 2014 à 1:09
petch
Développeur

dotnet35 script has been fixed 10 days ago to support newer Wine versions
TheSickining Mercredi 22 Janvier 2014 à 4:04
TheSickiningAnonymous

I tried the installing the dotnet component, and I'm getting more errors. I think I'm gonna let it rest a bit, and figure out POL a little more before trying Mortal Online again. Since it's not a supported title I imagine it's going to take some tinkering to figure out the proper way to get it working.
booman Mercredi 22 Janvier 2014 à 17:30
booman

Not a bad idea.. try some easier games like Drakensang.
I have a step-by-step guide here at GamersOnLinux.com
I can download and install Drakensang in about 10 minutes and you are in-game playing

Edité par booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Vous êtes ici: Index > PlayOnLinux > Mortal Online