Far Cry

Cannot get the game to work

Auteur Réponses
horsemanoffaith Mercredi 22 Janvier 2014 à 6:37

I have written a script to load Far Cry into PlayOnLinux, and I had the game working on my test system at the time (Ubuntu 12.04.1 LTS 64-bit). I have attempted to load Far Cry on my Arch system, and nothing I do works. I have used my script, I have used Booman's Far Cry walkthrough, and I even paid for Far Cry through Steam, and I cannot get the game working. I have a copy of the script saved to my computer, and I would post it here, but I don't want to take up a whole bunch of room doing so. The script was pretty simple- I used Wine version 1.4.1, copied all the files from each disc one at a time, chmod'ing (777) the files after they were copied, then running the setup.exe from the temp directory. When I launch the game, I hear the game disc being accessed, see the splash screen, then the game crashes. It doesn't matter what version of Wine I use- every one I have tried has crashed. What's strange is when I check the debug file, there is no error. I have even tried running the executable from the Miscellaneous tab on the Configuration page in the PlayOnLinux window, and I get an error saying that a dll file is missing. When I check the virtual drive for that dll file, the file is there. When I run Far Cry through Steam, the game just doesn't start at all. Can you guys help me get this game running again? I've got LOTS of my games working on my desktop- more games than most of the other Linux installs I have done in the past, and I want to keep all my games there. Here's my system specs:

Arch Linux 64-bit using the latest version of the Cinnamon desktop
Linux kernel
AMD FX 4300 Quad-core
nVidia GT 640 2GB
8GB system memory
POL version 4.2.2
Wine versions tested: 1.4.1, 1.6.2, 1.7.8, 1.7.9, 1.7.10

I may have tested other Wine versions, but I'm not sure. I do not currently have any Far Cry files installed on my computer. Help getting this game working would be greatly appreciated!!!

Edité par horsemanoffaith

booman Jeudi 23 Janvier 2014 à 0:07

Steam is a whole other world for Far Cry. There has been a recent update that breaks all wine versions except 1.6.2 and 1.7.8 or newer.
So if you use Steam, make sure to use these versions of Wine only.
On top of that, a new update is causing the overlay to break launching games in Steam.
So make sure to go to Settings, in-game, uncheck "community" which is the overlay.

I have seen this problem very recently with any version of Wine. Games just can't launch.

My manual installation guide is pretty old and was only for the retail version, but GOG has a DRM free version that may prove to be more consistant.

Don't forget the OpenGL configuration in system.cfg
That was critical to get Far Cry running.

I have a few questions:
1. Can you run any other games on your computer?
2. Have you installed 32-bit libraries for game compatibility?
3. Do you have the Nvidia proprietary drivers installed?

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
horsemanoffaith Jeudi 23 Janvier 2014 à 5:18

I found out about the Steam issue the hard way... I had to play with the Wine versions until I found the versions that would allow me to launch Steam. As a matter of fact, Portal 2 won't work correctly (at least on my computer) unless I use 1.6.2. Use any other version and the game crashes as soon as you touch anything on your keyboard.

I have the retail version- the same one that you talked about in your walk-through... the 5-disc CD set. Still doesn't work. I followed your walk-through to a T, and nothing.

In answer to your questions- Yes, Yes, and Yes LOL. I have 16 games installed in PlayOnLinux, and they all work, even though I have had to do some tweaking to get them working. One of the problems I am currently having is that I can't play Bioshock full-screen- I can't keep rotating 360*... my character will stop both ways at one point. Changing the settings for mouse warp override does no good in POL. I have found that it does work properly using the Windowed mode, but I don't like the desktop bar at the bottom of the screen. It's tolerable, but I would prefer not to see it. I will have to try 1.6.2 to see if I can get Bioshock working correctly.

Arch supports nVidia proprietary drivers in the main repos. I am currently using 331.38-2. According to Arch's package site, this is the latest driver for nVidia. I just confirmed that 331.38 is the most current version on nVidia's site, as well. I will be messing around with Far Cry again soon. I have a large number of my games installed... there are only a few that I have left that I want to get up and running if I can. I will see what I can do over the next few days.
horsemanoffaith Dimanche 26 Janvier 2014 à 11:41

Hey Booman!!! I got Far Cry to work!!! I copied all of my disks to my hard drive, installed Far Cry on a 64-bit (yes, 64-bit) prefix, installed the game, downloaded the 64-bit patch and installed it, and whammo, the game runs like a champ- even when I have everything maxed out for video. I can play it 32-bit or 64-bit. The only issue I am having is some minor stuttering from time to time... and frequent swearing when I get blown to bits. Even on easy the game isn't very easy. I have died so many times already! I was unable to get the game running any other way, at least so far. I think I have to find a REAL no-cd crack (many of the ones that are online are bogus- they are cracks that you have to have someone's .iso file for) to get the game functioning... not sure why it doesn't work with the CD... it could have something to do with Arch LInux, because the CD directory isn't the same as Ubuntu/Linux Mint. I'm not sure why it doesn't work, but I'll try installing on Ubuntu and see if I can get it to work. That was the OS I originally had it working on to start with. We'll see what happens. At least I can play the game again!!!
booman Dimanche 26 Janvier 2014 à 17:48

Great! I"m glad you got it working! Thanks for sticking with it!
I still wonder if the GOG version will have problems or not?

I forgot to tell you that any older version of Wine crashes Steam. 1.6.2 and 1.7.8+ works just fine.

I can't belive the 63-bit patch worked! That was unexpected.

As for Bioshock, are you using a virtual desktop in Wine?
I use virtual desktop for every game. The mouse should work fine and you can still set the game for full-screen.

Let me know if you need help with it.

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
petch Dimanche 26 Janvier 2014 à 22:17

There's a script to install the GOG version.
horsemanoffaith Lundi 27 Janvier 2014 à 7:47

Yep, I am the persistent sort. I found out about Wine versions and Steam the hard way- I was trying to use Steam and it kept crashing. I downloaded all of the 1.7 Wine versions and tried all of them... found out exactly what you told me. I found your post about stable Wine and used it for Portal 2. It's the only Wine version I can get the game running on. Any button presses on the keyboard on any other Wine version causes Portal 2 to crash. I have got Bioshock working full screen again... I think I went to Wine 1.6.2 and changed mouse warp override to force and it's working now. I don't use the virtual desktop because I seem to have Steam log-in issues when I do. What I do now for Steam games is I create a new prefix (and new Steam install) for any new game and fiddle with it until I get it working. If I find a bunch of Steam games that run with the same settings, I'll group them together in a single Steam prefix. If there is anything special I have to do, I leave that game by itself. It makes things WAY easier!
Daerandin Lundi 27 Janvier 2014 à 15:35

Steam games crashing on wine 1.7.8 is caused by the most recent Steam update now in January. Games will work again if you disable the Steam overlay. This can be done in Steam settings, but I experienced some problems with games exiting when I disabled it this way.

Another way to disable Steam overlay that works better in my experience, is to enter wine config, and add a custom library named "gameoverlayrenderer", then select the newly added library, and click on Edit. Set it to "Disabled".

If I don't have it disabled, games either crash as soon as I touch the keyboard, or as soon as I continue game progress.
booman Lundi 27 Janvier 2014 à 18:57

Ditto here.
I've had the same problem with the "in-game" community overlay.
Daerandin's suggestion works perfectly!

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
greencopper Dimanche 1 Mai 2016 à 23:32

I haven't been able to get it installed no matter what Wine version I am using. During installation it always halts at "Please insert the disk: license.txt", however all files are located in the directory.

Update: I did a touch "license.txt" and eventually got it installed, but graphics are messed up.

Edité par greencopper

Vous êtes ici: Index > PlayOnLinux > Far Cry