Forums

[Script] Hearthstone

Auteur Réponses
Jump to the page: 1 - 2 - 3 - 4
Balfuset790 Dimanche 8 Juin 2014 à 22:05
Balfuset790Anonymous

Okay, so I've run into a small issue that I was hoping someone could help with.

USing the second script the game isntalled fine, and Battle.net itself runs. However I have the issue as screencapped previously with it claiming that the agent has gone to sleep and needs to be woken.

NAvigating through the POL shell I got to where the Agent.exe file is and when I try to run it I get the following error

bash: ./Agent.exe: cannot execute binary file

Any thoughts on this?
TheEvilPancake Dimanche 15 Juin 2014 à 19:33
TheEvilPancakeAnonymous

Wanted to give you the solution few days ago but was doing something and forgot. Anyway just open the directory of hearthstone through pol and run hearthstone.exe, the game will say that you need to run battlenet.exe (exe that you oppened will be useless and you can just close it by clicking on the notification you got in hearthstone.exe) to run it and battlenet will just run itself , then just type your username and password, for some reason I didn't click on remember me (superstition?) and when you enter battlenet just click on play ( as you'll be in hearthstone tab right away) in next few seconds cause battlenet will crash pretty soon but the game will work, I play like this for some time and it works everytime.

That solves the agent is sleeping problem and I hope you won't have further issues running the game.

neowiz73 Mercredi 18 Juin 2014 à 20:23
neowiz73Anonymous

I have discovered the default shortcut is running the wrong .exe, the proper one to be using is in /Program Files/Battle.net/Battle.net.Launcher.exe

I simply just created a new shortcut in POL to point to that .exe and just run that shortcut when i want to play. you don't get the sleep error.

Edité par neowiz73

Hobbypunk Lundi 23 Juin 2014 à 16:28
HobbypunkAnonymous

Hello,

 

i've a little problem, since a few days i get a error message when i try to start Hearthstone: "The game crashed. The crash report folder named "bla bla" next to game executable. It would be great if you'd send it to the developer of the game!"

i tried to reinstall Hearthstone with and without the POL Script and with nearly any wine version, but nothing helped :-/

Here i pasted the crash report, i hope anyone of you can help.

 

Greets,

Marcel

Undischargedd Lundi 30 Juin 2014 à 1:32
UndischargeddAnonymous

Hello,

I tryed to use this script to install Hearthstone but it just stays there on "What language do you want to install"? with no options, and no next button, please help!

I'm running Debian Wheezy 7.1 with the newest version of POL

Here is a picture of it:

http://imgur.com/wFuSYzQ

Garve Mardi 1 Juillet 2014 à 14:02
GarveAnonymous

Ok the OP script works, but I have to add -nohttpauth to the argument field in the configuration.

Edité par Garve

kweepeer2 Jeudi 24 Juillet 2014 à 17:17
kweepeer2Anonymous

Sorry that many people are having problems running this game, but it is a pain to run in Linux actually, as it witnessed by the "garbage" rating on winehq appdb: https://appdb.winehq.org/objectManager.php?sClass=version&iId=30038

It worked ok in beta, but since then compatibility has regressed as they patched the game.

At this moment I am unable to even run the game since the game times out on startup.

Slightly off-topic but I wish Blizzard would just release a Linux version, it's a Unity game so it's not impossible.

Sabbasth Lundi 28 Juillet 2014 à 14:07
SabbasthAnonymous

 

I have discovered the default shortcut is running the wrong .exe, the proper one to be using is in /Program Files/Battle.net/Battle.net.Launcher.exe

I simply just created a new shortcut in POL to point to that .exe and just run that shortcut when i want to play. you don't get the sleep error.

 

Quentin PÂRIS Mardi 29 Juillet 2014 à 12:44
Quentin PÂRIS
Admin

Does someone want to post a script here? http://www.playonmac.com/en/supported_apps-1-0.html

kweepeer2 Mercredi 30 Juillet 2014 à 20:12
kweepeer2Anonymous

I'll submit new version in a few hours. I have some info too on the time-out issues thanks to Reddit, should be able to fix it.

kweepeer2 Mercredi 30 Juillet 2014 à 21:05
kweepeer2Anonymous

New version submitted, it should be up once approved: http://www.playonmac.com/en/app-1950.html

 

It should work a whole lot better. I have not done extensive testing but enough to know that it should fix some previous issues.

 

Changelog:

- Readded dbghelp & msvcp100 overrides.

- Cleaned up code.

- Modified launcher target "Battle.net Launcher.exe" instead of "Battle.net.exe" (thanks Sabbasth).

- Added flash player install, seems needed for some people and doesn't hurt.

Edité par kweepeer2

kweepeer2 Mercredi 30 Juillet 2014 à 21:06
kweepeer2Anonymous

Btw, if someone wants to submit images and icon, feel free... If not, I will get to it some day :D

EwanRGR Lundi 1 September 2014 à 15:48
EwanRGRAnonymous

I am having an issue trying to install on U14.04 where it gets to loading Battle.Net in the install and then hangs at 53% each time. I've tried removing the PlayOnLinux drives and even uninstalling and reinstalling and keep getting the same issue. Also, would it be possible to upgrade the script to use Wine 1.7.25 which appears to have several bug fixes?

 

EwanRGR Lundi 1 September 2014 à 16:07
EwanRGRAnonymous

So I just tried running the Hearthstone installer directly under Wine, and it stops in the same place but shows that it is encountering error 2600 (Battle.net error) if that helps in debugging.

EwanRGR Lundi 1 September 2014 à 16:39
EwanRGRAnonymous

Tried the -nohttpauth suggestion from earlier in the thread but I get several fixme messages that imply that the "get_system_proxy_autoconfig_url" is not supported on this platform. Tried this under both 1.7.15 and my normal 1.7.25. 

EwanRGR Vendredi 5 September 2014 à 3:24
EwanRGRAnonymous

So am I basically just SOL on this?

kweepeer2 Vendredi 5 September 2014 à 9:55
kweepeer2Anonymous

Which version of the script are you using? The one directly from POL I hope?

On your manual attempt, the error 2600 (Battle.net error) is probably because you did not do the dll overrides. I suggest you read the source of the POL script or follow winehq appdb notes if you want to do manual installs. But please note that there is a good reason we didn't update the Wine version higher than 1.7.15 because the newest versions will give timeout problems when connecting to the game once you have it installed.

Sorry I can't be of more help.

DrAnax Samedi 27 September 2014 à 15:11
DrAnax

For people encountering the "Error In POL_Shortcut", here's what I did:

  • On the screen with the error, just press 'Next'
  • Press "Configure"
  • Click "hearthstone" on the left
  • On the "General" tab, click "Make a new shortcut from this virtual drive"
  • Click "Hearthstone Setup.exe"
  • Press "Next" twice and then click "Cancel"
  • Close the "PlayOnLinux" configuration window
  • Click the "Hearthstone Setup" icon on the main window and choose run

I'm still installing the game, so I don't know how it will go from that point on.

lorenafavario Vendredi 17 Octobre 2014 à 19:02
lorenafavarioAnonymous

Hello everybody:

I dont know if this is the right place for this cry for help but since I started all this with Hearthstone installation maybe u guys can give me some help.

I installed Hearthstone using the script provided from Playonlinux (the ones listed in the program), everything worked fine I love the game and ofc playonlinux did everything automatically.

So, because it installed battlenet client too, I decided to give wow a try. (the new wow, the one u get from battlenet, i think its 6.0.2 Warlords of Draenor). The games runs but i have 6fps and its horrible to play.

I read about the OpenGL trick and things like that to tweak it but...... Since its in the same installation/folder as Hearthstone if i change something maybe its going to affect the game.

Plus, wow doesnt show up in my list of games installed with playonlinux. So no way to touch anything.

I read that wow works perfect with last wine version but dont know if its the same hearthstone uses.

What should I do? unistall and reinstall again in a separated playonlinux installation? or i can fix the FPS anyway using your expert help? Please help me, my brother gifted me a retail suscription and I cant play it well.

Thanks in advance - Lorena from Argentina

lorenafavario Vendredi 17 Octobre 2014 à 19:21
lorenafavarioAnonymous

Sorry BTW this is my computer - Is it ok to play new World of Warcraft

Operating System - Ubuntu 14.04 TRUSTY (i686)
Cinnamon Version - 2.3.0
Linux Kernel - 3.13.0-27-generic
Processor - Intel Core 2 Duo CPU    E4600  @ 2.40GHz x 2
Memory - 2.0 GiB
Hard Drive - 678.5 GB
Graphic Card - Advanced Micro Devices, Inc. (AMD/ATI) Park (Mobility Radeon HD 5430) (prog-if 00 (VGA controller))

When I search on additional drivers I can see that 1 proprietary driver is in use:
Using Video driver for the AMD graphics accelerators from fglrx-upfates (proprietary) IS SELECTED