[League of Legends] Game Crashes after the game start

Auteur Réponses
Nastrand Mercredi 12 Février 2014 à 17:02


Yesterday i downloaded League of legends for first time using the playonlinux installer, for all the night it ran updates for the game, and now i've the game installed.

The problem happens when i try to start a game, any game, i can select the champion, the LoL logo appears and the charge screen too, the game stuck in the charge screen for about two or three minutes, and after that start the game. But it only run correctly for a few seconds, i mean, the game start and i can see all in my screen (HUD, textures, animations) but after a few seconds everything stops and stay like a picture.

I can still hear the background music of the game, and i can move the mouse, but the FPS stays at 00 or 01 and the timer in the corner dont change, i tryed to wait for about 15 minutes and stay freezed, in the basic tutorial the game ran to 20-30 seconds approximately, but i start seeing the game when its in 18 seconds.

Im using Manjaroo 0.8.8 64-Bits with XFCE and all the updates installed, i tryed to run the game under 1.5.24-LeagueOfLegendsShop, 1.5.18-LeagueOfLegends, 1.5.12-LeagueOfLegends, 1.5.12-LeagueOfLegendsShop and is the same output everytime.

My video drivers are video-catalyst-legacy, the computer has a Phenom II at 3.0, 4 GB RAM, in this same computer with this distribution i've ran Dota2, World of Warcraft: Wotlk at max and World of Warcraft: Cataclysm, so i don think its related to the configuration.

Here are the output of the debug log:

Also i've tried to do this: and after doing everything that said there, i get a Black Screen after the League of Legends logo after the champiosn select, so i've to reinstall everything this morning, including POL and now i'm back to the problem described before.

Ive changed the wine emulation to win XP and win 7, same results, i've edited my /etc/hosts file and put the correct config and still the same, also i tryed to enable, disable and let to default the GLSL and still the same.

Sorry if i missed any info, and sorry for the bad english

BlondVador Mercredi 12 Février 2014 à 18:29


Edit your /etc/hosts file and put your hostname instead of local there.

My case :
default:     localhost.localdomain     localhost


edited:     localhost.localdomain     arch


arch is my hostname.

Nastrand Mercredi 12 Février 2014 à 18:32

Hello, i've already done this     localhost.localdomain          equipo

equipo is my hostname. Thanks for your answer

EDIT: I forgot to mention this doesn't solve my problem

Edité par Nastrand

Nastrand Lundi 17 Février 2014 à 1:11

I dont want to be anoyin, but someone can help me? im still searching on google and didnt found nothing yet

BlondVador Lundi 17 Février 2014 à 9:02

I using ArchLinux, not Manjaro, and i've no problem. Everything work nice.

You can try to reinstall Adobe Air components but I promise nothing :x.

Nastrand Lundi 17 Février 2014 à 18:08

Thanks BlondVador

Two questions: Adobe Air components, mean installing it from the components menu in POL?

And, did you use ATI Graphic card? if it is, what driver did you use?
BlondVador Mardi 18 Février 2014 à 8:09

Yes, from the components menu in POL ;).

No, I've nVidia GTX 660M.

Motoko Mardi 18 Février 2014 à 21:06

hello i am trying to find my /etc/hosts so i can change local to my hosts name and i can not find it nor anything online on where to find it is it possible for someone to explain where it is exactly or post a link that might help me find it?

Thank you very much in advance :)
Nastrand Mardi 18 Février 2014 à 23:28

Hello, the file hosts is inside the etc folder. If you cant find it try to write no the terminal this:

sudo gedit /etc/hosts

and put your password.

Also: I tried reinstalling Adobe Air and there is no change.

Edité par Nastrand