Forums problem

Agent went to sleep

Auteur Réponses
AzadKV Jeudi 3 Avril 2014 à 15:32


I installed client on my POL.
When I launch it, it says: "Agent went to sleep, attempting to wake it up ..."
And does nothing.

I tried this with dbghelp "disabled" and "native, builtin"
Wine version: 1.6.1
Linux: UbuntuStudio 13.10 x64

Please help.
izberion Jeudi 3 Avril 2014 à 17:30

I've got the same problem. I keep trying until it works.

I just got it working. Wine 1.7.14

Though most of the time the client pops up and gets stuck on Loading Account Information

Edité par izberion

apT Vendredi 4 Avril 2014 à 22:34

Having the same issue..

Edité par apT

apT Samedi 5 Avril 2014 à 3:08

Here is the last page of debug:

Database Remove: /agent/download
Deferred delete of 'download' Resource
Deferred delete of 'download' Resource completed
Queue 'download' Resource for delete
Queue Request for : handle - 0x00d88760, index - 3, running - 0
Deleting remaining resources
OnComplete: handle - 0x00d88760, result - 0, running - 1, request - found
Cleanup: total requests process - 4
I 2014-04-05 00:57:01.939428 [Browser] {} Opening URL externally instead of navigating due to whitelist: cef-error: browser=ConnectScreen
I 2014-04-05 00:57:02.337706 [Browser] {} (20):Injecting javascript into page: cef-error: readyState: complete
I 2014-04-05 00:57:02.339200 [Browser] {} (17):Executing injected javascript: cef-error:
I 2014-04-05 00:57:32.213595 [Browser] {} Opening URL externally instead of navigating due to whitelist: cef-error: browser=ConnectScreen
fixme:win:FlashWindowEx 0x33d380
W 2014-04-05 01:05:43.782691 [Agent] {Agent} Transport method changed to NamedPipe
D 2014-04-05 01:05:43.849791 [Main] {Main} Shutting down game provider
D 2014-04-05 01:05:43.850845 [Main] {Main} Shutting down engine
I 2014-04-05 01:05:43.851258 [BattlenetAPI] {Main} Forcibly disconnecting from
E 2014-04-05 01:05:43.852246 [BattlenetAPI] {Main} Disconnected from err= (60) connectionId=1
D 2014-04-05 01:05:44.025243 [Main] {Main} Shutting down callback queue
D 2014-04-05 01:05:44.031651 [CacheManager] {Main} Stats.TasksQueued: 261
D 2014-04-05 01:05:44.032417 [CacheManager] {Main} Stats.TasksCompleted: 261
D 2014-04-05 01:05:44.032984 [CacheManager] {Main} Stats.CacheWrites: 59
D 2014-04-05 01:05:44.033482 [CacheManager] {Main} Stats.CacheReads: 132
D 2014-04-05 01:05:44.033979 [CacheManager] {Main} Stats.CacheMisses: 60
D 2014-04-05 01:05:44.034662 [CacheManager] {Main} Stats.FilesReadFromArchive: 15
D 2014-04-05 01:05:44.035414 [CacheManager] {Main} Stats.FilesDownloads: 59
fixme:win:FlashWindowEx 0x33cb60
apT Samedi 5 Avril 2014 à 3:12

I will try anything to get this running.. and provide any information I can, just let me know.. and how..

running wine 1.6.1
PlayOnLinux 4.2.2(using wine 1.6.1 and 1.6.2 and 1.7)
on Linux Mint Petra v 15 or 16?

edit:  installed wine 1.6.2 and still no load

Edité par apT

izberion Samedi 5 Avril 2014 à 16:57

I changed the executable from Agent.exe to Launcher.exe and now it works.
apT Samedi 5 Avril 2014 à 17:51

I went into the files, used wine to load the launcher, and installed hearthstone with the installer, instead of installing hearthstone through PlayOnLinux.

Cronck Samedi 2 Juillet 2016 à 16:49

this is what fixed all battlenet logins for me

sudo apt-get update 
sudo apt-get install ttf-mscorefonts-installer


hope this helps 

Vous êtes ici: Index > PlayOnLinux > problem