Problems after quitting a game

Auteur Réponses
Shuzolost Lundi 5 Mai 2014 à 22:55

Hi guys :) ! I've got a problem with PlayOnLinux regarding the desktop *after* quitting any game I play.

Games play smooth ( I've downloaded some of my gog games ), but everytime I close literally any game, I'm stuck with my desktop being resized to just one quarter of the screen ( top left ) while the rest is pitch black, which presumably means that PoL forces my desktop to the same resolution of the game I've been playing.

I'm pretty much sure of that because, if I open the menu from the keyboard, it shows in the "available" corner of the screen, while the rest just stays dead, and I'm forced to restart everytime.

Does anyone know a solution for this ?

Thanks in advance :)
petch Mardi 6 Mai 2014 à 0:01

Shuzolost Mardi 6 Mai 2014 à 0:09

Thanks for the quick reply, petch :) ! I'm not quite sure "how" to do that though, since I'm a total newbie to Linux ( I'm running Linux Mint 16 right now, and it's just my second experience with it, as I had previously tried Ubuntu with Unity... I think ).

Do I simply open the terminal and copy and paste that ? Do I have to do that everytime I run POL ?

Sorry for the bother, really >.<''
petch Mardi 6 Mai 2014 à 8:48

Mmmmh,yes the instructions in above posts were more oriented toward script writers.

Or, so 2 ways:
- In PlayOnLinux interface: Configure button > (select the virtual drive on the left) > Miscellaneous tab > "Open a shell in this virtual drive" button
Then type the instruction mentionned before,
POL_Shortcut_InsertBeforeWine "The Name Of The Game Shortcut" "trap 'xrandr -s 0' EXIT"
- In a file manager, go to the directory .PlayOnLinux/shortcuts in your home directory (.PlayOnLinux name starting with a dot it's considered "hidden" directory so you may have to enable the display of hidden files and directories), then carefully edit (say, with gedit) your game shortcut to add "xrandr -s 0" on its own line at the edit, after the POL_Wine ... line
Shuzolost Mardi 6 Mai 2014 à 20:00

Ok, I'm really beginning to think I've got some kind of mental problem preventing me from doing things right, as I can't say if I'm either crazy or just plain dumb :P

In the miscellaneous section of POL config, I find all four of the games I've installed, but, whenever I try to click the "Open a Shell" button on any one of them, it just doesn't open anything. I tried to paste the command into the "Command to exec before running the program" box, but it really didn't work. Right now, everytime I quit a game I use the terminal command xrandr -s 1600x900 ( which is obviously my native resolution ). Not really that much of a hassle, but it would be great to have POL do it automatically, which I believe it does. It probably just hates me ! XD