Forums

Errors installing rFactor2

A noobs first POL application install

Auteur Réponses
opticnerver Lundi 2 Juin 2014 à 5:55
opticnerverAnonymous

Hello Linux/POL Guys,

I am running Linux Mint 16 MATE 64bit on an ASUS G73Sw INTEL i7, 8Gb Laptop
(trying to sort this while Mint 17 downloads)

I
am a Linux Noob, though I learned Unix under DEC VMS and BSD years ago,
then worked under IRIX on SGI equipment until it was sadly supplanted
by NT and (less sadly) INTEL and 3rd party graphics hardware in late
90´s.

I have decided it´s time to build a serious gaming
computer, and I refuse to purchase another MS distro, so I have finally
arrived at the decision to build a Linux machine.
My Install (on a USB
test drive on my laptop) went well, but I have found myself stuck
getting WINE based applications to install and run properly.

I
have read everything that I can find, which all indicates that this
should be relatively simple, it hasn´t been, and therefore I am now
seeking assistance.

I´m not quite sure how to succinctly describe the issue, so here´s the play-by-play:

LAUNCH
PlayOnLinux -> INSTALL Button -> Select ¨rFactor 12¨ from
available applications -> PlayOnLinux Installation Wizard loads ->
NEXT Button:

Dialog Box request: ¨Please select rFactor 12 install File¨
(Didn´t I just do that?)
BROWSE Button puts me in /usr/share/playonlinux/python

in this folder there is a  install.py  file - this appears to NOT be the requested ¨install¨ file...¨Wine seems to have crashed¨

Back
to my intuitive solution:  The request is for the actual Game Install
file,... Browse to the downloaded rFactor Installation file directory:
(rFactor2_DemoBuild_660.exe) -> Select OPEN

PlayOnLinux Wizard now
shows rFactor 12 (POL app) under the POL Wizard Title and rFactor Native
MS (.exe) Installation file listed beneath the Browse button.

Select POL Wizard NEXT Button

Select ERASE 
Installs DirectX, Registers Libraries

(BTW I have installed every available version of GECKO to eliminate that particular error - are 3 installed versions of GECKO a problem?)

rFactor Native Install Page displays, (¨Welcome to rFactor Setup Wizard¨,)

POL Wizard Dialog Box displays spinning clock for indefinite period of time
¨Please wait while rFactor 12 is installed"  (I wait up to an hour)

I decide that I am to select the NEXT button on rF2 Dialog Box
I NEXT my way through the rF2 setup, extracting the core files to the default (C:\Program Files\rFactor2) location

When
this completes, I select FINISH, and the POL Wizard Dialog Box (with
spinning clock) continues for about 20 seconds, then errors:

SAD FACE

 ¨Error in POL_Shortcut
  Binary not found: rFactor.exe
  Have you installed the program to the default location?¨

Not sure if I have to change the shortcut link (?)
I´m out of things to try, any help would be most appreciated.

Thanks in advance
opticnerver Lundi 2 Juin 2014 à 6:08
opticnerverAnonymous

I should have mentioned: It's using WINE 1.4.1

Edité par opticnerver

booman Mardi 10 Juin 2014 à 22:05
booman

Wow, great detail on what you have already worked on.

To be honest, I stopped useing the .py scripts to install games.  I always do a manual installation so I have a little more control over the installation.  Not to mention it teaches you how PlayOnLinux works.

Check out some of the guides here on GamersOnLinux

You will find that a manual installation can help you troubleshoot what PlayOnLinux is doing.

I checked on WineHQs to see what test results came up, but nothing good.  Mostly "garbage"
So now you have no choice but to trial-n-error with different libraries and verions of Wine. Kinda sucks, but there is still a chance it might run.

I noticed someone posted that these libraries are needed to run rFactor2:

  • directx9
  • vcrun2009

If you can't find those in PlayOnLinux packages, then look for:

  • d3dx9
  • vcrun2008
  • vcrun2010

Those might help.  Also, I would definitely try a newer version of Wine like 1.6.2 or 1.7.19
They may have better results with certain games.

Can you post your specs:

  • video card/chip?
  • 32-bit libraries installed?
  • proprietary video drivers installed?

† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
opticnerver Mercredi 11 Juin 2014 à 1:07
opticnerverAnonymous

Thank you very much for this information, Booman. For the recorod, I am using my laptop with Linux Mint installed on an external USB drive to test (and learn) the OS/configuration before setting it up on a new desktop, that will of course have a different graphics card (that will be a nVidia GeForce GTX 780Ti)

The graphics card on my laptop is a nVidia GeForce GTX 460M.

The nVidia driver currently is Version 331.38

I have no clue, at this point, how to tell you which 32-bit libraries are installed.

Also, I now have Mint 17 installed.

For now, I will work on the advice that you have already given, thank you again for your help.

booman Mercredi 11 Juin 2014 à 1:22
booman

No problem, those step-by-step guides should give some insight on how PlayOnLinux, Packages, Wine Configuration and virtual drives work.

Your desktop is a perfect culprit for running games in Linux.  Specially that GTX 780 Ti  it will rock!

So when you are running Mint on your laptop from the flash drive, can you install drivers and updates?
Playing games from an operating system on a flash drive will probably kill performance.  So it may be better to install on a free partition and dual-boot.  Otherwise, if you have an extra 2.5in hard drive, you can install Linux on it and test on your laptop.


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained