Using Mono instead of DotNet

Auteur Réponses
afd_rulez Dimanche 20 Juillet 2014 à 19:43


I've been posting alot regarding my attempt at installing a game (Magicka), and my most dominant issue with it: dotnet, specifically dotnet30 and dotnet35. I got a tip about the issue that recommended using Mono instead of trying DotNet.

So I created a test virtual drive, installed everything needed (excluding dotnet), and got it running. Steam worked fine, as with the previous drive. 

Now when I run the game. Nothing happens, that is, nothing I can immediately see, but I can hear my laptop crunching. On the terminal running PlayOnLinux, I don't see any changes after opening Steam. But in another terminal window, using top command, I see Magicka.exe running and using almost 100% cpu.

My questions: Is the game acutally running fine, but I can't see it?

Also: How exactly do I get Mono to be part of the drive and working fine?

I know that when Wine is initialized, Mono is installed with it. In the previous drives I assume Mono gets deleted when trying to install dotnet (I've read that somewhere). I checked if Mono is there going to Configure-->Wine-->Wine uninstaller, and it was there.

Is there any other way to install it, and make the game dependent on it rather than dotnet? (I noticed that the game tried to install dotnet in steam as it usually does, and I had to change something in the registry to make the message disappear, not sure if the game is actually using mono)

Any help is appreciated.

Regards :)

Edit: forgot to mention, I'm using Wine 1.7.22, and Mono 4.5.2. I'm working on Ubuntu 14.04.


Edité par afd_rulez

New to this, and Loving it.
booman Lundi 21 Juillet 2014 à 2:24

Yes, mono is automatically installed when you use wine in PlayOnLinux. So you don't have to do anything.  I have read that mono and dotnet conflict with eachother, but I have not experienced this yet.

I know you PMed me and we talked about Wine 1.5.18
I have been able to install all of the dotnet libraries successfully with this version of Wine.  Even if I'm not using it to run the game.

Did you disable the Steam In-Game Community overlay?  It can cause games to crash or not even start.

Also, did you install the 32-bit libraries for your distro?  Magicka only supports 32-bit as far as I know... so without them most games won't run.

What is your video card?  Intel, AMD, Geforce?  Did you install the proprietary drivers for it?

I had a hard time getting Magicka to run, but once I figured it out, I tried to capture everything in the guide.

Feel free to post your debug output so I can see the errors

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
afd_rulez Lundi 21 Juillet 2014 à 5:05

Thanks booman, You've been of great help. I've become more invested in solving the Magicka problem than of playing the game xP

I've noticed that mono and dotnet avoid being together. To the point that when installing dotnet, mono gets uninstalled/removed in the process.

After posting this thread, I tried changing the overlay option, same results. Game doesn't show, but CPU is being used.

I don't know what you mean by 32-bit libraries, but I've made sure that all my work is done in 32-bit prefixes or virtual drives.

My Video Card: VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

My Video Driver: i915


I've tried many things after that, and made some progress. I even began using only wine/winetricks instead of POL to see if I get different results. I noticed that the results are almost the same, but with different installation processes.

One of the most noticable observations is that once .NET Framework 2.0 is installed (independently or part of dotnet30/dotnet35) it will produce an error if tried to install again. So, if I install dotnet30 which instalels the .NET Framework 2.0, everything will be fine. Then if I try to install dotnet35, I'll get an error message from the beginning and everything will stop. I worked around that by creating a clean prefix and installing dotnet35 immediatly, which produced different results, but it ultimately didn't work (Things are messed around in my head, I think I'm talking about my Wine experimentation). I think I found dotnetfx35.exe in the drive and installed it via wine command, and I think it installed almost completely, but eventually I got a message over the .NET Framework 35 Setup that said:

"A fatal error occured. However, mscorees.dll could not be loaded to display the appropriate error message.

Please reinstall the .NET Framework"

As I said, I've been doing tons of experimenations, when I get consistent results, and can reproduce the error, I'll post about it somewhere.

New to this, and Loving it.
booman Lundi 21 Juillet 2014 à 16:17

Man that really sucks.  I have lived all of this before and had all the same problems.  Error here, error there.
You are doing all of this with Wine 1.5.18 correct?
Which version of PlayOnLinux are you using?  Maybe that is causing some problems

You may want to just start over with a new virtual drive, don't install any libraries, install steam and then close it.
Go to PlayOnLinux configure and install the dotnet libraries one at a time.  Start with dotnet30 and it will install the prerequisites, then install dotnet 35 and then dotnet40

Maybe that will help to avoid errors.  There were times when I installed dotnet over and over, eventually it wouldn't error, but when I used Wine 1.5.18 it never errored.

Since you CAN hear the game but only have a black screen, there is a chance the Intel Linux drivers are not able to handle the 3D requirement.  Even though Windows can, there is a chance those drivers in Linux can't.

Normally the Intel chips are called:  Intel HD 3000, Intel HD4000, etc.

As for 32-bit libraries, Ubuntu 64-bit will not include these libraries to run 32-bit programs. I'm still kinda at-a-loss on how to install them because Ubuntu 13 removed the packaged called "ia32-libs" and now its called "multi-arch"

So maybe search your Software Manager for "multi-arch" and see if they have something you can install that will give you the proper 32-bit libraries for games.

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
afd_rulez Lundi 21 Juillet 2014 à 23:02

The last part has been done in Wine/Winetricks, it is really basic and I guess easy to use (PoL was a great intro to understaning it). However, I still don't know how to change versions(Unlike in PoL where it is easy). So all was done in 1.7.22 (Which didn't crash immediately, but don't know if contributed to the last problem). I'm currently thinking of sticking to PoL, and trying to find a solution(although creating prefixes/drives is faster in just Wine).

I just wanted to clarify what happened when I tried to run Magicka that time, nothing happend. No black screen, no white screen, just Magicka.exe running, and the Steam interface in front of me. Also, I haven't been able to reproduce that senario recently, I'll try to get consistent results.

I checked my package manager, and I do have multiarch-support installed. I don't know if the Wine version that I have is specifically 32-bit. But I suppose that PoL got me covered in that.

Thanks for your replies, man. They're keeping me going. I hope any other person who'd had similar experiences with this kind of problem would also share anything about it.


Edit: Also, is it required to have dotnet40?

Edité par afd_rulez

New to this, and Loving it.
booman Lundi 21 Juillet 2014 à 23:47

Yeah I would stick to PlayOnLinux because there is a lot less Terminal commands and you can switch Wine versions on-the-fly.  In Winetricks, you have to create a new wineprefix and then start over.

I download the Wine versions ahead of time and make sure to only download 32-bit versions, then when I do a manual installation I select 32-bit virtual drive.

This way you know everything is 32-bit compatible.

I don't think Magica needs dotnet 40

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained