Forums

cannot install new components: POL_Install_ does not exist!

POL install does not seem to exist

Auteur Réponses
quaelgeist Dimanche 3 Aoüt 2014 à 21:26
quaelgeistAnonymous

Hello. As described in the title, whenever I want to install new component to a wineprefix, I get the error: 

Error in POL_Call
Function POL_Install_ does not exist!

I am using Arch Linux on Kernel 3.15.7-1.

I am using PlayOnLinux 4.2.5-dev, compiled from AUR. Arch offers 4.2.4-1 via the repository, which had the same error.

The console output:

playonlinux
Looking for python... 3.4.1 - skipped
Looking for python2.7... 2.7.8 - selected
[main] Message: PlayOnLinux (4.2.5-dev) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/sean/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Überprüfe Plugin: Capture...
[install_plugins] Message: Überprüfe Plugin: ScreenCap...
[install_plugins] Message: Überprüfe Plugin: PlayOnLinux Vault...
[maj_check] Message: Web version : 1407049810
[maj_check] Message: Current local version : 1407003876
[maj_check] Message: Updating list
[POL_Config_Write] Message: Config write: LAST_TIMESTAMP 1407049810
[POL_SetupWindow_Init] Message: Creating new window for pid 5922
[POL_Call] Message: Calling POL_Install_
[POL_Call] Error: Function POL_Install_ does not exist!
False^C
Ctrl+C pressed. Killing all processes...

 

what can I do now? There is no package with something like "pol_install" or anything familiar, nor any git or someting.

petch Lundi 4 Aoüt 2014 à 8:23
petch
Développeur

My guess is that it comes from getPackageFromName (python/configure.py):

...
            selectedPackage = "POL_Install_"+selectedPackage
...

It must somehow be called with an empty string selectedPackage...

Like if no component was selected before "Install" button was hit

Edité par petch