Forums

Disabling of PlayOnLinux Crash dialog

It triggers on a specific game that still runs nicely

Auteur Réponses
Sweeper Mercredi 6 Aoüt 2014 à 21:11
SweeperAnonymous

Hello

I am trying to make my SimCopter work properly, as such I have made my own script for launching that starts the POL shortcut I made, then greps the process ID of that after waiting, and then pipes that into a program called "cpulimiter"

This is needed since the game causes an internal faults and crashes after a few minutes on modern / fast hardware, slowing it down actually solves the problem.
The problem I have is that PlayOnLinux after the "sleep" command is called in the script (To let the game startup fully and get the process ID properly) pops up its crash dialog where it says "POL Wine has crashed bla bla bla" which is naturally totally utterly bullshit as the game still runs and can be played as long as you do not click that "next" or "close" button in that dialog box.

As a result I wonder if there is a way to disable it on application basis, this game has its own virtual Wine drive if it means anything.

For reference I am running Arch Linux with the 3.15.8-1 Kernel and PlayOnLinux version: 4.2.4

And this is the script I quickly whipped up that seems to get the job done, except that PoL crashes:

#!/bin/bash
#Bash script for running SimCopter with cpulimiter
/usr/share/playonlinux/playonlinux --run "Sim Copter" %F & sleep 2
scpid=$(pgrep SimCopter.exe)
cpulimit -l 40% -p ${scpid}

petch Mercredi 6 Aoüt 2014 à 23:05
petch
Développeur

In PlayOnLinux console:

POL_Shortcut_QuietDebug "Sim Copter"

 

Sweeper Mercredi 6 Aoüt 2014 à 23:11
SweeperAnonymous

Forgot to mention, I have tried that FAQ item, and I still get it.
The PlayOnLinux shortcut at the moment looks like this:


#!/bin/bash
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
export WINEPREFIX="/home/sweeper/.PlayOnLinux//wineprefix/SimCopter"
export WINEDEBUG="-all"
cd "/home/sweeper/.PlayOnLinux//wineprefix/SimCopter/drive_c/./Program Files/Ma$
POL_Wine SimCopter.exe "$@"
[ "$WINEDEBUG" = "-all" ] && exit 0

 

I noticed the WineDebug seems to be mentioned twice? This is a setup created by the GUI and not manually edited.

petch Mercredi 6 Aoüt 2014 à 23:18
petch
Développeur

Sweeper Jeudi 7 Aoüt 2014 à 0:55
SweeperAnonymous

Is it possible it never gets triggered then? Perhaps I should reference it in my script before I give the sleep command and grabs it's process ID...
 

kvr2007 Jeudi 28 Aoüt 2014 à 22:13
kvr2007Anonymous

Indeed the console version of PlayOnLinux for some reason ignores this setting. What you can do is just add:

export POL_IgnoreWineErrors=True

to your program startup script.

Please see here for some details:

http://www.playonmac.com/en/topic-9933.html