Forums

after update Neverwinter mmo wont play

Auteur Réponses
omraf760 Vendredi 15 Aoüt 2014 à 15:07
omraf760Anonymous

HI all 
after the recent update I cant play with the game i get this error/ scroll down u can find the debug log
linux mint 17 64 bit
asus k53s laptop with geforce gt 520m using nvidia 331.38
POL 4.2.2 wine 1.6

[​IMG] 

[08/15/14 14:44:56] - Running wine-1.7.24 ArcLauncher.exe (Working directory : /home/oommeerr/.PlayOnLinux/wineprefix/Arc/drive_c/Program Files/Perfect World Entertainment/Arc)
fixme:shell:SetCurrentProcessExplicitAppUserModelID L"PERFECTWORLD.ARC.2.0": stub
fixme:advapi:RegisterEventSourceW ((null),L"ArcService"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x00000000,(nil),0x0002,0x00000000,0x72df20,(nil)): stub
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:process:WTSGetActiveConsoleSessionId stub
fixme:wtsapi:WTSQueryUserToken 0 0x72dc80
fixme:advapi:CreateProcessAsUserW (nil) L"C:\\Program Files\\Perfect World Entertainment\\Arc\\ArcUpdate.exe" L"" (nil) (nil) 0 0x00000430 0x340000 L"C:\\Program Files\\Perfect World Entertainment\\Arerr:eek:le:NDRCContextBinding invalid handle 0x404603
fixme:shell:SetCurrentProcessExplicitAppUserModelID L"PERFECTWORLD.ARC.2.0": stub
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenSessionId, ...) semi-stub
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenSessionId, ...) semi-stub
fixme:msg:ChangeWindowMessageFilterEx 0x1004e 4a 1 (nil)
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:shell:SetCurrentProcessExplicitAppUserModelID L"PERFECTWORLD.ARC.2.0": stub
err:eek:le:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:eek:le:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
err:eek:le:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:eek:le:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
err:eek:le:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:eek:le:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
fixme:msg:ChangeWindowMessageFilterEx 0x20054 4a 1 (nil)
fixme:msg:ChangeWindowMessageFilterEx 0x10076 4a 1 (nil)
fixme:eek:le:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:wbemprox:client_security_SetBlanket 0x7c74d430, 0x1c7f68, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7c74d430
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:eek:le:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:winsock:WSALookupServiceBeginW (0x1dde5b4 0x00000ff0 0x1dde5fc) Stub!
fixme:iphlpapi:NotifyAddrChange (Handle 0x1dde48c, overlapped 0x9fedc8): stub
fixme:winsock:WSALookupServiceBeginW (0x1dde5f4 0x00000ff0 0x1dde63c) Stub!
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:eek:le:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:eek:le:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
err:eek:le:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:eek:le:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
err:eek:le:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:eek:le:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0x4650000 0 0x33fb08 4
fixme:thread:SetThreadIdealProcessor (0xfffffffe): stub
fixme:heap:HeapSetInformation 0x4760000 0 0x33df6c 4
fixme:thread:SetThreadIdealProcessor (0x7c): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33d98c,0x00000000), stub!
fixme:wbemprox:client_security_SetBlanket 0x7d7a8430, 0x184e78, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7d7a8430
fixme:win:EnumDisplayDevicesW ((null),0,0x33d4b8,0x00000000), stub!
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
fixme:thread:SetThreadIdealProcessor (0xb4): stub
fixme:iphlpapi:NotifyAddrChange (Handle 0x33c7e8, overlapped 0x473b778): stub
fixme:winsock:WSALookupServiceBeginW (0x33c8e8 0x00000ff0 0x33c930) Stub!
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:iphlpapi:CancelIPChangeNotify (overlapped 0x473b778): stub
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0x47f0000 0 0x33fc78 4
fixme:thread:SetThreadIdealProcessor (0xfffffffe): stub
fixme:heap:HeapSetInformation 0x52e0000 0 0x33fc70 4
fixme:dbghelp:validate_addr64 Unsupported address fffffffff73b0000
fixme:dbghelp:validate_addr64 Unsupported address fffffffff7390000
fixme:dbghelp:validate_addr64 Unsupported address fffffffff7320000
fixme:bitmap:CreateBitmapIndirect planes = 4
fixme:win:EnumDisplayDevicesW ((null),0,0x33d5c4,0x00000000), stub!
fixme:wbemprox:client_security_SetBlanket 0xf6e3d430, 0xe6666e8, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0xf6e3d430
fixme:win:EnumDisplayDevicesW ((null),0,0x33d0e8,0x00000000), stub!
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
fixme:win:EnumDisplayDevicesW ((null),0,0x33de48,0x00000000), stub!
fixme:d3d11:D3D11CreateDevice stub: adapter (nil), driver_type D3D_DRIVER_TYPE_HARDWARE, swrast (nil), flags 0x1, feature_levels 0x33e5dc, levels 0x6, sdk_version 7, device (nil), feature_level 0x33e5fixme:win:EnumDisplayDevicesW ((null),0,0x33dbe8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33dbf8,0x00000000), stub!
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0xec0000 0 0x33fc8c 4
fixme:heap:HeapSetInformation 0xfd0000 0 0x33fc00 4

Please help me. sorry if i didnt post in the right place or the right way

omraf760 Samedi 16 Aoüt 2014 à 11:02
omraf760Anonymous

no one can help me ?
anyone exprincing this ?

omraf760 Samedi 16 Aoüt 2014 à 11:37
omraf760Anonymous

no one can help me ?
anyone exprincing this ?

omraf760 Samedi 16 Aoüt 2014 à 16:59
omraf760Anonymous

[08/16/14 16:56:21] - Running wine-1.7.20 GameClient.exe (Working directory : /home/oommeerr/.PlayOnLinux/wineprefix/Arc/drive_c/Program Files/Perfect World Entertainment/Neverwinter_en/Neverwinter/Live)
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0x47e0000 0 0x32fc78 4
Shared memory should be enabled by default since not using dev data.

DO_AUTO_RUNS...fixme:thread:SetThreadIdealProcessor (0xfffffffe): stub
fixme:heap:HeapSetInformation 0x52d0000 0 0x32fc70 4

  InputLib startup...InputLib startup... done                         (0.00)
RefSystem: Creating NormalHandles table, size 64.

 done.                                                                (0.21)

Loading logo...
 done.                                                                (0.00)

Preloading DLLs...fixme:dbghelp:validate_addr64 Unsupported address fffffffff7320000
fixme:dbghelp:validate_addr64 Unsupported address fffffffff7300000
fixme:dbghelp:validate_addr64 Unsupported address fffffffff72a0000
fixme:bitmap:CreateBitmapIndirect planes = 4

done.                                                                 (0.72)

FileSystem startup...Failed to add GameDataDir: ./platformData (it does not exist or could not be accessed)

  Loading hoggs...

    UNACCOUNTED FOR                                                   (0.15)

    Add to folder cache: ./piggs/bins.hogg:...
    done                                                              (0.04)

    Add to folder cache: ./piggs/data.hogg:...
    done                                                              (0.02)

    Add to folder cache: ./piggs/texture.hogg:...
    done                                                              (0.18)

    Add to folder cache: ./piggs/exes.hogg:...
    done                                                              (0.00)

    Add to folder cache: ./piggs/texture2.hogg:...
    done                                                              (0.00)

    Add to folder cache: ./piggs/object.hogg:...
    done                                                              (0.00)

    Add to folder cache: ./piggs/sound.hogg:...
    done                                                              (0.02)

    Add to folder cache: ./piggs/dynamic.hogg:...
    done                                                              (0.00)

    Add to folder cache: ./piggs/bins2.hogg:...
    done                                                              (0.00)

    Add to folder cache: ./piggs/character.hogg:...
    done                                                              (0.00)

   done (10 hoggs)                                                    (0.45)
  GameDataDirs:
   *./Data
    ./Localdata

  Auto-enable PatchStreaming...   enabled (simulation off)                                           (0.00)

 done.                                                                (0.46)

Caching folders...
  Precaching animation_library...
  done.                                                               (0.00)

  Precaching autobinds...
  done.                                                               (0.00)

  Precaching bin...
  done.                                                               (0.00)

  Precaching character_library...
  done.                                                               (0.00)

  Precaching defs...
  done.                                                               (0.00)

  Precaching dyn...
  done.                                                               (0.00)

  Precaching environment...
  done.                                                               (0.00)

  Precaching fonts...
  done.                                                               (0.00)

  Precaching genesis...
  done.                                                               (0.00)

  Precaching keybinds...
  done.                                                               (0.00)

  Precaching maps...
  done.                                                               (0.00)

  Precaching materials...
  done.                                                               (0.00)

  Precaching messages...
  done.                                                               (0.00)

  Precaching object_library...
  done.                                                               (0.00)

  Precaching powerart...
  done.                                                               (0.00)

  Precaching shaders...
  done.                                                               (0.00)

  Precaching sound...
  done.                                                               (0.00)

  Precaching texts...
  done.                                                               (0.00)

  Precaching texture_library...
  done.                                                               (0.00)

  Precaching ui...
  done.                                                               (0.00)

  Precaching world...
  done.                                                               (0.00)
 done.                                                                (0.00)
Parsing command line...


Done parsing command line.                                            (0.00)
GamePrefsInit: giGamePrefSet now 0

Gathering system specs...fixme:win:EnumDisplayDevicesW ((null),0,0x32d5c4,0x00000000), stub!
fixme:wbemprox:client_security_SetBlanket 0xf6f03270, 0xe6566e8, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0xf6f03270
fixme:win:EnumDisplayDevicesW ((null),0,0x32d008,0x00000000), stub!
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION

done.                                                                 (0.19)
CPU: 2100 Mhz (2/4 cores) / RAM: 7895 MBs (7258 free) / Video Card: WINE Graphics Driver / Driver Ver: UnknownVendor / UserVA: 4.0GB / OS Ver: 6.1.7601 / VidMem: 1024 MBs / D3D11: Unknown
Acceptable video card driver


UtilitiesLib startup...fixme:win:EnumDisplayDevicesW ((null),0,0x32de48,0x00000000), stub!
fixme:d3d11:D3D11CreateDevice stub: adapter (nil), driver_type D3D_DRIVER_TYPE_HARDWARE, swrast (nil), flags 0x1, feature_levels 0x32e5dc, levels 0x6, sdk_version 7, device (nil), feature_level 0x32e5d4, context (nil)
fixme:win:EnumDisplayDevicesW ((null),0,0x32db48,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32db68,0x00000000), stub!

 done.                                                                (0.01)

Creating primary rendering device...
Trying (Direct3D9Ex)...fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0xec0000 0 0x33fc8c 4
fixme:heap:HeapSetInformation 0xfd0000 0 0x33fc00 4
fixme:dbghelp:elf_search_auxv can't find symbol in module
fixme:dbghelp:MiniDumpWriteDump NIY MiniDumpWithDataSegs
Shared memory should be enabled by default since not using dev data.
Shared memory should be enabled by default since manual production mode on even though using dev data.
 SetSharedMachineIndex 1
 Lang 0
 ceProcessId 8
 ceThreadId 9
 ceArgs 40152264:656
 productionMode
 CECrash 1

tydevers Samedi 16 Aoüt 2014 à 22:25
tydeversAnonymous

I have this problem as well. The most recent Neverwinter update on 8/14 broke the game. I've run the game for quite a while on the 64 bit Ubuntu platform(10 -14.04), using an Arc client workaround and the standard wine from the ubuntu repo (1.4?). The game has always run well. I've had the occassional break after an update but nothing that couldn't be fixed. This time is different.

Gets to the Neverwinter patch screen and seems to patch fine. The play button makes the program crash, yielding the same blank Crypticerror screen shown by Omraf760 above.

I found Boomer's write up and gave it a shot last night.

http://www.gamersonlinux.com/forum/threads/neverwinter-free-mmo-guide.170/

Partitioned a drive, and loaded linux mint 17, 32 bit, cinnamon. Arc loads beautifully via that method but the Neverwinter patch screen fails after clicking the play button, same as before.

I'll keep working on a solution working around the Boomer write up(which is VERY well done). I just wanted to chime in and say that its not just Omraf760 who has the problem.

Linux Mint 17 32 bit cinnamon

AMD Phenom II x 4

4g memory

Nvidia GTX550 Ti video card

anarchogre Dimanche 17 Aoüt 2014 à 22:06
anarchogreAnonymous

Same deal. Arc updates and is fine. Neverwinter crashes on the after you hit "play". I just got done installed Neverwinter a couple of weeks ago via Boomer's guide (which was flawless). Here I sit, eagerly anticipating a fix from someone that knows way more about all this than me!

Core i7 950 × 8 

12g memory

GeForce GTX 285

tydevers Dimanche 17 Aoüt 2014 à 23:18
tydeversAnonymous

It looks like a few of the developers are involved. It appears that the last patch had some big changes.

http://nw-forum.perfectworld.com/showthread.php?729881-After-MOD4-update-NW-crashes-on-wine-linux/page5

anarchogre Mardi 19 Aoüt 2014 à 5:28
anarchogreAnonymous

tydevers Jeudi 21 Aoüt 2014 à 5:43
tydeversAnonymous

I was able to login on the preview server. So the actual patch should fix the problem.

booman Mardi 26 Aoüt 2014 à 20:38
booman

Can anyone else confirm that Neverwinter is working again?


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
tydevers Mercredi 27 Aoüt 2014 à 5:58
tydeversAnonymous

 

Can anyone else confirm that Neverwinter is working again?

 

Its working with the new patch on my end. Here is the setup:

Linux Mint 17 64 bit cinnamon

AMD Phenom II x 4

4g memory

Nvidia GTX550 Ti video card 331 driver

installed via your write up, except I run it in full screen and I do not have winecfg set to emulate a virtual window.

 

booman Mercredi 27 Aoüt 2014 à 14:37
booman

Awesome!  I have almost the exact same computer setup.  So I know it will work with my machine
Thank You


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained