Issues with Star Wars: Knights of the Old Republic -- Steam Version

MD5 sum mismatch and crash

Auteur Réponses
Rubin Samedi 30 Aoüt 2014 à 4:31

Hello, everyone. I'm having a problem with KOTOR on Steam.  The install worked without a problem, but when I then try to run the game through POL I get the error:

Error in POL_Download
POL_Download - MD5 sum mismatch ! (1 attempt)

The debugger output is as follows:

Running wine-1.3.5 swkotor.exe (Working directory : /home/rubin/.PlayOnLinux/wine/linux-amd64)
wine: cannot find L"C:\\windows\\system32\\swkotor.exe"

If I try to just run the executable ("wine swkotor.exe") the game crashes just after the character creation step, with the message:

Unhandled exception: page fault on write access to 0x0086d004 in 32-bit code (0x0046bf22).

I have the game set to run in windowed mode, have turned all the graphics to the lowest setting, and disabled sound and movies.

Does anyone have any suggestions on how to get KOTOR fully running? I would be very appreciative.

System information:
Linux 3.13.0-35-generic x86_64 / Ubuntu 14.04
Wine 1.6.2
Playonlinux 4.2.4
Intel Core i7-3630QM CPU @ 2.40GHz
Intel HD 4000 graphics (256 MB shared RAM), Intel i915 driver


Rubin Jeudi 4 September 2014 à 4:26

Upon further study, it looks like the KOTOR installation did not go as well as I thought.

I deleted the game and tried to reinstall. During the installation, I saw this error:

[POL_SetupWindow_menu] Message: menu answer: 256
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
/home/rubin/.PlayOnLinux//install: line 173: cd: /home/rubin/.PlayOnLinux//wineprefix/SWKotOR/drive_c/Program Files (x86)/LucasArts/SWKotOR: No such file or directory

Part of this seems to stem from line 173 of the installation script:


This might be the right path when installing from the CD, but for Steam the path should be

cd "$WINEPREFIX/drive_c/Program Files (x86)/Steam/SteamApps/common/swkotor"

I'm not sure what's calling


but it looks like the L is screwing things up.

Update: This is from line 167 in the script:

regedit vms.reg

This gives me the error

wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)

I get the same error from line 182,

regedit SWKotor_fix.reg

Interestingly enough, this error only pops up when I run regedit from the POL console. From the standard console, I don't get this error.

Edité par Rubin

Rubin Jeudi 4 September 2014 à 6:04

Another interesting thing is the first time Steam is installed and run (lines 85-87)

if [ "$GAME_MEDIAVERSION" == "STEAM" ]; then
        POL_Call POL_Install_steam

there is no text. You can login if you remember where to click, but when Steam launches, there is no menu, so you can't go to your games list.

Fortunately, the second time Steam runs (lines 141-144)

elif [ "$GAME_MEDIAVERSION" == "STEAM" ]; then
        cd "$WINEPREFIX/drive_c/$PROGRAMFILES/Steam"
        wine "Steam.exe" "-applaunch 32370"
        POL_SetupWindow_message "$LNG_WAIT_STEAM_END" "$TITLE"

the text is back.

In the large scheme of things, this probably doesn't matter, but I wanted to bring it up just to make sure someone knows about it.



Edité par Rubin

Rubin Vendredi 5 September 2014 à 5:57

I used the POL console to work through GNU_Raziel's install script line by line, and with the changes I mentioned above, it looks like the install completed successfully.

The next error comes from running the script to actually launch the program:

[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
export WINEPREFIX="/home/rubin/.PlayOnLinux//wineprefix/SWKotor"
export WINEDEBUG="-all"
cd "/home/rubin/.PlayOnLinux//wineprefix/SWKotor/drive_c/./Program Files (x86)/Steam/SteamApps/common/swkotor"
POL_Wine "swconfig.exe"  $@


[POL_System_CheckFS] Message: Checking filesystem for swconfig.exe
[POL_System_SetArch] Message: POL_ARCH set to amd64
[POL_Wine_SetVersionEnv] Message: Wine 1.3.5 not installed. Installing it
[POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.5, amd64
shasum: ./PlayOnLinux-wine-1.3.5-linux-amd64.pol:
Server sha1 : 2e5b6dcf1233b6fadc5c520d8ccf2a5cf78a5ef3
Client sha1 :
rm: cannot remove ‘PlayOnLinux-wine-1.3.5-linux-amd64.pol’: No such file or directory
[POL_Wine_Install_resources] Message: Installing gecko for wine 1.3.5 amd64
[POL_Wine_Install_resources] Message: Linking gecko
ln: failed to create symbolic link ‘/home/rubin/.PlayOnLinux//wine/linux-amd64/1.3.5/share/wine/gecko’: No such file or directory
[POL_Wine_Install_resources] Message: wine_gecko-1.4-x86.msi already installed. Skipping
[POL_Wine_Install_resources] Message: Installing wine_gecko-1.4-x86_64.msi
[POL_Download] Message: Downloading
cat: wine_gecko-1.4-x86_64.msi: No such file or directory
[POL_SetupWindow_question] Message: question answer: False
[POL_Download] Error: POL_Download - MD5 sum mismatch ! (1 attempt)
[POL_SetupWindow_Init] Message: Creating new window for pid 19212

It looks like the problem is that there is no wine 1.3.5 for AMD64 in POL. Since I have wine 1.6.2, I edited the file /home/rubin/.PlayOnLinux/wineprefix/SWKotor/playonlinux.cfg, changing the wine version from 1.3.5 to 1.6.2. Then I used POL's wine version management tool to install wine 1.6.2 AMD64. 

The good news is that I'm not getting the MD5 error now. Yay!

The bad news is that KOTOR is still crashing like I mentioned in my OP. I've made a lot of progress, at least. Maybe tomorrow I'll figure out what's causing the crash.

Edité par Rubin

Rubin Samedi 6 September 2014 à 4:43

I've come to the conclusion that there's something fundamental about KOTOR/Steam that prevents it from running under Wine, at least on my system. I've been able to successfully install and run KOTOR from the CDs using POL, however.


Still, I was able to uncover a few bugs in the POL install and launch scripts that should be corrected:

1. Calling regedit inside POL generates an error

2. The KOTOR install script should be updated to reflect that the location of KOTOR/Steam is $WINEPREFIX/drive_c/Program Files (x86)/Steam/SteamApps/common/swkotor/

3. The default wine version 1.3.5 causes problems on 64-bit Linux, and should be replaced by a different version


Good luck to the next person trying to get KOTOR/Steam running! I look forward to seeing what you can accomplish.