Star Wars: Jedi Knight II

Inability to Start

Auteur Réponses
phillip9001 Lundi 24 Novembre 2014 à 0:13


I tried installing the video game Star Wars: Jedi Knight II on my Linux Mint 17 (KDE x64) system through POL 4.2.5 but it won't start. Everytime I do run the program it crashes and freezes my desktop at the lowest resolution (800x600). I tried using wine 1.4, 1.6, and 1.7.29 but I keep getting the same outcome. Everything is default except I've installed: the microsoft core fonts, the Dxfull setup, DX9 program, and dinput. I even tried installing it from scratch (without selecting the jedi outcast link in the " install game" POL library), but I still get the same crash. I have attached the hyperlinks to the log files from the debugging processes ([1] with window emulation and [2] without emulation,respectively) I hope it helps, but here are some of the specs regarding POL setup: 32bit Win XP, all default video setup.


- Thank you for your help.




Edité par phillip9001

Bladeforce Mercredi 26 Novembre 2014 à 22:19

If this is the same game you can play it natively in Ubuntu now

phillip9001 Dimanche 30 Novembre 2014 à 3:10

Thank you Bladeforce for your help. I followed the instructions explained on the github website you provided and got it working! I'm setting this thread to solved.

If someone else is having the same problem, just go to website provided:

For more explicit instructions go here:

(note: in the final step try: "sudo ./jk2sp" rather than "./jk2sp")