Forums

League of Legends, cannot alt-tab or switch workspace

Auteur Réponses
iiwii Mardi 6 Janvier 2015 à 9:09
iiwiiAnonymous

I am using Fedora 21 and I can not alt-tab or switch windows while running LOL, I was able to do it in Linux Mint.

I have seen other posts and have tried Config>> Configure Wine>> Graphics tab and unchecked "Allow the windows manager to decorate the windows" and unchecked "Allow the window manager to control the windows" which made it better but I am still not able to alt-tab or switch to another workspace.

I read another post which recommended switching to another virtual terminal eg. Ctrl+Alt+F2, log in then "startx" and start the game there so I can just hit Ctrl+Alt+F1 to get back to my original desktop. This is a good idea but I would rather switch workspace. Any suggestions or idea would be appriciated.

 

Ronin DUSETTE Mardi 6 Janvier 2015 à 21:27
Ronin DUSETTE
Admin

What desktop environment does Fedora run? Mint uses a different one (Cinnamon, I believe). You could also run it in a virtual desktop (in the same menu where you found the checkboxes for window decorations.) that is the resolution for your monitor. That is what I do (I have 4 monitors, and run a single game on one monitor while I can work on the others.).

It is likely the desktop environment that is causing that. I run KDE, and any time I need to use ALT in a program in Wine, I have to hold down the Win (SUPER) key too, because ALT is a major shortcut-button in KDE. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
iiwii Mardi 6 Janvier 2015 à 22:10
iiwiiAnonymous

I am using Gnome3, I didn't even thing about that, thank you for your reply I hope that information will lead me to the right path. I will also try the virtual desktop you mentioned.

Four monitors sounds awesome, one day I will go that path. The only issue is that I am using a laptop and I have one mini display port and vga, but that problem is for a later time.
 

Ronin DUSETTE Mardi 6 Janvier 2015 à 22:36
Ronin DUSETTE
Admin

Lol. Yeah, the virtual desktop is the solution for me, with my particular setup. You may want to look at the shortcut settings in Gnome and see what else ALT does. Or, maybe try using the WIN (SUPER) key + ALT like I have to do for KDE. It may work. The WIN key pretty much escapes what ALT already does. It may be something to look at. Unfortunately, it is one of those things that varies from system to system.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
iiwii Jeudi 8 Janvier 2015 à 18:06
iiwiiAnonymous

I tired the virtual desktop, it wokred the first time, but when I tried to alt-tab again it stoped working, switching to the bottom workspace did not work :-(, I will look more into this. I also installed cinnamon and switching workspaces worked, but LOL was only running at 1 fps.

So now I have another thing to look into, trying to get LOL running smooth in Cinnamon like it runs in Gnome, and try to get Gnome and LOL to play nice when switching workspaces or alt-tabing. I will keep this thread updated. Any suggestions are welcomed.

iiwii Jeudi 8 Janvier 2015 à 18:35
iiwiiAnonymous

After a reboot LOL is running smootly in Cinnamon and I am able to alt-tab and switch workspaces, not the fix I had in mind but this works for me, I will still look into alt-tab and workspaces in Gnome.

"Allow the window manager to decorate the window" and "Allow the window manager to control the window" must have a check in the box for workspaces to work for me, if it is unchecked you can still switch workspaces but LOL will still be displayed in all the workspaces, you can try opening apps but LOL will just go over it.

To see if they are checked launch "Playonlinux" then click on "Configure" then select the "Wine" tab and click on "Configure Wine". A new window should open, then click on the "Graphics" tab and make sure those two are checked.

To install Cinnamon in Fedora 21.

yum install cinnamon
Ronin DUSETTE Jeudi 8 Janvier 2015 à 19:13
Ronin DUSETTE
Admin

Yeah. It can get really picky, depending on game and desktop environment. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
iiwii Samedi 10 Janvier 2015 à 11:12
iiwiiAnonymous

Victory, workspaces is working wit LOL now, I am not too sure what I did, I looked through my history and yum history, with yum I installed pulseaudio-libs-devel, im not sure if that has something to do with it.

I also did a yum update which updated

Updated harfbuzz-0.9.35-1.fc21.i686               @updates
    Updated harfbuzz-0.9.35-1.fc21.x86_64             @updates
    Update           0.9.36-1.fc21.i686               @updates
    Update           0.9.36-1.fc21.x86_64             @updates
    Updated harfbuzz-icu-0.9.35-1.fc21.x86_64         @updates
    Update               0.9.36-1.fc21.x86_64         @updates
    Updated libical-1.0-7.fc21.x86_64                 @koji-override-0/$releasever
    Update          1.0-8.fc21.x86_64                 @updates
    Updated mpfr-3.1.2-6.fc21.x86_64                  @koji-override-0/$releasever
    Update       3.1.2-8.fc21.x86_64                  @updates
    Updated perl-Filter-1:1.50-3.fc21.x86_64          @koji-override-0/$releasever
    Update              1:1.53-1.fc21.x86_64          @updates
    Updated ppp-2.4.7-5.fc21.x86_64                   @updates
    Update      2.4.7-6.fc21.x86_64                   @updates
    Updated stoken-libs-0.8-2.git.ba44603.fc21.x86_64 @koji-override-0/$releasever
    Update              0.81-1.fc21.x86_64            @updates
    Updated tcpdump-14:4.6.2-2.fc21.x86_64            @updates
    Update          14:4.6.2-3.fc21.x86_64            @updates
    Updated wireshark-1.12.2-1.fc21.x86_64            @updates
    Update            1.12.2-2.fc21.x86_64            @updates
    Updated wireshark-gnome-1.12.2-1.fc21.x86_64      @updates
    Update                  1.12.2-2.fc21.x86_64      @updates


I'm not sure, maybe it was the pulseaudio devel 32bit, I was having headphone issues with LOL so I was messing with that, then I went back to Gnome and wanted to see if anything changed and I was able to switch workspaces.

I hope this information helps anyone in need.

Ronin DUSETTE Dimanche 11 Janvier 2015 à 19:14
Ronin DUSETTE
Admin

There is nothing in Pulseaudio (which controls audio) that would make ALT-TAB work or not work. haha. For the sound, yes, you likely didn't have the 32-bit libs. Either way, it's working. lol.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
iiwii Dimanche 11 Janvier 2015 à 23:16
iiwiiAnonymous

I can't explain why its working, I looked through my history and yum history to see what was the only changes and that was it. It doesn't make sence, I uninstalled Cinnamon and now I am using Gnome3, everything is still working properly.

I know pulseaudio deals with audio, I paused my search to try to fix the workspaces in gnome3 and was trying to fix an audio issue I had with my Logitech G930. The sound would work from my laptop speakers and from my monitor when I connect through HDMI, but when I connected my headphones the sound would speed and sound like its cracking. I was able to fix it with information from this fourms.

https://www.playonlinux.com/en/topic-12753-PA_audio_fix_figured_out_advice_on_making_it_clean.html

i though it was because I did not have the pulseaudio-module-bluetooth.i686

Now that everything is fixed its time to kick butt in LOL, see you guys there.

Ronin DUSETTE Lundi 12 Janvier 2015 à 8:31
Ronin DUSETTE
Admin

Lol. If it works, it works. :)


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts