Forums

GTA IV doesn't start

Auteur Réponses
wojtek88 Dimanche 11 Janvier 2015 à 14:33
wojtek88Anonymous

Hi guys,
I've decided to test GTA IV installation script. I am using Steam store version of the game.
Game was playable on Windows setup (some time ago, when I was using it ;) ).
My current setup main informations:
Ubuntu 14.10 64bit
Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
10 GB RAM
NVidia 540M (Optimus, 331.113 drivers, NVidia GPU session always in use)


When I give script a try, everything installs ok, shortcut is added to PlayOnLinux main window. When I start GTA IV using created shortcut, "Log in to Social Club" window pops up. No matter which option I choose (Play or Play (offline)), "Log in to Social Club" window dissapears, and nothing else happens.

Here is the output of the "Play (offline)" try:
[POL_Wine] Message: Running wine-1.3.23 LaunchGTAIV.exe (Working directory : /home/mateusz/.PlayOnLinux/wineprefix/GTAIV/drive_c/Program Files/Steam/steamapps/common/Grand Theft Auto IV/GTAIV)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonmac.com/fr/page-26-Winemenubuilder.html
Fontconfig error: Cannot load default config file
Fontconfig error: Cannot load default config file
Fontconfig error: Cannot load default config file
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file: No such file or directory
[POL_Wine] Message: Wine return: 0

here is the output of the "Play" try:
[POL_System_CheckFS] Message: Checking filesystem for LaunchGTAIV.exe
[POL_Wine] Message: Running wine-1.3.23 LaunchGTAIV.exe (Working directory : /home/mateusz/.PlayOnLinux/wineprefix/GTAIV/drive_c/Program Files/Steam/steamapps/common/Grand Theft Auto IV/GTAIV)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonmac.com/fr/page-26-Winemenubuilder.html
Fontconfig error: Cannot load default config file
Fontconfig error: Cannot load default config file
Fontconfig error: Cannot load default config file
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file: No such file or directory
Fontconfig error: Cannot load default config file
Fontconfig error: Cannot load default config file
Fontconfig error: Cannot load default config file
Fontconfig error: Cannot load default config file
[4669:4669:0111/141420:ERROR:desktop_window_tree_host_x11.cc(1547)] Not implemented reached in void views::DesktopWindowTreeHostX11::MapWindow(ui::WindowShowState)
Created new window in existing browser session.
[POL_Wine] Message: Wine return: 0

Before I've decided to create this topic I went trough similar topics on the forum and it looks like most of the issues are connected to sound card (and it is not the case here). Any help to run the game would be very appreciated.

Ronin DUSETTE Dimanche 11 Janvier 2015 à 19:08
Ronin DUSETTE
Admin

I don't see anything related to your sound card. I see an X11 error and you are missing a config file for your fonts. Though, I am not sure what else would be causing that. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
wojtek88 Lundi 9 Février 2015 à 9:54
wojtek88Anonymous

Hi Ronin,
Yesterday I have decided to give it one more try and for some reason now it works. I've tried to restart machine before but it didn't succeed, but for some reason now it works.

Now I have problem with controller, but I will start new thread with that issue.
Anyway, thanks for help.