Forums

Any full screen games

Keys not working

Auteur Réponses
Uselesslight Jeudi 12 Février 2015 à 6:38
UselesslightAnonymous

Hi guys, I'm having an issue with PlayonLinux, literally any game that I play, Fallout 2, diablo 2 etc..  With Play on Linux, if I have to use the CTRL or ALT buttons either:

A) in CTRL's case, nothing happens or;

B) in ALT's case, the dash opens in the game and pauses or crashes it.

 

I've spent a lot of time trying to find the issue anywhere else online and I can't seem to find any information on it.  Except for AOE2, which I fixed by creating some registry keys.

Ronin DUSETTE Jeudi 12 Février 2015 à 7:20
Ronin DUSETTE
Admin

Full computer specs, please. I have some issues in KDE like this, but there are easy workarounds. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Uselesslight Jeudi 12 Février 2015 à 7:26
UselesslightAnonymous

Lenovo Ideapad P580

Intel I7-3520

NVidia GT630M

Ubuntu 14.04 Unity

 

edit: I'm also running 32bit, by accident though haha..  I meant to do 64bit, but I clicked the wrong download link in the first place and I've been too lazy to correct it.

Edité par Uselesslight

Ronin DUSETTE Jeudi 12 Février 2015 à 7:42
Ronin DUSETTE
Admin

Hmm. Unity. If this is a laptop, then you will need the proprietary drivers for your Nvidia card, and you will want to be running Bumblebee, if you are not already.

http://bumblebee-project.org/

Otherwise it is just trying to use the built-in Intel iGPU in your i7. We want it using your Nvidia card with the proprietary drivers, so you will need that to do it. 

If you have that set up, then I suspect it is a problem with Unity and it's default keyboard shortcuts. On KDE, for instance, ALT is a major hotkey, so in order to make it work on a lot of apps, I have to use the WIN key in conjunction with it to basically escape it from the grasp of KDE. 

If that does not do anything, then go to Configure -> select virtual drive -> Configure Wine -> Display tab -> and attempt to emulate a virtual desktop, and uncheck the boxes for decorating and control windows with the window manager.

Start with all of that and let me know what you got. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Uselesslight Vendredi 13 Février 2015 à 3:38
UselesslightAnonymous

Hey again, I've now had the time to attempt to do the above instructions.

I went to the bumblebee project website and I followed the instructions to a T for the installation of Bumblebee.  I had one error that was corrected by running apt-get -f install.  Afterward I went to my additional drivers and chose the propietary version of my drivers and the light is green and no longer says I'm using an alternate software. 

 

However, I didn't see anything in my additional drivers that made any reference to Bumblebee whatsoever so I'm not exactly certain if it worked out right..  Should there be something there ie: "Using NVIDIA binary driver version 331.113 from nvidia-331 (proprietary, tested, bumblebee vX.Y)" ??

 

The reason I ask is because inside of the Fallout NV splash screen I can open up the options menu and choose which graphics adapter I want to use and the only thing in the dropdown is "Intel(R) Ivybridge Mobile" and my NVIDIA GT630M is not in the list.  One other thing to note about that is that during installation with PlayOnLinux, it asked me which graphics adapter I wanted to use and at that screen GT630M was in the list and it was selectable.

 

Moving on, sorry if I'm rambling a bit. 

I got fullscreen working though, despite the above info's. However ALT + CTRL do not work in game, ALT still opens the dash, even if I press the super key in conjunction with it..

 

I wonder though, is it possible to install an alternate desktop and config Wine to launch Fallout NV on the alternate desktop?  If that's possible, could I then prevent ALT + CTRL from being system keys and "force" them to work in the game window?

Ronin DUSETTE Vendredi 13 Février 2015 à 17:01
Ronin DUSETTE
Admin

 

Intel(R) Ivybridge Mobile" and my NVIDIA GT630M is not in the list. 

That is why you need Bumblebee working correctly. When it is installed, you can switch between your intel card and your Nvidia card. It has nothing to do with PlayOnLinux. You NEED to have bumblebee working if you want to use your nvidia card to play, even if you have the proprietary drivers installed, because bumblebee allows you to switch to your Nvidia card. 

You need to get that fixed before anything. If you are having issues installing it, check their forums and FAQs. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Uselesslight Samedi 14 Février 2015 à 4:08
UselesslightAnonymous

I got Nvidia-prime installed instead of Bumblebee, the GT630M is in the graphics list ingame now.  I had to reinstall the game before anything changed though.  Thanks for the help, it got me going in the right direction!
 

Ronin DUSETTE Samedi 14 Février 2015 à 7:52
Ronin DUSETTE
Admin

Excellent. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts