Tried updating PlayOnLinux but now it can't find 32bit OpenGL libs and WINE.

Auteur Réponses
freeroute Dimanche 22 Février 2015 à 19:33

Hi, so I had an earlier version (from 12.04 repo) of POL and saw that there was an update available.

I went to and copied every instruction for Ubuntu (precise), along with installing wine:i386. However, when I tried installing wine:i386 I got an enormous dependancy question from aptitude -

I thought aptitude was smarter than me so I chose Yes.

Afterwards, when I tried opening POL it first says the following:

PlayOnLinux is unable to find 32bits OpenGL libraries.

You might encounter problem with your games

Afterwards it says the following:

PlayOnLinux cannot find wine (from Wine)

You should install it to use PlayOnLinux

It is however updated to PlayOnLinux 4.2.5!

I have elementary OS Luna 64bit (which is basically Ubuntu 12.04, precise). With i5-3360 (Intel HD4000) and 16GB or RAM.

Edité par freeroute

Ronin DUSETTE Dimanche 22 Février 2015 à 19:39

You need to install the 32-bit drivers for you graphics card, multiarch-support, and install just regular ol' Wine. To be honest, you might need to reformat your system (with an updated distro. 12.04 is old (almost 3 years now), and not worth the effort of working with. Get something based off of 14.04, a new version of debian, or something newer than that. Trust me; it will fix a LOT of yours issues. 

Basically, apt uninstalled a ton of libraries, leaving in what most call "dependency hell". 

Personally, I would back up my home folder and reformat the system with an updated distro (Again, I prefer anything based of Ubuntu 14.04, but just any up-to-date distro will do), and then just install PlayOnLinux from the deb file, and let it pull in the dependencies you need. You will also need to apt-get multiarch-support and the i386 libs for your Intel card (32 bit mesa libs).

If you don't want to go that route, then you will need to work out the dep issues with your distro's forums (like askubuntu or something), as it falls out of scope for us. I still think a fresh install with a nice, new distro will make a huge difference. ESPECIALLY for your chipset.

Edité par RoninDusette

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Lundi 23 Février 2015 à 21:39

This has happened to me a few times when updating PlayOnLinux in Mint.  I would restart my computer and everything was fine again.

† Booman †
Mint 20.1 64-bit | Nvidia 460 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained