Forums

POL won't work after filesystem move

Constant PoL_Wine has crashed

Auteur Réponses
monsterrex Lundi 11 Mai 2015 à 3:39
monsterrexAnonymous

I had this problem many months ago when I first tried to use POL for games and just gave up but I now have realized that this is the only option for playing most games. After every install I have tried it gives me the error "PoL_Wine has crashed..." no matter what I do. This started after I moved all the PlayOnLinux directories to a external hard drive and linked them from their original file location. Before moving the fies it would give me a dialog about an incompatable file system and problems may persist but this was solved after the move.

Specs: Ubuntu 14.04 64-bit, Acer Chromebook 11 CB3-111-C670, 2gb RAM, Intel Celeron N2830 Dual Core @ 2.16GHz, Intel Bay Trail Graphics, 16gb SSD + Toshiba 1TB USB3.0 External HDD

Edité par monsterrex

booman Mardi 12 Mai 2015 à 1:05
booman

Yeah, this is a difficult one.  How did you go about linking to the external drive?

What file system did you format the drive as?

This is one reason why I went with the Acer Chrombook C710 because of the 320GB hard drive.  I know SolidState is faster, but 16GB just isn't enough space.

Have you tried doing a test and make a link to "wineprefix" folder in the 1TB drive and install a game in there? Even if you have to re-install all of your games, its better than not playing at all.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
monsterrex Vendredi 15 Mai 2015 à 3:07
monsterrexAnonymous

To link the file systems used the cp -av, then removed the files from the ssd with rm -rf, ending by using ln -s for the link to the external. Not sure how to answer how it's mounted but it's location is "/media/user/exthdd" I feel like it would be good to mention that it is used for my steam games which required it to be attached to the system (I forgot exactly how I mounted it). But on the linking of the "wineprefix" folder, it is already on the external as I have coppied and linked the whole ".PlayOnLinux" folder to a location on the external drive. Also I don't mind erasing/reinstalling as I have no games installed so whatever I can do to make it work is a valid option.

booman Vendredi 15 Mai 2015 à 20:04
booman

Linking the .PlayOnLinux might be the problem... I'm speculating of course because I'm no programmer.
Try re-installing PlayOnLinux so its back in /home/username/.PlayOnLinux
Then move the wineprefix to your external drive and make a link to it at /home/username/.PlayOnLinux/

This way PlayOnLinux will install all the games in the wineprefix on your external drive.

I'm just guessing of course, but in theory it should work.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Vendredi 15 Mai 2015 à 20:14
Ronin DUSETTE
Admin

This should cover it right here. A lot of people have used this method and it should just work. 

http://wiki.playonlinux.com/index.php/How_to_move_PlayOnLinux_virtual_drives_to_another_disk


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Vendredi 15 Mai 2015 à 20:23
Ronin DUSETTE
Admin

Also, in the future, please post your debug log in your first post as well. :) It helps not have to ask for it if we need to see it.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
monsterrex Mercredi 20 Mai 2015 à 0:20
monsterrexAnonymous

The method you suggested did not work, it came up with the same error message as in previous attempts. Looking at the debug files the only thing that sicks out is "wine: /home/user/.PlayOnLinux//wineprefix/osu_on_linux is not owned by you" which seems to be the problem, I can post the whole debug file if need be but this seems to be the only error.

Update: I have tried both what the wiki recommends and the "/wineprefix" move, both result the same.

Edité par monsterrex

booman Mercredi 20 Mai 2015 à 0:24
booman

Yes, post the debug anyways.

Apparently your external drive doesn't have the proper permissions to allow PlayOnLinux to run games.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
monsterrex Mercredi 20 Mai 2015 à 1:00
monsterrexAnonymous

[05/19/15 17:59:01] - The following file is located on a noexec mounted filesystem.\nIt might prevent wine from working\n\n/home/monsterrex/.PlayOnLinux/

This is the only message that comes up in the "default" debug section. This is with it in the normal location with the "wineprefix" folder moved.

Edité par monsterrex

booman Mercredi 20 Mai 2015 à 1:07
booman

Found this post on reddit

Here's how to fix it:

  1. Open Play On Linux
  2. Click on the Tools drop down menu
  3. Open PlayOnLinuxConsole
  4. When the console opens type: POL_Config_Write NO_FSCHECK TRUE
  5. Hit enter and close the console.
  6. You should now be able to install windows files using Play On Linux since this disables the FS Check.

Cheers! Hope this helps! I have the acer c720p and this was driving me crazy..


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
monsterrex Mercredi 20 Mai 2015 à 4:01
monsterrexAnonymous

Still giving me the "POL_Wine has crashed" error after any fix. I'll take up working on this on my own or just use wine from now on. This thread can now be closed.

Edité par monsterrex

petch Mercredi 20 Mai 2015 à 6:45
petch
Développeur

That method has already been reported to work (not to mention I tested it in the first place ;) )

Some programs can fail under Wine when used from a filesystem mounted "noexec", old gog installers for one (haven't tried with newer ones). They crash in a non-obvious way, actually it took me a while to find out what was wrong, so this check is to prevent people from wasting time in similar cases.

Edité par petch