Forums

Star wars republic commando not starting properly.

Auteur Réponses
giffmemana Mercredi 22 Juillet 2015 à 11:22
giffmemanaAnonymous

I installed the game through linux and when it starts I hear the game music but not the game itself. The resolution is changed to 800x600 and I don't see the game itself (just the desktop which is really bugged). Kinda like my problem with jedi academy which I fixed by installing the binaries from here (in the HOWTO):

https://appdb.winehq.org/objectManager.php?sClass=application&iId=1713

Maybe it's the same kind of  bug ? The driver has so many extensions it makes the game crash ? If so how do i fix it ? Do I need to start it prefixed with the line from the HOWTO ? If so how do I do that ? Thanks you in advance for your help.

 

Wine version 1.7.46, Linux mint 17.1, playonlinux 4.2.2

PC specs: amd x2 250, nvidia gt 220, 4gb ddr3 ram.

Driver version : nvidia 331.133 (the recomended one from the driver manager)

Edité par giffmemana

petch Mercredi 22 Juillet 2015 à 11:31
petch
Développeur

What you can try is

Configure button > (select game shortcut) > Miscellaneous tab > Commands to run before the program:

export __GL_ExtensionStringVersion=17700

 

giffmemana Mercredi 22 Juillet 2015 à 15:49
giffmemanaAnonymous

But on that virtual drive I have many games installed through steam. How can I do it just for republic commando ? It's just a shortcut for steam and all the games are there.

Edité par giffmemana

petch Mercredi 22 Juillet 2015 à 17:47
petch
Développeur

I can confirm that this setting is per-shortcut (and that's why I asked you speficically to select a shortcut and not a virtual drive)

giffmemana Mercredi 22 Juillet 2015 à 18:03
giffmemanaAnonymous

I see, sorry. But on my virtual drive I have only one icon - the steam one. I tried to add a republic commando icon by click on "make a new shortcut from this virtual drive" added SWRepublicCOmmando.exe (added the thing in miscelanious) and then I got an error "Failed to find steam". How can I fix this ?

Edité par giffmemana

giffmemana Jeudi 23 Juillet 2015 à 11:12
giffmemanaAnonymous

Update:

It's not SWRepublicCommando.exe it was LaunchRC.exe but now when I start the game I only get the launcher and when I click on the buttons nothing happens.