Forums

Skyrim: Crackling Sound

Auteur Réponses
MickRegister Vendredi 7 Aoüt 2015 à 9:52
MickRegisterAnonymous

Hello,

I simply cannot get the sound crackling fixed on my Fedora Box (4.1.3-200.fc22.x86_64). I am using pulse on the system and the error is:

ALSA lib pcm.c:7905:(snd_pcm_recover) underrun occurred

I already tried quite a lot, including

- Setting frangments in /etc/pulse/daemon.conf:

; default-fragments = 5
; default-fragment-size-msec = 2

- changing "/etc/pulse/default.pa" as described in http://thehumble.ninja/2014/02/06/fixing-alsa-lib-pcmc7843snd_pcm_recover-underrun-occurred-while-keeping-pulseaudio-in-your-system/

 

But nothing worked up to now. Can somebody help me on this please?

Greets,

Michael

petch Vendredi 7 Aoüt 2015 à 10:41
petch
Développeur

Interesting article about making PulseAudio use dmix (so that Wine can use ALSA directly in parallel, as I understand).

But maybe the problem is elsewhere? Audio buffer underrun means that audio buffers were not refilled fast enough so eventually the card had nothing left to play; Maybe your system (hardware and/or drivers) is not powerful enough for the game options you selected, and can't keep up?

 

MickRegister Vendredi 7 Aoüt 2015 à 11:28
MickRegisterAnonymous

I switched down the graphics detail level, but same thing. Beside, the problem directly comes up when launching the game: There is only the logo with some simple background sound and already at this point, I have the crackling sound.

booman Vendredi 7 Aoüt 2015 à 19:31
booman

Try this setting:

change default-fragment-size-msec = 10

to default-fragment-size-msec = 5

That works for me.  You will need to restart or kill pulseaudio to hear if it worked.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
MickRegister Lundi 10 Aoüt 2015 à 9:16
MickRegisterAnonymous

I solved it with via the settings in /etc/pulse/daemon.conf ("default-fragments" and "default-fragment-size-msec"). Up to now, I only found some guesses how to configure this, but here is a very interesting link:

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Glitches.2C_skips_or_crackling

Search for the section beginning with "Setting the default fragment number and buffer size in PulseAudio". Sure, you have to calculate a bit, but I guess this is not complicated and with the settings I found out via this, Skyrim works fine up to now.

Thanks a lot, I will mark this thread as solved.

 

booman Lundi 10 Aoüt 2015 à 17:26
booman

Awesome!  Glad you got it working!


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained