Wine crashes when installing non-listed program

Problem when initialising a virtual directory

Auteur Réponses
Skava Jeudi 10 Mars 2016 à 15:14

Linux Kernel: 3.16.0-4-amd64

Linux Distribution: Bunsen Labs

Distribution Release: 8.2

POL Version: 4.2.5

Laptop Specs: Intel Centrino Core Duo, 2 GB Ram, 80GB Storage

Hello all, sorry if this has been asked before. I'm having a problem where I can't install any programs due to the wine version not being set up properly. Basically, when the program asks which version of wine I want to use (which I installed before hand via Tools->Manage Wine Versions) the program gives me an error message saying that wine has crashed. I've launched the program through console and notice the missing directory error message, but I honestly don't know what to do from there. Any help will be appreciated

chokey@debian:~$ playonlinux
Looking for python... 2.7.9 - selected
[main] Message: PlayOnLinux (4.2.5) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_System_CheckFS] Message: Checking filesystem for /home/chokey/.PlayOnLinux/
[main] Message: Filesystem is compatible
[maj_check] Message: List is up to date
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[POL_Config_Write] Message: Config write: MANUAL_INSTALL_INCREMENT 7
[POL_SetupWindow_Init] Message: Creating new window for pid 16330
[POL_SetupWindow_menu] Message: menu answer: Install a program in a new virtual drive
[POL_SetupWindow_textbox] Message: textbox answer: sumatra
[POL_Wine_SelectPrefix] Message: Selecting prefix: sumatra
[POL_SetupWindow_checkbox_list] Message: checkbox_list answer: Use another version of Wine~Configure Wine
[POL_SetupWindow_menu] Message: menu answer: 1.9.5
[POL_System_SetArch] Message: POL_ARCH set to x86
[POL_SetupWindow_menu_num] Message: menu_num answer: 0
[POL_System_SetArch] Message: POL_ARCH set to x86
[POL_Wine_PrefixCreate] Message: POL_WINEVERSION is already set to 1.9.5. Using it
[POL_Wine_PrefixCreate] Message: Creating prefix (1.9.5)...
[POL_Wine_PrefixCreate] Message: Using wine 1.9.5
[POL_Wine_InstallVersion] Message: Installing wine version path: 1.9.5, x86
[POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86
[POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.9.5
[POL_Wine] Message: Running wine-1.9.5 --version (Working directory : /usr/share/playonlinux/python)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
/usr/share/playonlinux/lib/wine.lib: line 527: /home/chokey/.PlayOnLinux//wine/linux-x86/1.9.5/bin/wine: No such file or directory
[POL_Wine] Error: Wine seems to have crashed

If your program is running, just ignore this message.
Skava Samedi 12 Mars 2016 à 15:08

Ok I believe I solved it with a bit of extra reading. I had a look in the log file (.PlayOnLinux/wineprefix/Sumatra/playonlinux.log) and it mentioned something about adding a multiarch thing, can't quite remember nor am I able to find the same log file since I shortly deleted aftwards (not the smartest thing I did). Also not that Sumatra may not be what you'll find since that's the software I was trying to install.

I had to do something like:

sudo dpkg --add-architecture:i386

Although that isn't exactly what I did.

With a bit more reading, I've found this (which I should've found earlier) Since I'm on a debian based distro, I used the following and it worked out for me:

sudo dpkg --add-i386

sudo apt-get update

sudo apt-get install wine:i386
Evilmummy Samedi 19 Décembre 2020 à 18:52

Sudo dpkg --add-i386 not working for me

garyartista Mercredi 29 Décembre 2021 à 16:32

When I tried your solution, I get the following


E: Package 'wine:i386' has no installation candidate