Command & Conquer 3 Issues

Script won\'t download the patched version of Wine

Auteur Réponses
aegistalons Dimanche 27 Avril 2008 à 19:02

I'm new to PlayOnLinux. Looks like an amazing program. I want to install CNC3, but its having an issue.

When it gets to the part to download the patched version of Wine, I hit next. It then says "Click on download to start", which I do and it just sits there. I let sit for 20 minutes and sit nothing.

Any ideas?
Ghostofkendo Vendredi 2 Mai 2008 à 1:29

Hi aegistalons,

It's strange, did you tried once again at least?
Because, I tried to download the patched version of Wine (manually, I didn't used the script because I don't have CnC 3) and it worked.

So try again and if it still doesn't work, do like me:
- download manually the patched Wine HERE.
- once it's done, move it to ~/.PlayOnLinux/WineVersion
- Continue the installation as if the script downloaded patched Wine normally.

katula Mardi 6 Mai 2008 à 6:08

I was running into the same issue, and after following the above steps I was able to get it to install without major issue. When I launch the game using the 0.9.58-cnc3 version, the cursor comes up but I have no menu text? All text in the game is blank, the menu outlines are there, just no text. If I try launching with 0.9.58 I am able to see all the menu/game text, but no cursor. Quite a predicament, any suggestions as to a possible fix?
GNU_Raziel Mardi 6 Mai 2008 à 13:18

Install msttcorefonts and freefonts with you package manager.
If it's still do not work, install fontforge and try again.

This game is still definitely problematic since it require specific patches that break playability with other games, so using a specific patched and compiled wine version is, for the moment (let's hope wine dev team will find a way to fix it), the only way to play cnc3 with cursor and lan play...
katula Vendredi 9 Mai 2008 à 3:14

Sorry for the delay in status update here. It took a while to get things to work effectively .

Problematic? Heh, that was an understatement.

So to start off, I tried the font packages you advised without success. Then I proceeded to pull down the wine-0.9.58 source as well as the patch files, compiled, still only getting cursor without any game text. So then I started pulling down a few different versions of wine and almost had success with 0.9.38 (this was the version where the x11drv file was patched to bypass animated cursor rendering and instead use the standard mouse), the only problem was that I had no audio.

Somewhere during the constant reading over the previous days I finally actually read what I was reading as opposed to just scanning down to the parts I needed and downloaded the DEB package they have available with the fixes included for 0.9.61 from

Now with this version I was able to launch CNC3 and get both cursor and graphics, but no sound (haha). It seems like there's an issue with Alsa not playing well within the PlayOnLinux wrapper, was getting errors from mixer.c that were apparently an issue with wine fixed many many versions ago.

So next I basically installed the package to the standard locations within my OS (/usr/local/...., etc) and I was able to launch the game with animated cursors, menu text, and sound support. But other than my initial frustration I really enjoyed working through this issues and coming out with a fully functioning playable CNC3 under linux.

However, my issues over the past few days has still not changed my opinion of POL and I would like to thank Raziel and the entire development team for putting this together. I find the entire package overall to be fairly rock solid, and after a few days of tweaking, very intuitive and easy to work with. Thanks for making my head spin for these past few days, I learned a lot and look forward to getting other games running with this software.
Daseinhorn Jeudi 5 Juin 2008 à 5:59

I do have the missing install text issue, and the referred font packages are already installed to the latest version. I use wine 1.0RC3 on Ubuntu Studio 8.04 and the latest PlayonLinux, and I am trying to install C&C3 with the custom prefix which is offered with PlayonLinux. Any ideas for solutions?

(en passant les mecs, je suis francophone, donc si vous voulez répondre en francais, faites-le)
Dabenet Samedi 28 Juin 2008 à 15:41

I have the same problem...
I have installed 0.9.58 pathched wine, but i have no cursor...
The game install only in english, i'm italian!!! How can i install italian language? I have no audio too..

Ubunt 8.04 64bit, Geforce 8600mobile

Edité par Dabenet