Forums

Arabic typing on Office 2010 POL

Need help to type in arabic

Auteur Réponses
OrionExpress Mardi 1 Novembre 2016 à 21:49
OrionExpressAnonymous

Hello,

I installed Office 2010 on PlayOnLinux 4.2.10 and it works correctly.

There's one thing that doesn't work: the arabic language support.

The documents written in arabic were not displayed correctly (the characters were not related). I searched the internet and I have done a change inside POL:

I opened the Microsoft Word configuration -> Miscellaneous -> Launch a shell. Then I typed POL_Wine_AutoSetVersionEnv. Then I launched Winetricks inside the Office 2010 Prefix in POL and I installed usp10.dll. Then I opened POL's Wine config and I added usp10.dll in the override section as Native.

Now the arabic documents are displayed correctly but it didn't solve all the problem. I can't type arabic correctly (characters are not related).

So usp10.dll is OK for displaying arabic correctly but it's not sufficient to type in arabic (or I missed something).

I tried to add arabic in Word's configuration, but the language appears as "keyboard layout = not enabled (or not activated)". In a real Windows installation, clicking on that "not activated" text opens "Advanced text services" (for xp, "Text services and Input languages" in more recent Windows), but in POL's Word it does nothing.

Can you please help me to get arabic typing working? Is there a way to get this component of the control panel activated? Is there something in the registry that needs to be changed? Is there another way to solve this problem (without looking for cpl, rundll32 and shell32 files)?

Thank you.

OrionExpress Mercredi 2 Novembre 2016 à 19:38
OrionExpressAnonymous

Thank you very much guys for the replies...

My problem is related to RTL languages support, it has been discussed here for example, with no definitive solution:
https://www.playonlinux.com/fr/topic-11298-Hebrew_Font_is_messed_up.html

I finally understood how it works and I found a workaround.

PlayOnLinux uses the system locale settings and apply them to the applications installed on it.

For example, if your Linux system is in French, then POL's Office will activate only the french for the keyboard layout. (to know your locale settings, just type the command "locale" in a console, it will return "LANG=fr_FR.UTF-8" [if in french] and other lines).
If your system is in arabic ("locale" cammand indicates LANG=ar_MA.UTF-8 [or another arabic variant such as ar_SA]), then POL's Office will activate only the arabic for the keyboard layout.

In order to launch Word in arabic without changing the system locale settings, you have to create a shortcut for each language.

1) For the arabic Word shortcut you need to indicate the following command:
LC_ALL=ar_MA.utf8 /usr/share/playonlinux/playonlinux --run "Microsoft Word 2010"

Change "ar_MA" with the language and variant you want, it works with other RTL languages.

2) For the french Word shortcut you need to indicate the following command:
LC_ALL=fr_FR.utf8 /usr/share/playonlinux/playonlinux --run "Microsoft Word 2010"

If the shortcut contains only the following command /usr/share/playonlinux/playonlinux --run "Microsoft Word 2010", it will pick the system locale language and activate the corresponding keyboard only.

At the end, you will have two Microsoft Word 2010 shortcuts (give them different names), one for the RTL language and another one for the latin language, so you can type in the language you want without changing the system locale settings (nor reboot the session) each time. It's not a definitive solution because I'm unable to activate both languages at the same time, and I don't know if it's possible, because the "Advanced text settings" are not implemented in Wine (no corresponding cpl files), nor in PlayOnLinux.

I hope this will help people that need to use both latin and RTL languages in Microsoft Word 2010 on PlayOnLinux.

Bye.