Can't switch to bluetooth headset

Auteur Réponses
Feketekertekereje Lundi 2 Janvier 2017 à 14:46


I use a Sony ZX330BT wireless headset. It works fine in Xubuntu (there are some minor issues, but I don't think they matter in this case), but if I run a program through PlayOnLinux, then it uses the built-in speakers of my netbook. From what I read wine is supposed to use the default audio device, and I did switch it to my wireless headset. I also tried to switch to one of the other two options in the configure wine menu (namely HDA Intel MID - CX20585 Analog and HMA Intel MID - HMDI 0), but they do nothing. They appeared after I switched from Windows XP to Windows 7 mode.

Feketekertekereje Lundi 2 Janvier 2017 à 14:52

So pressing the tabulator sends the message. Unfortunately I wasn't aware of that, and so I accidentally sent the message in an incomplete format.

English isn't my first language, and upon reading through my message again I've realized it can be easily misinterpetended. So, I have sound with programs run through PlayOnLinux when my default audio devices are my built-in speakers, but I don't when the default device is the headset. Does wine need some components installed?

MonkeyMind Mardi 3 Janvier 2017 à 11:00

Hello  :)
I had similar "problem" with opensuse, pulse audio and my bluetooth headset. It setted built-in speakers as default output and when I connected my bt it ignored it. I had to change pref manually  and set higher priority in pulseaudio settings. At least check it.
If you can post the message and run playonlinux in the terminal. :)

Feketekertekereje Mardi 3 Janvier 2017 à 12:28

Thanks for the answer. Is there a way to select the default device in the PulseAudio menu that I just can't find? I've actually turned off the built-in speakers there, and it says that the only audio device now is the headset. Yet programs run through PlayOnLinux still use the speakers. This is rather unsettling. Should I try to change the default device through command lines somehow?

Might be related,  I have to delete the headset from the list of available devices every time I start the system if I want it to work properly.