POL instance crashing now

Well it had worked!

Auteur Réponses
jenschnoor87 Samedi 3 Juin 2017 à 23:36

So I had Origin (and was launching Sims 4 from it) running perfectly fine a couple of weeks ago and now it's crashing before it can even be launched. This is the debug printout I get:

[06/03/17 17:15:17] - Running wine-1.8 Origin.exe (Working directory : /home/jen/.PlayOnLinux/wineprefix/sims3/drive_c/Program Files/Origin)
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32ed84 1 C) semi-stub
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x98cde8 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x98cc28 1 C) semi-stub
fixme:system:SetProcessDPIAware stub!
fixme:msg:ChangeWindowMessageFilterEx 0x10058 4a 1 (nil)
fixme:msg:ChangeWindowMessageFilterEx 0x10058 112 1 (nil)
err:module:import_dll Library Qt5Svg.dll (which is needed by L"C:\\Program Files\\Origin\\imageformats\\qsvg.dll") not found
err:ole:CoInitializeEx Attempt to change threading model of this apartment from apartment threaded to multi-threaded
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:wbemprox:client_security_SetBlanket 0x7bf69ae8, 0x1d7fc0, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7bf69ae8
fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  195
  Current serial number in output stream:  196

I have the current version of POL 4.2.10 and it had all been working fine on Wine 1.8 with Windows XP. Any help would be appreciated because I'm not all that techy, although I have gotten pretty good at opening and pasting into terminals.

AMD FX-4100 Quad | 16GB RAM | Linux Mint 18 | GeForce GT 740
ImperatorS79 Dimanche 4 Juin 2017 à 8:50

Maybe an update of origins, did you try a more recent version of wine ? Like 2.7, 2.8, or 2.9 ? You can also try staging version of wine after.

POL5 is here ! ->
jenschnoor87 Lundi 5 Juin 2017 à 4:44

I just tried 2.7, 2.8, 2.9 and their respective staging options. It's still crashing.

And now this is also listed in the debug in addition to what was already there:

err:module:load_builtin_dll failed to load .so lib for builtin L"winebus.sys": cannot open shared object file: No such file or directory
err:winedevice:async_create_driver failed to create driver L"WineBus": c0000142

AMD FX-4100 Quad | 16GB RAM | Linux Mint 18 | GeForce GT 740
ImperatorS79 Mardi 6 Juin 2017 à 9:08

Normally on ubuntu (for example) it's (no more



sudo apt-get install libudev0:i386

But i doubt it will work.

Seems you also had some bugs with the context creation (maybe linked to OpenGL)

Normally it should run fine (platinum on appdb):


Try that (from appdb):

In winecfg, switch to Windows 7 and use wine-staging-nine "(gallium nine ?)"

In Options.txt, set fullscreen = 0, or it will crash on startup.


If the game crashes on launch, be sure that "Origin In-Game" is disabled in Origin's settings.

Origin > Application Settings > Origin In Game > Uncheck "Enable Origin In Game"

PS : if it's due to a maj of Origins, we will have to wait...

PS2: to install origin I needed a library to unpack dxtn texture (i see that in the log)

so don't forget to install it :

sudo apt-get install libtxc-dxtn-s2tc0

PS3 : maybe you will need this

Download (legacy OriginThinSetup.exe).
Create a fresh wineprefix (32-bit).
Run the installer and leave the default options.
When Origin launches it will tell you that "Your update could not be completed.".
Download and put the contents into your_wine_prefix/drive_c/Program\ Files/Origin/ , so that that folder contains a Origin.exe file.
You can then start this Origin.exe and log in.

PS4 : I finally manage to run origin with the tricks above

Edité par ImperatorS79

POL5 is here ! ->