Forums

HELLO! I need help, any given would be greatly welcomed. And in advance, Thank you.

I'm just trying to install a game from the program, (PoL) and it keeps crashing.

Auteur Réponses
Jump to the page: 1 - 2
haloboy11721 Vendredi 21 Juillet 2017 à 16:23
haloboy11721Anonymous

Okay so, I am a little new to the site/Linux, (Not all that new to Linux though, I actually know more than the average noob.) so please forgive me for any ignorance I give.

I Would like to just say first of all. Thank you for taking the time to read this. And now on to the request, and my basic info to help you guys out with my question. (of which is a game I am trying to install, and it crashing.)

My Linux OS version is. (  Ubuntu 16.10  )
Processor. (  AMD E-350 Processor x 2  )
Graphics. (  Gallium 0.4 on AMD PALM (DRM 2.46.0 / 4.8.0-59-generic, LLVM 3.8.1)  )
OS type. (64-bit)
Disk(space) (488.4 GB)
And lastly my PoL version. (4.2.11)

Now sadly I do not know how to access the logs for the download, so telling me how will be a big help to me.

This is AT BEST what I currently have from what it says from the error.

"Error in POL_Wine
Wine seems to have crashed

If your program is running, just ignore this message"

and after that, when I hit next, this is what shows up in the error box. (it's not really important.)

"Error in POL_Shortcut
Binary not found: PathOfExile.exe
Have you installed the program to the default location?"

And that is sadly it. (That is until I figure out how to open the logs.)

And thanks to some light/medium research, I have found out that I most likely if not do, have wine installed wrong/not fully. (which I did uninstall and then reinstall.) So any and all help is greatly appreciated, and lastly, Thank you.

Cheers.

booman Samedi 22 Juillet 2017 à 1:40
booman

Make sure to update to PlayOnLinux 4.2.12

Then Run Path Of Exile with "debug" instead of "Run"  then you will see all the errors


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Samedi 22 Juillet 2017 à 2:32
haloboy11721Anonymous

This is the best I could get. Sorry if it's not what you're looking for, I just could not follow your instructions to the letter. Sorry about that.


[07/21/17 20:24:01] - Running wine-1.7.55 --version (Working directory : /home/jordan/.PlayOnLinux/shortcuts)
wine-1.7.55

PlayOnLinux logfile
-------------------
Date: 07/21/17 20:24:01

> PlayOnLinux Version
  4.2.12
> uname -a
  Linux jordan-EL1360G 4.8.0-59-generic #64-Ubuntu SMP Thu Jun 29 19:38:34 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
> lsb_release -a
 
> wine --version
  wine-1.7.55
> POL_WINEVERSION
  1.7.55
> WINEPREFIX
  /home/jordan/.PlayOnLinux//wineprefix/pathofexile
> Distribution
  Ubuntu 16.10
> glxinfo \| grep rendering
  direct rendering: Yes
> glxinfo \| grep renderer
      GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Gallium 0.4 on AMD PALM (DRM 2.46.0 / 4.8.0-59-generic, LLVM 3.8.1)
> OpenGL libs (Direct rendering testing)
  32bits direct rendering is enabled
  64bits direct rendering is enabled

[07/21/17 20:24:42] - Running wine-1.7.55 cmd /c echo %ProgramFiles% (Working directory : /home/jordan/.PlayOnLinux/shortcuts)
C:\Program Files
[07/21/17 20:24:59] - Running wine-1.7.55 msiexec /i /home/jordan/.PlayOnLinux//tmp/pathofexile/PathOfExileInstaller.msi (Working directory : /home/jordan/.PlayOnLinux/tmp/pathofexile)
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet

 

booman Samedi 22 Juillet 2017 à 2:40
booman

There should be a lot of fixme: and err:

have you tried a newer version of Wine like 2.12-staging?

Also, make sure you have the newest version of PlayOnLinux 4.2.12

Sometimes the PlayOnLinux installers (scripts) are old and something is broken, so I will do a manual installation instead.  Are you using Steam or Origin?


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Samedi 22 Juillet 2017 à 2:46
haloboy11721Anonymous

Okay well. I'm using the newest version of PoL, (I updated it.) and I have not tried that bit with wine yet, (just did, still did not work.) and I plan on using steam as much as I can.

Edité par haloboy11721

booman Dimanche 23 Juillet 2017 à 22:30
booman

I normally use manual installations, but it requires a bit more knowledge of the games you want to run.  It requires more steps to setting up a virtual drive and select which version of Wine you want to use.  Then you install the packages the game needs to run.

Which games are you wanting to play?


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Jeudi 27 Juillet 2017 à 15:36
haloboy11721Anonymous

Sorry for the long wait for my reply, I was offline due to me having computer problems, but I think I fixed it, however, I must sadly say, That I am currently running Ubuntu 14.04 LTS as my OS, (I will update it soon.) and now I have nothing installed that I did before. (Other than steam.) I personally don't mind, so don't worry. Anyway, back to the question. I mostly plan on JUST AND ONLY playing POE, which is the only thing I really want to play honestly.

booman Jeudi 27 Juillet 2017 à 17:35
booman

Cool, I have been playing Path of Exile with my wife and we are stuck at the boss in Chapter 3. He is impossible!

Just make sure you use the newest "staging" version of Wine and your video drivers need to be up-to-date as well.  Are you using Intel, Nvidia or AMD?


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Vendredi 28 Juillet 2017 à 1:44
haloboy11721Anonymous

I am using AMD. And just for reference. Pfffff. sorry, this is kind of funny but, I put all my computer info at the top. it says this too. XD.


"Graphics. (  Gallium 0.4 on AMD PALM (DRM 2.46.0 / 4.8.0-59-generic, LLVM 3.8.1)  )"


hehe, yeah. anyway. I want to also say, thank you for your help that you've given me so far.

Edité par haloboy11721

booman Vendredi 28 Juillet 2017 à 1:51
booman

sorry, I completely missed that.

I'm pretty sure there is a Gallium wine version that will be very beneficial for your video card.  I've never used it, so I can't give you any tips.  Just look up "Gallium 9" and Wine related topics.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Vendredi 28 Juillet 2017 à 1:53
haloboy11721Anonymous

Just a quick update. I looked at my graphics real quick, instead of relying on that old one. and well. take a look at this.

 

Gallium 0.4 on AMD PALM (DRM 2.43.0 / 4.4.0-88-generic, LLVM 4.0.0)

 

It says that I have DRM 2.43.0 /4.4.0-88-generic, instead of my DRM 2.46.0 / 4.8.0-59-generic. which made me feel like I've just gotten a degrade, and I now have LLVM 4.0.0, instead of the old LLVM 3.8.1 so I feel a little bit better. :D

Edité par haloboy11721

booman Vendredi 28 Juillet 2017 à 1:59
booman

But will it play games?

Are you able to play any games on your laptop at all?


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Vendredi 28 Juillet 2017 à 2:28
haloboy11721Anonymous

Well. On steam, yes. I don't know about PoL though because it always crashes during the installation process, (for the games) also, I have a desktop, not a laptop. XD hehe. just wanted to let you know.

Edité par haloboy11721

booman Vendredi 28 Juillet 2017 à 16:59
booman

Oh cool, I didn't realize this was a desktop.

So all games you have tried to install crash during the installation?

I would try re-installing PlayOnLinux, maybe something is missing from the initial installation.  Also, I normally install Wine from the Mint package manager first, then I download the PlayOnLinux installer and install it.  That is how I do a fresh installation.

Sometimes when PlayOnLinux is first launched, it warns about xterm, so you might want to install xterm from your package manager as well.

Sorry this is all such a pain.  Once games will install, it should be fairly easy to install more games.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Samedi 29 Juillet 2017 à 2:09
haloboy11721Anonymous

Sounds good, I'll try that.

haloboy11721 Samedi 29 Juillet 2017 à 2:52
haloboy11721Anonymous

Yes, they all do crash. (so far anyway.)

I don't think anything is, but I did anyway just incase.

Xterm is already installed on my computer by defalt, and I don't know were to find that package anyway. (a link would be nice. :D)

I can only hope. Also, can you maybe give me a step-by-step guide on how to get into the logs. That would make this a lot more easy, you know, knowing what the problem is and all. hehe... yeah.

booman Dimanche 30 Juillet 2017 à 1:08
booman

Logs is pretty easy, but it usually works when a game is already installed.  You can launch it with "Debug" instead of "Run"

One way around this when you are installing a game is to created the wineprefix (Virtual Drive) ahead of time and put the installer in the drive_c directory.

  1. Click Configure
  2. Click "New" on the left side
  3. Name the virtual drive
  4. Navigate to the drive_c (path:  /home/username/.PlayOnLinux/wineprefix/game/drive_c)
  5. Copy/paste your installer in the drive_c
  6. Back to PlayOnLinux Configure
  7. Select new Virtual Drive
  8. General Tab
  9. Click "Create a shortcut in this virtual drive"
  10. Browse to the installer in drive_c
  11. Click Next
  12. Give it a Name
  13. Select "I don't want to make another shortcut"
  14. Close Configure
  15. Select the installer
  16. Click "Debug" left side

Now it will try to install the game and show you a log window with all the errors


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Dimanche 30 Juillet 2017 à 12:28
haloboy11721Anonymous

I think I got it. here you go.

 

[07/30/17 06:11:55] - Running wine-1.7.55 cmd /c echo %ProgramFiles% (Working directory : /usr/share/playonlinux/python)
C:\Program Files
[07/30/17 06:21:07] - Running wine-1.7.55 winepath -u C:\\users\\jordan\\Desktop (Working directory : /home/jordan/.PlayOnLinux/wineprefix/Pick_me./drive_c)
/home/jordan/.PlayOnLinux//wineprefix/Pick_me./dosdevices/c:/users/jordan/Desktop
[07/30/17 06:23:12] - Running wine-1.7.55 PathOfExileInstaller.exe (Working directory : /home/jordan/Downloads)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:EventRegister {5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x46a030, 0x46a048
fixme:advapi:EventSetInformation 2, 0x4677f8, 43
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:advapi:DecryptFileW (L"C:\\users\\jordan\\Temp\\{715E0B25-DE93-438A-8DEF-60D9FCB89AC7}\\", 00000000): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:EventRegister {5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x46a030, 0x46a048
fixme:advapi:EventSetInformation 2, 0x4677f8, 43
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:advapi:DecryptFileW (L"C:\\users\\jordan\\Temp\\{4925A6E3-6498-4F44-BA8C-C1D2E6B2DBC5}\\", 00000000): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:EventRegister {5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x10001123, 0x1002a200, 0x1002a218
fixme:advapi:EventSetInformation 2, 0x100274b8, 43
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0x1562a4,0x156078): stub
fixme:shell:SHAutoComplete stub
fixme:advapi:DecryptFileW (L"C:\\users\\jordan\\Temp\\{4925A6E3-6498-4F44-BA8C-C1D2E6B2DBC5}\\", 00000000): stub
fixme:exec:SHELL_execute flags ignored: 0x00000100
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:EventRegister {5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x46a030, 0x46a048
fixme:advapi:EventSetInformation 2, 0x4677f8, 43
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:wuapi:automatic_updates_Pause
fixme:advapi:DecryptFileW (L"C:\\users\\Public\\Application Data\\Package Cache\\{90A4562F-D4A1-4B65-906D-41F236CF6902}v2.6.3.15212\\PathOfExileInstaller.msi", 00000000): stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister 0: stub
fixme:wuapi:automatic_updates_Resume
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)

booman Lundi 31 Juillet 2017 à 1:10
booman

Hmm, I don't see anything significant.  

When you setup the virtual drive did you install these packages first?

  • POL_Install_corefonts
  • POL_Install_d3dx9
  • POL_Install_d3dcompiler_43
  • POL_Install_msvc100
  • POL_Install_Registeredfonts
  • POL_Install_riched20
  • POL_Install_Tahoma
  • POL_Install_vcrun2010

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
haloboy11721 Lundi 31 Juillet 2017 à 2:03
haloboy11721Anonymous

Same thing, though this time I attempted repair instead. (yes, just in case I reinstalled them. No luck.)

 

[07/30/17 19:58:38] - Running wine-1.7.55 PathOfExileInstaller.exe (Working directory : /home/jordan/Downloads)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:EventRegister {5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x46a030, 0x46a048
fixme:advapi:EventSetInformation 2, 0x4677f8, 43
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:advapi:DecryptFileW (L"C:\\users\\jordan\\Temp\\{5B6CA312-6E32-48E0-973A-41986F31D7A6}\\", 00000000): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:EventRegister {5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x46a030, 0x46a048
fixme:advapi:EventSetInformation 2, 0x4677f8, 43
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:advapi:DecryptFileW (L"C:\\users\\jordan\\Temp\\{C69E913D-2AEE-4ECC-886C-7725AD681FEE}\\", 00000000): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:EventRegister {5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x10001123, 0x1002a200, 0x1002a218
fixme:advapi:EventSetInformation 2, 0x100274b8, 43
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0x15630c,0x155f00): stub
fixme:shell:SHAutoComplete stub
fixme:advapi:DecryptFileW (L"C:\\users\\jordan\\Temp\\{C69E913D-2AEE-4ECC-886C-7725AD681FEE}\\", 00000000): stub
fixme:exec:SHELL_execute flags ignored: 0x00000100
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:EventRegister {5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x46a030, 0x46a048
fixme:advapi:EventSetInformation 2, 0x4677f8, 43
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:wuapi:automatic_updates_Pause
fixme:advapi:DecryptFileW (L"C:\\users\\Public\\Application Data\\Package Cache\\{90A4562F-D4A1-4B65-906D-41F236CF6902}v2.6.3.15212\\PathOfExileInstaller.msi", 00000000): stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister 0: stub
fixme:wuapi:automatic_updates_Resume
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)