I can't install anything

Error "This script does not more exists"

Auteur Réponses
kenny.niutanen Samedi 9 Janvier 2010 à 19:16


I installed PlayOnLinux and tried to install any program - all installation attempts resulted in the error: "This script does not more exists".

My system info:
Distro: Jolicloud robby
Desktop Gnome
Error: This script does not more exists
Computer Acer Aspire One with 8G SSD - no hard disk

Any advice how to go forward?

BR, Kenny N - not really a linux specialist, but a fan still
I ran POL from the console and got the same result. The console messages were as follows, maybe this helps:

kenny@KennyAAO:/usr/bin$ ./playonlinux
PlayOnLinux v3.7.2

Checking python :                     [ Ok ]
Murrine 0.91.x Development Snapshot, Copyright Andrea Cimitan
Running install menu
Exception in thread Thread-1 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
File "/usr/lib/python2.6/", line 525, in __bootstrap_inner
File "/usr/share/playonlinux/python/", line 46, in run
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'sleep'
Unhandled exception in thread started by <bound method getDescription.__bootstrap of <getDescription(Thread-1, started -1249383536)>>
Error in sys.excepthook:
TypeError: 'NoneType' object is not callable

Original exception was:
Traceback (most recent call last):
File "/usr/lib/python2.6/", line 497, in __bootstrap
File "/usr/lib/python2.6/", line 572, in __bootstrap_inner
with _active_limbo_lock:

Edité par kenny.niutanen

cdvl Mardi 8 Juin 2010 à 0:45

I get the same error message when I try to install something. I get no "real" error messages though. Running POL from a terminal window gives me no errors.

Please help. It sucks to be stuck.

Kind regards
Quentin PÂRIS Mardi 8 Juin 2010 à 12:39
Quentin PÂRISAnonymous

Please update POL first
autoayuda Mercredi 9 Juin 2010 à 20:01

I get the same error in Ubuntu x64. I don't know what else to do, this is annoying.
franko Lundi 26 Juillet 2010 à 13:56

I can confirm this is happening on my system, too. Whenever I try to install something it gives me a "This script does not more exists" error window, but no errors in terminal, though. And I can't install anything.

I have Ubuntu Lucid 64 bit and PlayOnLinux 3.7.6.

I am not sure if this started after upgrading POL or Ubuntu... But it used to work fine.
Could it be because of the old config files in my home directory, those in ~/.PlayOnLinux? I did a fresh install of Lucid some months ago, but I have my /home on a different partition, so I left it intact. Then I installed POL back, using the same configs in ~/.PlayOnLinux. Could it be some conflict with the old configurations? If so, what should I do to fix it without losing all my prefixes and installed apps?

I noticed this just today because I didn't need to install any Windows app till now. Now I am forced to do it the classic Wine way.

I like this project, it makes my life with Wine easier. But in this state, POL is just worthless. So I hope this will be fixed soon.

Thank you for your effort in doing all this.

Edité par franko

franko Jeudi 29 Juillet 2010 à 14:59

franko Samedi 31 Juillet 2010 à 19:55

franko Dimanche 1 Aoüt 2010 à 14:57

franko Dimanche 1 Aoüt 2010 à 15:05

Do I have to learn french to get some support here?
franko Dimanche 1 Aoüt 2010 à 15:39

I have just tried to remove my .PlayOnLinux directory, and the problem persists...

I see that in the news you say that you solved a compatibility problem with Lucid. But it seems like there still is a compatibility problem with Lucid. Maybe it is architecture related. Have you tested on Lucid 64? But the first poster here doesn't even use Ubuntu, which leaves me with a doubt...
Quentin PÂRIS Lundi 2 Aoüt 2010 à 1:18
Quentin PÂRISAnonymous

Hi !

Can you send a ticket to the Bug tracker ? It will be easier for us to find and correct the problem.

franko Mercredi 11 Aoüt 2010 à 22:14

I just did. But I have already said everything here....