No sound in AOEIII

The introduction film has sound but the game (and the menu screen) not

Auteur Réponses
kthomeer Mercredi 17 Février 2010 à 21:24


I'm just new on PlayOnLinux.

I have Ubuntu 9.10, Wine 1.0.1 (standard with ubuntu) and an updated POL 3.7.3

I installed, patched, etc AOE III without a problem.

I did set the sound configuration (Wine Config in POL) on ALSA. The sound test in Wine Config is good.

When I start the game, I have the introduction film WITH sound. After that: NO SOUND (city screen with menus, game, ...). I tried DirectSound (Wine Config) on hardware emulation, but without succes.

Windows: no problem.

Can anyone help me?


NSLW Mercredi 17 Février 2010 à 21:55

Make sure no other sound application (Amarok, Rhythmbox etc.) is running when you start AOE III then try again.

Did you try to set OSS in WineConfig? If you want to try it install alsa-oss package earlier.
kthomeer Mercredi 17 Février 2010 à 23:43


1. no other sound application is running
2. i did try OSS in WineConfig, after installing alsa-oss

... but no difference.

BTW, I get the following error when I "Update the wineprefix" or "Simulate Windows reboot": "Program error, dxdllreg.exe has encountered a serious problem ..." (translated form Dutch). I didn't had this problem in the previous POL version.

NSLW Jeudi 18 Février 2010 à 17:10

Hmm... maybe it's caused by Wine. Did you try to play AOE III on Wines with lower version numbers?
kthomeer Vendredi 19 Février 2010 à 22:33

Lower version: how?
kthomeer Vendredi 19 Février 2010 à 22:42

OK, I lowered to 1.1.10 and it worked. There was even no error when updating wineprefix and/or windows boot simulation.

kthomeer Vendredi 19 Février 2010 à 22:45

But with 1.1.10 AOEIII - Asian Dynasties won't work:

screen and sound problems from the start.
NSLW Samedi 20 Février 2010 à 15:31

Try higher Wine version, but lower than the one on which you've got issues.
kthomeer Dimanche 21 Février 2010 à 23:33

In Asian Dynasties the introduction works <=1.1.19, but it hangs from the start of the city menu (but with the city menu sound!). I tried it until 1.1.14, but it still hangs (BTW 1.1.15 has problems installing in POL!). I remarked that there is a sound delay with ALSA, but not with OSS.

<= 1.1.19 there is also not a Program Error, when I "Update the wineprefix" or "Simulate Windows reboot" (supra).
NSLW Lundi 22 Février 2010 à 9:17

Strange cause I played whole game through (with ad ons) without any issue on Wine 1.1.35
kthomeer Mardi 23 Février 2010 à 11:32

And sound player? OSS or ALSA?
NSLW Mardi 23 Février 2010 à 12:08

In POL's winecfg it was alsa, but Fedora uses PulseAudio.
Vous êtes ici: Index > PlayOnLinux > No sound in AOEIII