[script] Grand Theft Auto IV

Auteur Réponses
Jump to the page: 1 - 2 - 3 - 4
X0Ki Mardi 8 Juin 2010 à 20:56

Just letting you know that the line

#cleaning temp
cd "$WINEPREFIX/drive_c/windows/temp/"
rm -rf *

if the script is not used correctly (i.e. PLAYONLINUX with value different from the correct path) will do a "rm -rf *" on your current directory. I learned it the hard way, give it a look.

Let me know if you need any more data on the subject, but once I put a "#" in front of it it the problem was solved, kind of...

Edité par X0Ki

NSLW Mercredi 9 Juin 2010 à 7:19

I think that PLAYONLINUX variable has nothing to do with that as it contains the path for program and not for program files.
DAVVVVE Dimanche 13 Juin 2010 à 23:00

I bought gta Episodes .... from steam . Does it works with play on linux =?
DAVVVVE Dimanche 13 Juin 2010 à 23:01

I bought gta Episodes .... from steam . Does it works with play on linux =?
X0Ki Mercredi 16 Juin 2010 à 0:26

After a couple days fighting against versions, and cracks and patches and reinstalls I finally got it to work. Thanks a lot for the script.

If this is to any help to anyone out there:

Tested on: Fedora 12.
Working Version: 1.0.4
Xliveless Version: 0.999b7 (the script will search for b2, but it isn't in the server anymore, so change that line and you'll be fine)

The first couple times I installed, gta4.exe and some other files for some strange reason just wouldn't appear, but not the last time, I don't know what I did differently.

Side note to Fedora (and some other distros) users: if you need pulseaudio, the wine version installed does NOT provide support for it, and needs to be patched. There is a simpler way, though: look up in the script the url from where the patch is to be downloaded, and download it by hand. There will be a folder named gta4, with a single file (
Now you need to navigate to /usr/lib/wine and rename to and then paste the patched one right there. Run playonlinux and in the environment settings set gta IV to use "system" wine version by default. There you go, your sound now works correctly!

I hope I have expressed that correctly, my English is not what it used to be...

PS: I have a Core2Duo at 2'8 GHz and a Nvidia 9800GTX with 1GB of dedicated DDR3, and the game runs EXACTLY as laggy at high settings, automatic settings or with everything to "low" or even "off", any clues about what could be causing this?
NSLW Mercredi 16 Juin 2010 à 17:03

Xliveless link updated. Thanks for report.

If you've got crack for version higher than then GTA would also work with newest patch.

AFAIK there is no problem with sound if you install some packages through package manager.
DAVVVVE Mercredi 23 Juin 2010 à 1:33

Can someone make this script working with steamdownload , I havent the dvd ,

Thanks .
Im a noob at play on Linux / wine so scripting for me is useless
DAVVVVE Jeudi 8 Juillet 2010 à 23:24

Anyone =? I wanna play this game
Aztec Vendredi 19 Novembre 2010 à 13:23

Hello, I tried to install GTAIV and have an error: "File is not on server:". I installed POL 3.8.5 and refreshed repository. How can I resolve it?
GNU_Raziel Vendredi 19 Novembre 2010 à 15:49

Aztec Vendredi 19 Novembre 2010 à 19:02

Thank you. I solved it downloading patch from
Huji Mercredi 24 Novembre 2010 à 15:09

GTA 4 doesn't work. When I run the game (cracked with razor's crack) i get an error from RGSCLauncher and an error from wine. How to resolve this ?

PS : I get these errors just after the razor screen

Edité par Huji

GNU_Raziel Mercredi 24 Novembre 2010 à 20:08

We do not support piracy, problem caused by it have nothing to do here.
Huji Dimanche 28 Novembre 2010 à 16:48

If i don't use a crack, at the end of the installation the date checking stops at 30%. Any idea ?

PS : I have an authentic version

Edité par Huji

oskasteinar Mercredi 15 Décembre 2010 à 22:27

I tried to install GTA IV (licensed russian version) on Ubuntu 10.10, but when the installer starts, it shows message like "Your system is not suitable for GTA IV". I just don't have any idea what to do...

Edité par oskasteinar

Mach nur viel Spaß, dann alles anderes nicht wichtig ist.
Просто получай кайф, тогда всё остальное неважно.
Just have a lot of fun, then all other has no matter.
scalvo Mardi 1 Février 2011 à 23:26


I'm trying to install GTA IV in Ubuntu 10.10 86_64 following this script.

The installation seemed to go right. However, once it finished, I tried to run the game and it didn't work.

I removed this line from the launch script:

export WINEDEBUG="-all"

Then, when I run

playonlinux --run "Grand Theft Auto IV"D

At the end of the output it says something about missing .dlls

fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_HANDLE_INFORMATION
fixme:ntdll:NtQueryObject Unsupported information class 3
err:rpc:I_RpcGetBuffer no binding
fixme:ntdll:NtQueryInformationProcess (process=0xffffffff) Unimplemented information class: ProcessDebugFlags
err:module:import_dll Library MSASN1.dll (which is needed by L"C:\\\\windows\\\\system32\\\\xlive.dll") not found
err:module:import_dll Library xlive.dll (which is needed by L"C:\\\\Archivos de programa\\\\Rockstar Games\\\\Grand Theft Auto IV\\\\GTAIV.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\\\Archivos de programa\\\\Rockstar Games\\\\Grand Theft Auto IV\\\\GTAIV.exe" failed, status c0000135

I am sorry, I don't know how to write these lines within the "code box".

I would apreciate it, If anyone could help me with the installation.

Thank you

Edité par scalvo

todd_1215 Vendredi 7 Octobre 2011 à 19:47

I am trying to run GTAIV - DVD and am not able to. I install razor, quartz, vcrun2005, sounds works in winecfg using ALSA but I get a failure. Game never launches.

[POL_Wine_SetVersionEnv] Message: Setting wine version path: 1.3.23, x86
[POL_Wine_SetVersionEnv] Message: "/home/tkennedy/.PlayOnLinux//wine/linux-x86/1.3.23" exists
[POL_Wine] Message: Running wine-1.3.23 LaunchGTAIV.exe
rm: cannot remove `*': No such file or directory
fixme:mixer:ALSA_MixerInit No master control found on HDA NVidia, disabling mixer
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x14a918,0x14a838): stub
err:mmtime:TIME_MMTimeStop Timer still active?!
[POL_Wine] Message: Wine return: 1
fixme:exec:SHELL_execute flags ignored: 0x00000100

wodddkf Samedi 29 Octobre 2011 à 11:00

If anyone can make this work in ubuntu 11.10, it would be awesome.

I got it to work after some messing around with latest ppa version of playonlinux and the gtaiv v7 patch in install scripts after the installation is finished.

But it is very laggy (maybe due to compiz or full screen mode) But I get strange errors after I quit and try to relaunch it without installing update 7. So it is possible but we will have to see if anyone can update this script for latest update.
Malik Jeudi 1 Aoüt 2013 à 22:54

I would like to install gta 4 but what do i do. i see it on the website and when i click install i don't know what to open or where it would be.
Malik Vendredi 2 Aoüt 2013 à 2:50

Everytime i try to install grand theft auto iv on the playonlinux the program it doesn't work it keep giving me an error and a frowny face. I'm a noob on linux and this very confusin for me. Can someone please help me.