Oblivion doesn't load

Auteur Réponses
LNXlady Mercredi 2 Juin 2010 à 1:26

Hi everyone. I'm hoping someone can help me get Oblivion working, please? I installed it with POL but wasn't able to install the patch. It just seems to lock up when I try. Then I tried running the game without the patch. The Oblivion cursor bounces around for a minute like it's going to load, and then nothing. I don't get an error message, it just doesn't launch.

I don't know how to tell what version of the game I have, but it doesn't include the Shivering Isles expansion. I have wine 1.2.
I'm running Mandriva 2010 KDE on an HP with the AMD Phenom 9500 Quad-Core Processor. 3Gig memory, I think. I have an Nvidia GeForce 8500GT video card and I'm using the proprietary driver. Is there any other info I can provide that would help? I'm kind of lost, here.

Edité par LNXlady

NSLW Mercredi 2 Juin 2010 à 21:18

Have you used NO-CD?
LNXlady Mercredi 30 Juin 2010 à 2:28

No, I'm not using a No-cd hack. I have the cd in the drive. I eventually found that I can run and play the game by clicking the oblivion.exe file in the folder directly. I can't run the game from withing POL nor from the desktop shortcut it created. Now, the problem is that I can't run it from oblivionlauncher.exe either, so I can't enable mods. From what I've read elsewhere, I think it is a registry problem, but I don't know how to fix it.

Edited to clarify - I can run oblivionlauncher.exe, but all the options are grayed out except the website link. I can't click data files to enable the mods.

Edité par LNXlady

LNXlady Mercredi 30 Juin 2010 à 18:35

Ok, I used the POL registry edit to add an entry to oblivion and now the POL link will run the launcher and I can select my mods BUT the clicking the play button says it can't find oblivion executable. If I actually go to the folder and click oblivion.exe the game loads but without my mods. If I go to the folder and click oblivionlauncher.exe I get grayed out options. So....still not working but seems closer.
LNXlady Mercredi 30 Juin 2010 à 18:58

If I run POL with Konsole, I get this error:
Running The Elder Scrolls 4 - Oblivion
/Bethesda Softworks/Oblivion/: No such file or directory/.PlayOnLinux/wineprefix/TheElderScrolls4_Oblivion/drive_c/Program Files

and I think the problem is that there should be a /Bethesda Softworks on the end of that but I don't know where to tell it that. The registry entry IS pointing to the Betehesda Softworks folder, but that doesn't seem to be where where the game is looking for the .exe file.
LNXlady Mercredi 30 Juin 2010 à 21:13

I noticed that if I right-click on the game from within POL and tell it to open the containing folder, I get this error -
The specified file or folder /home/melisa/.PlayOnLinux/wineprefix/TheElderScrolls4_Oblivion/drive_c/Program Files /Bethesda Softworks/Oblivion/ does not exist.

There shouldn't be a space after program files. That is why it can't find the folder. Please, can't anyone tell me where to change this?
Dr Phil Jeudi 1 Juillet 2010 à 12:55
Dr Phil

Download POL-Helper (is here in the forums), install it, open it up and choose "Edit POL-launcher". Then choose the Oblivion starter and edit as needed.
LNXlady Jeudi 1 Juillet 2010 à 14:36

Download POL-Helper (is here in the forums), install it, open it up and choose "Edit POL-launcher". Then choose the Oblivion starter and edit as needed.

Quote from Dr Phil

Thanks for the reply. I just tried that and it's made things worse. :( It didn't really let me edit the path, just choose a folder. It was pointing to the c drive folder and I changed it to the oblivion folder. Now the shortcut won't do anything at all and the plugin won't let me change it back. When I try to choose the shortcut to change it, I the plugin just closes itself and I get this in terminal:

Create/Edit POL Launcher pressed
Inside Set Environment Variables From Launcher function
Inside GetEnvironmentVariables
/home/melisa/.PlayOnLinux//plugins/POL Helper/scripts/menu: line 21: 25944 Segmentation fault ./POLH

And it looks like that file is now empty. It shows as 0 bytes.

Edité par LNXlady

LNXlady Jeudi 1 Juillet 2010 à 16:25

I think I've got it working now. Since the POL helper completely ruined my shortcut, I made a new one from scratch using my old morrowind POL shortcut as a template. That shortcut to oblivionlauncher worked but I still couldn't use the play button on it. I decided to make a separate POL shortcut directly to the .exe file (used same template) and that shortcut loads the game and the mods seem to work now. Someone really needs to fix that Oblivion script. A little thing like an extra space can lead to a lot of frustration!

Edité par LNXlady

NSLW Jeudi 1 Juillet 2010 à 20:03

I think that little space problem is fixed now.