Forums

Problème Devil may cry 4

Auteur Réponses
kanishkalx Mardi 24 Mai 2011 à 17:44
kanishkalxAnonymous

Bonjour à tous!!

Ma configuration:

Imac 27" 3,2Ghz Intel Core i3
mémoire: 4Go 1333 MHz DDR3
Video: ATI Radeon HD 5670 512 Mo
Playonmac 2.4.5, je ne suis pas sûr de la version de wine vu qu'elle s'est installé d'elle-même à l'ouverture de POM.


Mon problème est le suivant:
J'ai découvert POM hier, l'ai installé et décidé de me payer un bon beat'em all, en l’occurrence DMC4, vu la totale pénurie de ce genre de jeu sur notre plateforme à la pomme. J'installe le steam depuis POM et achète le jeu par ce biais. Il se télécharge.. tout va bien. Une fois terminé, j'installe le package DMC4 depuis POM, pas de message d'erreur, l'icône apparaît sur mon bureau, ainsi que dans POM: le jeu est installé me signale-t-on.
Un poil fébrile je double clique sur l'icône du jeu dans POM.... rien.
Je sélectionne cette même icône et clique sur exécuter...... toujours rien.
Je double clique sur l'icône DMC4 du bureau et, oh ça bouge!!!, l'application se lance, sautille dans mon dock puis disparaît.... bref rien.
Je quitte tout, je recommence... rien.
J'éteins l'ordi, je redémarre... rien.
J'essaye avec POM éteint en lançant uniquement l'icône DMC4 du bureau, l'application est lançé sur le dock et y reste, ma barre de menu affiche X11 mais..... toujours rien!

J'ai épuisé toutes mes capacités ordinastique!!
Un petit peu d'aide en français, anglais ou espagnol... serait la bienvenue, pour m'éviter d'avoir jeté 20 boulettes par la fenêtre en ces temps de crise....

Un grand merci à mon prochain sauveur!

Alx

Tutul Mardi 24 Mai 2011 à 19:01
Tutul
Modérateur

C'est peut-être un problème de raccourci...

1- Clique sur "Installer"
2- Clique sur "installer une application non supportée"
3- Sélectionne "Modifier une application existante"
5- Sélectionne ton préfix (dmc4 dans ton cas)
6- Ne coche rien et clique sur "suivant"
7- Va dans ton nom d'utilisateur/Library/PlayOnMac/wineprefix/ton préfix/drive_c/et tu cherche un .exe (n'importe lequel)
8- Annule le programme
9- Clique sur "OUI" pour créer un raccourci
10- Dans parcourir, sélectionne ton nom d'utilisateur/Library/PlayOnMac/wineprefix/ton préfix/drive_c/Le programme de démarrage de ton jeu (tu le cherche)
11- Rentre le nom du raccourci de ton jeu (le même que sur POM pour le remplacer)
12- TESTE

:p

Edité par Tutul


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
kanishkalx Mardi 24 Mai 2011 à 21:51
kanishkalxAnonymous

Salut Tutul,

Déjà merci pour ta réponse rapide.
Par contre je viens d'essayer ce que tu m'indiquais d'effectuer et sauf erreur de ma part cela ne fonctionne pas..
Détaillons:
Jusqu'au point numéro 7 de ton conseil, tout va bien!
après quand tu écris: "et tu cherche un .exe (n'importe lequel) " je me perds... dans mon dossier "drive_c", j'ai trois dossier: "program files" (dans lequel se trouve tout un bordel); "windows" (où le bordel est égal au précédent) et "users" qui est le miroir de mon ordi.
En premier lieu, comme tu l'écris j'en ai choisi un au pif (je ne me souviens plus duquel..)
Ensuite quand tu écris annule le programme, je ne te comprends pas, si je clique sur annule évidemment plus rien ne se passe, si je clique suivant et que j'annule ensuite: pareil. Bref j'ai cliqué suivant jusqu'à ce que j'obtienne une fenêtre qui me propose la création d'un raccourci.
Je trouve le programme de démarrage du jeu dans le dossier "users" précité et sur le desktop de celui-ci, je nomme la chose "dmc4", une nouvelle icône apparaît dans POM et là... rebelote, impossible à exécuter.
J'ai essayé plusieurs fois en ouvrant un .exe différent mais je doute de la justesse de mes bidouillages.
Maintenant quand j'arrive au point 7, Steam s'ouvre... je ne sais pas pourquoi.
Voilà, je ne sais que dire de plus..
Merci de ton aide dans tous les cas..
kanishkalx Mardi 24 Mai 2011 à 22:12
kanishkalxAnonymous

( \\_/ )
(='.'=)
(")_(")
newikator Mercredi 25 Mai 2011 à 0:58
newikator

Salut,

Je pense qu'il faut que tu cherche dans c:/programfiles/"le nom du jeu"/"l'exe du jeu"/
en général c'est ça, mais défois le "le nom du jeu" peut être remplacer par le nom de l'éditeur du jeu.
il faut que tu trouve l'exécutable pour lancer le jeu en faite.


Après, vérifie que la version de wine est celle qu'il faut pour le jeu
(normalement ya pas de problème, mais on ne sait jamais :D )
http://appdb.winehq.org/objectManager.php?sClass=application&iId=7521
pour vérifié ta version, outils/gérer les versions de wine


Si ce jeu fonctionne comme CounterS, Steam doit s'ouvrir a chaque fois,
maintenant, c'est vrai que c'est étonnant que steam s'ouvre °_°


Dans Steam/bibliothèque tu dois avoir le jeu d'affiché, essaye de le lancer par là aussi
(qui ne tente rien ... ;-) )

Edité par newikator


Newikator


Viens me défier en quelques clics !!
http://newikator.labrute.com
newikator Mercredi 25 Mai 2011 à 1:04
newikator


( \\_/ )
(='.'=)
(")_(")

Citer


:p

Edité par newikator


Newikator


Viens me défier en quelques clics !!
http://newikator.labrute.com
kanishkalx Mercredi 25 Mai 2011 à 10:28
kanishkalxAnonymous

Alors.... Comment résumer ce que je bidouille depuis une heure??

Premièrement j'ai tout réessayer depuis le début, désinstallation de tout et voilà, mais j'arrive à la même conclusion qu'hier.
Newikator, merci pour ton message, j'ai télécharger la version de wine qu'il me fallait. Ensuite quand je vais dans: mon nom d'utilisateur/Library/PlayOnMac/wineprefix/Dmc4_/drive_c/Program files, je trouve cinq dossiers:
- "Fichiers communs" où se trouve un exe nommé steamservice dans un dossier nommé steam.
- "internet explorer" qui contient... iexplore.exe.
- Deux dossiers windows media components et media player qui contiennent en effet plusieurs executables mais aucun en lien avec le jeu, ou alors je suis une burne totale!
- et enfin un dossier "steam" qui contient deux executables un "steamservice.exe" ainsi que tout simplement "steam.exe"

Voilà en gros pas d'executable du jeu..

Après je bidouille et je cherche un peu plus et je trouve dans :
nom d'utilisateur/biblio/POM/wineprefix/steam/drive_c/program files/steam/steamapps/common........ un doddier devil may cry 4 qui contient plein d'exe au doux noms de
- DevilMayCry4_DX9.exe
- DevilMayCry4_DX10.exe
- DMC4GDFBin.exe
- DMC4Launcher.exe

La première chose que j'ai faite c'est de double cliquer sur le launcher qui m'ouvre (enfin!!) une fenêtre du jeu avec au choix DMC4 Direct x version 9 (cliquable), la version Direct x 10 (grisé), Contrôle manette et quitter.
Je clique sur le premier choix, la fenêtre disparait, rien ne se passe....

Ensuite quand je double clique sur les autres executables, et j'ai bien sûr tout essayé, une fenêtre POM s'ouvre: pom is running your application, une autre de wine s'ouvre également la première fois et puis non rien, que dalle, niet!

Voilà où j'en suis ce mercredi matin avec déjà un mal de tête digne des plus grands soir de fête! Mais fête y a pas..

Merci de votre aide.
newikator Mercredi 25 Mai 2011 à 17:42
newikator

Pour résumé, DMC4 aurais surement bien marcher si tu avait acheter le CD d'installation plutôt que de l'acheter via Steam. Bref ...

le script ne doit pas fonctionner si tu n'a pas le CD
je pense qu'il faut que tu installe des trucs en plus dans ta bouteille steam pour que ça marche
du genre directX
instalation/autres/playonlinux fonction/
je croit qu'il y en a un qui s'appelle Directfull, sinon ya d3dX...

teste
(il doit y avoir d'autres combines, mais je ne les connais pas toutes)

Sinon ya pas moyen d'avoir le jeu en standalone quand t'achète via steam ?
Steam c'est bien pour la communauté, sinon, ça sert a rien.

Autre solution, tu l'as acheter, tu peut le cracké, personne ne te dira rien
et en récupérant un iso (par exemple) le script d'install devrai fonctionner

Newikator


Viens me défier en quelques clics !!
http://newikator.labrute.com
Tutul Mercredi 25 Mai 2011 à 20:57
Tutul
Modérateur

Sauf que le script comporte une section pour Steam qui devrait fonctionner !!!

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
kanishkalx Jeudi 26 Mai 2011 à 10:37
kanishkalxAnonymous

Je crois que je vais tout foutre à la poubelle et oublier tout ça..
Merci quand même à vous deux pour votre aide.
Tutul Jeudi 26 Mai 2011 à 11:47
Tutul
Modérateur

Déso pour toi
:cry:

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
GNU_Raziel Samedi 4 Juin 2011 à 1:00
GNU_Raziel

Salut,

Je pense que le souci viens de la manière dont tu as installé le jeu...Qu'entends-tu par "package dm4" ??

La méthode de fonctionnement normale est la suivante :
1- Tu installes PoM
2- Tu install DMC4 via PoM, en choisissant la version Steam lorsque demandé, ce la aura pour effet d'installer Steam puis de lancer le téléchargement de DMC4.
3- Une fois le DL fini, tu laisse PoM finir son install et te créer les raccourcis.

Testé sur le MBP d'un ami lorsque j'avais fait cet installeur, la version steam s'était parfaitement bien installée et avait fonctionnée sans souci.

Maintenant je sais que la dernière version de steam fonctionne plutôt mal avec wine, à cause de leur nouveau système de securité et de quelques autres "améliorations" (oui je déteste cette sale usine a gaz codé avec les pieds après une cuite).
Kriystaal Mercredi 16 Janvier 2013 à 21:33
KriystaalAnonymous

Hello! Désolé de déterrer un post assez ancien, mais ceci dit je rencontre le même problème. Correction, je rencontrAIS le même problème. En ce qui me concerne tout marche si je puis dire car je n'ai absolument pas de son. Console de débogage ouverte, j'apprend que le module directsound "is not implemented" et qu'il passe en HEL. Super, mais ça ne marche pas. Je fouine dans les packetages, trouve un dsound, le DL et après l'attente (oui le pack fait 300 Mo à la louche), grosse déception. Le jeu n'a toujours pas de son, rageant, mais en plus, il s'est mis à ramer comme un enf**ré... J'ai tout désinstallé pour reprendre depuis le début, même galère... Une idée...?
GNU_Raziel Dimanche 27 Janvier 2013 à 12:59
GNU_Raziel

Bonjour,

merci de votre rapport de bug, je jetterais un oeil et tenterais de résoudre le problème dès que possible.

J'aurais cependant besoin de quelque précisions :
- Version d'OSX utilisée
- Version du jeu installée (Boite, Steam ou autre version digitale - à présisée)
- Log complet du mode débogage.

Cordialement,

GNU_Raziel

Edité par GNU_Raziel