Not passing proper Shader Model version?

Auteur Réponses
rubin110 Lundi 19 Mars 2012 à 7:57

First off I think my issue is driver based but I figured posting here can't help.

I have a Thinkpad X220 with an Intel HD Graphics 3000 GPU, running Debian Sid x64. Mostly everything I've tried to run through Steam seems to error out with

"Video card is below minimum system requirements. You need a video card with at least Shader Model 3.0"

I've been using the LIMBO Demo to reproduce and test. Here's some debug output...

fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "Mesa DRI Intel(R) Sandybridge Mobile ", version "1.4 (2.1 Mesa 7.11.2)").
fixme:win:EnumDisplayDevicesW ((null),0,0x33f580,0x00000000), stub!

If I'm not mistaking the 3000 supports either shader 4.0 or 4.1. Again I'm guessing this is a driver issue. Googling around hasn't really provided me with an alternatives and I'm completely new with how mesa works. Thinking I might try building 7.12 but am guessing I would give up after 30 minutes.

Any suggestsions?
rubin110 Lundi 19 Mars 2012 à 8:34

As a suggestion from pango in the IRC channel, I tried upgrading to Mesa 8 from unstable, sadly the issue still remains.