Forums

Cannot set locale to ''.

Auteur Réponses
su8610 Samedi 2 Juin 2012 à 13:44
su8610Anonymous

Hi,my play on linux start with "Cannot set locale to ''.",how to fix it?ubuntu 12.04
su8610 Samedi 2 Juin 2012 à 14:42
su8610Anonymous

I hvae set locale=POSIX,and it is OK now
Kyabetsu Samedi 16 Juin 2012 à 10:51
KyabetsuAnonymous

And how did you do this, please ?
Aymeric P. Samedi 16 Juin 2012 à 12:22
Aymeric P.
Admin

Hi
What is your default language?
Could you post the result of command: env

Former member.
Kyabetsu Mardi 19 Juin 2012 à 21:04
KyabetsuAnonymous

Here you are :

SSH_AGENT_PID=1307

GPG_AGENT_INFO=/tmp/keyring-RhcoiA/gpg:0:1

TERM=xterm

SHELL=/bin/bash

XDG_SESSION_COOKIE=87a711f5e37afc173edbed6800000004-1340132251.106920-1630227950

__KMP_REGISTERED_LIB_2037=0xb5e2ba14-cafe91ef-libiomp5.a

__KMP_REGISTERED_LIB_2036=0xb5e2ba14-cafe6580-libiomp5.a

WINDOWID=65011718

GNOME_KEYRING_CONTROL=/tmp/keyring-RhcoiA

GTK_MODULES=canberra-gtk-module:canberra-gtk-module

USER=XXXX

LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:

LIBGL_DRIVERS_PATH=/usr/lib/fglrx/dri

XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0

XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0

SSH_AUTH_SOCK=/tmp/keyring-RhcoiA/ssh

USERNAME=XXXX

DEFAULTS_PATH=/usr/share/gconf/ubuntu.default.path

SESSION_MANAGER=local/XXXX:@/tmp/.ICE-unix/1271,unix/XXXX:/tmp/.ICE-unix/1271

XDG_CONFIG_DIRS=/etc/xdg/xdg-ubuntu:/etc/xdg

PATH=/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

DESKTOP_SESSION=ubuntu

LC_MESSAGES=fr_FR.UTF-8

LC_COLLATE=fr_FR.UTF-8

PWD=/home/XXXX

LANG=en_GB.UTF-8

MANDATORY_PATH=/usr/share/gconf/ubuntu.mandatory.path

UBUNTU_MENUPROXY=libappmenu.so

COMPIZ_CONFIG_PROFILE=ubuntu

GDMSESSION=ubuntu

SHLVL=1

HOME=/home/XXXX

LANGUAGE=fr:en

__KMP_REGISTERED_LIB_1403=0xb5e2ba14-cafe15a5-libiomp5.a

GNOME_DESKTOP_SESSION_ID=this-is-deprecated

IBUS_ENABLE_SYNC_MODE=1

LOGNAME=XXXX

XDG_DATA_DIRS=/usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/

DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-DmCUB9zycn,guid=ac734c49333f3b1dbacb37ab0000000d

LC_CTYPE=fr_FR.UTF-8

LESSOPEN=| /usr/bin/lesspipe %s

DISPLAY=:0

XDG_CURRENT_DESKTOP=Unity

LESSCLOSE=/usr/bin/lesspipe %s %s

COLORTERM=gnome-terminal

XAUTHORITY=/home/XXXX/.Xauthority

_=/usr/bin/env



So basically, I guess the answer is "English" ^^

Aymeric P. Samedi 23 Juin 2012 à 21:43
Aymeric P.
Admin

You have something wrong with you language setting.
LANGUAGE is set to French and English, your LC_* are set to French and your LANG is set to English.
So I suggest you to fix this one (ask your distribution).

You could force PlayOnLinux to run in English by setting variable LC_ALL to value C and running playonlinux, like this : LC_ALL=C playonlinux

Former member.