POP: The Two Thrones

Steam version, Invisible textures

Auteur Réponses
oogabooga Dimanche 14 Octobre 2012 à 15:28

Hi guys.

Used playonlinux to install steam, have used the basic installer to run pop sands of time and warrior within.

Wine: 1.4.1
Ubuntu 12.04

The Two Thrones runs just fine, except.. after the prince is attacked by the vizier, and his upper torso texture changes, neck to hips he becomes invisible except for the chain and armband textures. That.. was quite annoying but dealable. I then found out that ropes and chains, except the prince's chain, are invisible. Okay, that's worse. I ignored it for a bit and then I did some searching.. can't find anything on it. I've tried changing the settings in display configuration for "steam", nothing seems to help, and I had previously tried all the in game settings one by one. I had some occassional texture issues in the first two games, but they always corrected after a while. This time it's constant. I have no idea what else to do. Directx 9 seems to be completely installed and just for measure I even checked out the install packages majigger and made sure all the stuff was installed. Um.. Ah, I've also tried the install script but when installing steam it crashes the first time always, so it does it while using the official install script from the search box majigger and I'm unsure how to run that steam installation in that virtual drive under that wine version to get it to continue installation so I can hit next properly.

I saw once where d3dx9's #41 was missing.. but can't remember where I saw that. It loaded 25ish to late 40something ish.. 48? but did not load a 41.
oogabooga Lundi 15 Octobre 2012 à 0:33

fixme:d3d:wined3d_device_set_clip_status device 0x140da0, clip_status 0x33fb84 stub!
fixme:d3d:wined3d_device_set_clip_status device 0x140da0, clip_status 0x33fb04 stub!
fixme:d3d:wined3d_device_set_clip_status device 0x140da0, clip_status 0x33fb08 stub!

I added in the #41 dll myself, I have tried the dvd version of the game to no avail, this seems to be the main error I have. It's a bit creepy now because not just the upper torso of the prince, chains, and ropes are invisible.. farah's face and neck are, too.. so she's just some floating eyeballs with hair and teeth and a body... yeah.