PoL not running on Precise Kubuntu

Python 2.7 + WX 2.6,2.8 are installed

Auteur Réponses
DoktorV Mardi 16 Octobre 2012 à 5:06

Thank you for your time. While I am very computer literate in general, I have only started using Linux relatively recently and I am not strongly proficient with it yet. I will try to be thorough in explaining my problem.

Play on Linux was working some time ago but it no longer runs successfully on this system. I suspect a system update broke it but I don't know which one because I didn't try using PoL for perhaps three months.

I am running Kubuntu Precise Pangolin, I believe that's 12.04 but I'm not absolutely sure. The system lives on a Wubi dual-install with a Windows XP installation I occasionally need, if that matters.

System specs:
AMD Phenom 9600 quad-core
ATI HD3870 video card

When I realized PoL wasn't working, I tried the steps given at
I have reinstalled all the packages specified in section 1 and deleted the /.PlayOnLinux directory. That didn't help, so I restored the /.PlayOnLinux directory from a backup.

Attempting to run PoL from the progams list creates a PlayOnLinux link on the taskbar which doesn't link to anything, which disappears after a few seconds, followed by the crash notifier telling me a program just crashed. Attempting to run PoL from console produces the following:

**** Begin console copy-paste*****
user@ubuntu:~$ playonlinux
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
[install_plugins] Message: Checking plugin: Offline PlayOnLinux...
Traceback (most recent call last):
  File "", line 745, in <module>
    app = PlayOnLinuxApp(redirect=False)
  File "/usr/lib/python2.7/dist-packages/wx-2.6-gtk2-unicode/wx/", line 7700, in __init__
  File "/usr/lib/python2.7/dist-packages/wx-2.6-gtk2-unicode/wx/", line 7352, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "", line 689, in OnInit
    self.frame = MainWindow(None, -1, os.environ["APPLICATION_TITLE"])
  File "", line 274, in __init__
AttributeError: 'Gauge' object has no attribute 'Pulse'
Exception TypeError: 'join() takes exactly 2 arguments (1 given)' in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: Transgaming Cedega...
/usr/share/playonlinux/playonlinux: line 96: python2.6: command not found
user@ubuntu:~$ [install_plugins] Message: Checking plugin: Wine Import...
[install_plugins] Message: Checking plugin: Wine Look...
[install_plugins] Message: Checking plugin: Screen Capture...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
*** End of console copy-paste. Console hangs here until terminated.***

It was mentioned in another thread that Python 2.7 and after may have broken PoL, but I cannot figure out how to downgrade to 2.6. Relevant package versions currently installed, if it matters:

PlayOnLinux: 4.0.14-1
Python: 2.7.3-0ubuntu2
wxPython: and
cabextract: 1.4-1
ImageMagick: 8:
Wine: 1.4-0ubuntu4.1

Thank you for your time.

petch Mardi 16 Octobre 2012 à 12:07

I installed KUbuntu Precise in a VM, made all upgrades, and then PlayOnLinux 4.0.14 installed and worked just fine.
List of packages:

It's a 32bit installation (my CPU doesn't allow for 64bit VMs), but since it seems to be a Python issue, it shouldn't matter.
petch Mardi 16 Octobre 2012 à 12:31

Still testing, that's unrelated to your issue, but for now I've found I could not open a "shell" inside POL because xterm was not installed...

Edité par petch