Forums

How do I disable all error messages from PoL?

Auteur Réponses
raycharles Mardi 15 Janvier 2013 à 19:44
raycharlesAnonymous

I've installed Microsoft OneNote 2010 and it is working fairly well. The only problem is that closing it does not seem to actually kill the process, and I can not relaunch it until I kill the process manually with

killall ONENOTE.EXE

in the terminal. Still, I found a way to work around this issue (I added that command to the beginning of PoL's launcher for OneNote) and now it successfully kills the process and launches a new instance every time I click on the shortcut. However, it also displays an annoying error messages stating that Wine has crashes before launching.

Is there any way I can just hide error messages in PoL, in general or just for one application?
petch Mardi 15 Janvier 2013 à 21:54
petch
Développeur


Open PlayOnLinux console, and type

POL_Shortcut_QuietDebug "Shortcut Name"
raycharles Jeudi 17 Janvier 2013 à 18:19
raycharlesAnonymous

That works if I launch the application from the PoL UI but not if I launch it via a custom launcher (using the Ubuntu Unity dash and alacarte). The command for the launcher is:

playonlinux --run "Microsoft OneNote 2010"

I also added the following at the top of ~/.PlayOnLinux/Shortcuts/Microsoft_OneNote_2010 :

killall ONENOTE.EXE

which kills the OneNote process that always persists after I close it. Is there any command I could add to either the launcher icon or the shortcut script that would disable the error messages so I don't have to launch the PoL interface every time I use OneNote?
TIIUNDER Dimanche 4 Aoüt 2013 à 23:41
TIIUNDERAnonymous

That works if I launch the application from the PoL UI but not if I launch it via a custom launcher (using the Ubuntu Unity dash and alacarte).

Is there any command I could add to either the launcher icon or the shortcut script that would disable the error messages so I don't have to launch the PoL interface every time I use OneNote?

Quote from raycharles

Same here. Is it possible to disable error messages in shortcuts?

Edité par TIIUNDER

gen0 Mercredi 6 Aoüt 2014 à 13:13
gen0Anonymous

A hacky solution I found was to comment out in this file:

/usr/share/playonlinux/lib/wine.lib

the following 3 lines:

#       if [ "$errors" != 0 -a "$NoErrors" != "True" -a "$POL_IgnoreWineErrors" != "True" ]; then
#               POL_Debug_Error "$(eval_gettext 'Wine seems to have crashed\n\nIf your program is running, just ignore this message')"
#       fi

This worked for me in PlayOnLinux 4.2.4.  Otherwise I found the same behaviour - debugging was suppressed when launching within PlayOnLinux (after figuring out how to use the POL_Shortcut_QuietDebug command) but not from the .desktop shortcut.

 

kvr2007 Jeudi 28 Aoüt 2014 à 20:58
kvr2007Anonymous

Thanks for the tip! It actually helped me to find a neater solution, you can just add:

export POL_IgnoreWineErrors=True

to your custom shell script and it should do the same thing. Moreover, you will still be able to get error message windows for other POL programs and will not have to edit wine.lib after every PlayOnLinux update.

Cheers!

Ronin DUSETTE Jeudi 28 Aoüt 2014 à 21:26
Ronin DUSETTE
Admin

Just FYI, the error messages are there for a reason, and the pop-up messages do not tell us much when they come up, hence the debug output. Just something to be aware of.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts