The forum

Alt Tabbing from League of Legends

Cannot while in game

Author Replies
izberion Saturday 20 April 2013 at 17:50
izberionAnonymous

Hey guys, the only problem I have while running League of Legends (besides not being able to buy RP) is, I can't alt tab out of the game. I can switch to a different workspace (using cinnamon on Linux Mint 14), but it will leave the in game mouse, and the League of Legends game window will still be active, even though it is on a seperate workspace.

Is there any way I can get my mouse working in other workspaces while the game is running? It's really annoying having to listen to someone call me on skype and not being able to respond. I'm pretty much trapped in the game for the full 45 minutes. 

Thanks.
krissi Tuesday 23 April 2013 at 14:35
krissiAnonymous

have you tried the borderless window and see if that help any in video settings ?
izberion Tuesday 23 April 2013 at 16:46
izberionAnonymous

I've tried borderless. Doesn't help. I also tried changing it to windowed, but because I'm locked into the game, I can't move the window to the correct position.
Ronin DUSETTE Tuesday 23 April 2013 at 18:29
Ronin DUSETTE
Admin

Maybe in Wine Configuration in the Configure tab in POL, you could uncheck the boxes for window management and decoration? That could help.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
izberion Tuesday 23 April 2013 at 19:21
izberionAnonymous

That kind of worked. It's getting there. Alt-tab and swapping workspaces now works, but when I alt-tab and pick a different window, it just swaps right back to League. Same thing for swapping to a different workspace, even if it doesn't have the game in that workspace. I can't escape it.
Ronin DUSETTE Tuesday 23 April 2013 at 19:29
Ronin DUSETTE
Admin

Disable mouse-warp override?

PlayOnLinux -> Configure -> Select virtual drive -> Miscellaneous tab -> Mouse warp override

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
izberion Wednesday 24 April 2013 at 7:26
izberionAnonymous

Found out that unchecking the window management was what was making it jump to the active workspace, and always be on top. It was even doing it in the client, along with in game. Disabling mouse warp didn't do anything.
Ronin DUSETTE Wednesday 24 April 2013 at 17:21
Ronin DUSETTE
Admin

Ah. hmmmmm. Im not sure at this point, then.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
izberion Thursday 25 April 2013 at 6:27
izberionAnonymous

Yea I don't know either. League is the only game it will do it to. Guild Wars 2, for instance, and every other game I have installed actually, works fine while alt-tabbing and swapping workspaces.
Ronin DUSETTE Thursday 25 April 2013 at 16:35
Ronin DUSETTE
Admin

What Desktop Environment are you using? Like, which flavour of Linux are you running? Ubuntu?

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
izberion Friday 26 April 2013 at 6:40
izberionAnonymous

Linux Mint 14 using cinnamon.
Ronin DUSETTE Friday 26 April 2013 at 16:35
Ronin DUSETTE
Admin

Hmmmm. Im not sure if that would have an effect (just started playing with Cinnamon recently). I may install Mint this weekend (I work today) in a virtual machine and give it a shot to see if it does the same thing to me.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
izberion Friday 26 April 2013 at 18:19
izberionAnonymous

Ok thanks. I have no idea why only League of Legends is affected.
izberion Sunday 5 May 2013 at 19:56
izberionAnonymous

So I've discovered something. I can now not alt tab out of any game once it becomes the active window. I found this out when I tried to get out of Guild Wars 2 last night to answer message on skype.

And as for league, as long as I don't click on the game, I can alt tab. But that'll only work for the loading screen since I need to click to play :P
Romen Sunday 5 May 2013 at 22:36
RomenAnonymous

Well, just use the hotkey to open terminal (Ctrl+Alt+T on my Lubuntu) and the cursor should go back to normal.

Edited by Romen

izberion Tuesday 7 May 2013 at 6:34
izberionAnonymous

Well that didn't work. I had to hotkey the terminal window to another workstation. The mouse didn't return to normal and I couldn't close out of the terminal with the league mouse :P

EDIT: Figured it out. League wasn't set to be always on top. I marked that and now I have a normal mouse in other workspaces. The only problem with that is I can't use any other window in that space, but that's fine. I never have anything besides the POL window and the game in that workspace anyway

Edited by izberion

toruneko Sunday 7 September 2014 at 13:49
torunekoAnonymous

i don't know if it's too late to post a reply here, but i too had the same situation where i could not alt-tab from league once it starts loading the game.

but i have managed to fix it. here's how i did: once in loading screen or in game, hit "alt+space" twice or until window menu shows up, then from "layer" choose "normal". that did it. at least for me.

i also disabled window decoration thing in wine configuration, but kept window manager ticked.

hope this helps!!

Jonasbue Tuesday 24 July 2018 at 22:32
JonasbueAnonymous

I had the same problem with StarCraft 2 with Wine (not POL, but I doubt that makes much of a difference here). I solved it by opening Wine Configuration (winecfg), and in the Graphics tab, checking "Show a virtual desktop". I set the resolution size of the virtual desktop to the same as my regular desktop (which in my case is the same as the game resolution). This allows me to alt-tab between the game and any other tab, without the game freezing.