The forum

Ubuntu 64bit 13.04 League of legends crash on install

Sorry because i know there's a million threads

Author Replies
aphexmonster Monday 20 May 2013 at 23:10

I apologize in advance as i know there are already over 9000 threads about people who are having trouble installing this game, but I haven't found a topic even close to my issue. Fresh install of ubuntu all package upgraded. Fresh intsall of play on linux, and i've installed IE 7 and tested it. I have the install file for league of legends, and when i perform a non-listed installation of league of legends the installer will just go grey and freeze right before it begins installing. I configure my virtual drive with 3d3dx9, vcrun2005, wininet, corefonts in the new prefix but no matter what i do starting the install it turns grey instantly. Do i have to point it to a version of LOL already installed on windows previously and move it over to my linux machine to make it work ? Previously i have gotten the game to load on this machine by loading it the crude way all through command prompt and had a huge string to open it after navigating to its long directory string. However, after changing a video setting - the program would crash right at game start - unable to find a fix i decided to try POL and install it from the installation exe - I have had no success getting it to move. 
booman Monday 20 May 2013 at 23:29

First, which version of Wine are you using when it "gray screens"?

d3dx9, vcrun2005, wininet & corefonts is a good start.
If you are using Wine 1.4 or earlier, you will probably need: dotnet30
But if you are using Wine 1.5 or later, you won't need it.

I've had problems like this with games in the past and usually a newer version of Wine has fixed it, but sometimes its hard to know what directx version to install and the stinking dotnet/vcrun versions too.

I recommend testing it in a Virtual Desktop.
You can set this by doing this:
1. Launch PlayOnLinux
2. Click Install
3. Click Non-Listed Program
4. Name your Virtual Drive
5. Check all 3 options (Select Wine version, Configure Wine, Install Components)
6. Select your Wine version (I usually test with 1.4 or 1.5.25)
7. Configure Wine - Select display
8. Check Virtual Desktop
9. Set Resolution (1024x768 recommended)
10. Install components

If you still get a gray screen after installing packages after browsing to the setup.exe, try a different version of Wine. Then try again and again again.

This is how I test games... once you find the right version of Wine and components, it should run. Also Check about what other people have found to get it running.

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
petch Monday 20 May 2013 at 23:30

Use the official install script:
Install button > check "Testing" checkbox > Games > League of Legends
booman Monday 20 May 2013 at 23:32

oh yeah, try that too, but just in case it doesn't work try the above...

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
petch Monday 20 May 2013 at 23:38

The above won't work, LoL requires a specific version of Wine, the installer (and the downloader) require the environment variable GC_DONT_GC to be defined to work,...
aphexmonster Tuesday 21 May 2013 at 1:22

okay - i found the script for the LOL install - it will set up the virtual machine, and download all the necesary files - then when it finishes the download it stops with the error " Error in main
Could not change dir to /home/monster/Desktop/League of Legends! "
petch Tuesday 21 May 2013 at 13:14

There's not that many cases when you cannot enter a directory use just created...
So does this directory exist? Do you get an error if you try to create it manually?
aphexmonster Sunday 26 May 2013 at 21:09

I am just having a hair pulling experience of a time installing LOL and getting it to work. I'm running the script VERBATUM now with all of the components for the script - downloaded the installer file provided for league of legends. Got it to install fine without any freezing this time. Now - when i attempt to start the program it tells me " mono not installed " - when i press the install button the installer freezes on downloading and never returns functionality. I went into the vm and just added the mono .net configuration myself. When i start the program it tells me " no mono found " So i figure i might have the wrong version. I repeated the same steps with BOTH other versions of mono on there and wine returns the same message to me " no mono found " with the option to install - which it just freezes on. Has anybody here actually gotten LoL to work ?
petch Sunday 26 May 2013 at 23:02

Versions of Wine from 1.5.3 onward try to install wine-mono on themselves (and usually fail). But League of legends does not make use of Mono, that's a red herring in this case.

That said if you want to get rid of this message, you can download wine-mono-0.0.8.msi from (and wine-mono-0.0.4.msi from ?) and put them both as-is in /usr/share/wine/mono/ (that you'll probably have to create as root).
For more infos see
glennmc80 Wednesday 19 June 2013 at 17:54

I hit this thread when I was having issues - very novice Linux user but I think I may have found a quick fix *IF* you were choosing the same options as I was during the installation.

Initially when I was setting things up through PlayOnlineLinux (the official testing script), I was choosing to install from the file I grabbed from Riot's webpage. My first 3-4 trys I was receiving the greyed-out, hanging installation window issue you were describing. After starting over and selecting to download the installation tar instead of installing from the file I previously downloaded everything seemed to work ok for me.

Just to verify, I am also using 13.04 x64 with the wine version of 1.5x listed above (as per the official testing script). I certainly hopes this cures the situation you're running into as well!

Edited by glennmc80

petch Wednesday 19 June 2013 at 20:04

The game cannot be installed using downloaders (LeagueofLegends.exe) from Riot using the current script, and if I try I get the expected script failure "Error in main, Cant install using the official downloader, sorry".
And if you're not using the official script in testing you'll probably don't manage to install it (just to repeat myself).

Edited by petch