The forum

Civilization IV: Complete Edition

Having some XML issues, anyone? ;)

Author Replies
Jump to the page: 1 - 2
Ronin DUSETTE Sunday 14 July 2013 at 19:24

If you post the debug output from your installation, we can tell you why it cannot find the game. That should have been one of the first things you posted.

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
alcorsepol Friday 19 July 2013 at 19:58

Just as a note, my DVD only has 3 games, so maybe there are different versions of the "Complete" edition? Or maybe you are talking about the Steam version? Because that one has the Colonization game as well.
hangingman Saturday 20 July 2013 at 0:08

It looks like there are multiple versions of Civilization IV: The Complete Edition.

States, at the very bottom, that this is available in North American. Whether the European version is totally different is anybodies guess. From your experience, the answer is "yes".

Your script works great on installing the Civilization IV game and the two expansions, Warlords and Beyond the Sword. They also run well, by the way. Thank you! The Colonization game on my DVD installs. It is all one installation process. The problem with Colonization is that it is a stand alone game. It has a seperate installation path. Play On Linux handles the first three game using the scripts defined path but the second path used by Colonization is (of course) undefined. It is unlikely that Play On Linux could ever recognize when Colonization's installatioin even starts with in the Wine execution.

Since I also have the original Colonization CDROM, I wrote a seperate script that installs it, and the only patch that available 1.01f. I just used your script and aimed it at Colonization. The script follows.

The only issues with the Civilization IV installation was the overlay made by the Gnome top and bottom panels (stated above) and the failure to return to the original graphics mode. The panel problem is fixed by loging in with Gnome 2D. It has become my new standard login. For the graphics proble, I just log out and log back in.

Cheers, script follows

# Date : (2013-07-14)
# Last revision : (2013-07-14)
# Wine version used : 1.6-rc4
# Distribution used to test : Ubuntu 12.04 LTS
# Author : James Denier
# Licence : GPLv3
# Depend : msxml3

# This script was tested using the CDROM version of `Civilization IV: Colonization'

[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"

TITLECOMPLETE="Civilization IV: Colonization"
AUTHOR="James Denier"


POL_SetupWindow_presentation "$TITLE" "Firaxis Games" "" "$AUTHOR" "$PREFIX"
select_prefix "$PREFIXDIR"

# Let the user select a CDROM

# Check if this CDROM is the Civilization IV CDROM
POL_SetupWindow_check_cdrom "Autorun/Civ4Installer.ico"

# Make sure the right wine version is used, otherwise
# the user will run into a problem regarding copyright protection.
POL_SetupWindow_install_wine "$WORKINGWINEVERSION"


# Create the prefix for Colonization, a directory called `Colonization'

PROGRAMFILES="Program Files"

# Install DirectX9
POL_Call POL_Install_d3dx9

# Run installer
POL_SetupWindow_menu "Which installation medium do you want to use?" "Medium" "DVD~CDROM" "~"
wine start /unix "$CDROM/setup.exe"

POL_SetupWindow_message "Click Forward when the installation is finished" "$TITLECOMPLETE"

#Patch Civilization IV: Colonization 1.01f
cd "$HOME/.PlayOnLinux/ressources"
POL_SetupWindow_wait_next_signal "Patching game..." "$TITLECOMPLETE"
wine ColonizationPatch1.01f.exe

# Download and install msxml3.msi
# Override for msxml3 is needed before the install
# The msvcr71 one is just there so that mods will work later on

POL_Wine_OverrideDLL "native" "msxml3"
POL_Wine_OverrideDLL "builtin" "msvcr71"
POL_Call POL_Install_msxml3

#Create shortcuts
POL_SetupWindow_make_shortcut "$PREFIX" "$PROGRAMFILES/2K Games/Firaxis Games/Sid Meier's Civilization IV Colonization" "Colonization.exe" "" "$TITLE"

POL_SetupWindow_message "$TITLECOMPLETE installed."

alcorsepol Saturday 20 July 2013 at 0:15

A quick solution for the graphics issue, is to change the in game resolution to your preferred resolution, and then exit the game. At least that worked for me.

If someone could point me to a copy of the Civilization IV Complete Edition that has the Colonization version as well, then I can get it and see if I can make the script recognize the different DVDs and install them properly.

Personally I prefer to have an "All coverage" installer ^^
hangingman Saturday 20 July 2013 at 2:04

has the game for the same price as in the US with all four games.
alcorsepol Saturday 20 July 2013 at 12:04

has the game for the same price as in the US with all four games.

Quote from hangingman

Yup I bought it a few days ago to add Steam support to the script :-)
The script supports it already, but I want to support installing Colonization via the DVD as well, so if anyone can point me in the right direction, then I can edit the script so that it has support for that as well.

I'm considering getting all the games separately as well so that the script will be able to cover all of them.
hangingman Saturday 20 July 2013 at 19:59

I am by no means trying to discourage you but a discography would be needed. This is no easy task in itself.

I have the origin release of Civilization IV, Warloards, Beyond the Sword, Colonization, and the recently purchased, Civilization IV The Complete Edition. I can beta test these.

I know that there is also a Civilization IV Compelete (that includes Civilization III and Civilization IV), and there is the version you already have which excludes Colonization. You may want to consider a tightly focused script based on each specific release. You already have one that will load your version of "Complete". My script, or a cleaned up version, can do a stand alone Colonization. A new script that used the four game DVD version can be made. (Although I am uncertain that Play On Linux can handle this. ADMIN, you may want to comment on this.)

In any case, I will lend support. The downside is I am an old retired mainframe developer and teacher. While I have used Linux since its birth, time has taken much of the knowledge and skills. My keyboard does not have a built in walker "yet" but we are getting close.

alcorsepol Sunday 21 July 2013 at 0:37

Well, one way would be to do it like this, with these separate scripts

1: One script that handles the two versions of "Complete", that is, the one with 3 games and the one with 4 (Not the one that has Civ III and Civ IV). Adding support for Colonization on the other DVD is not a problem. I just need to get my hands on it so that I can test it properly :-)

2: One script for Civ IV and one for each of the expansions

3: One for the other "Complete" with the two games if that is needed (Don't think so?).

Since I love these games, I would love if we had scripts for all different versions and combos so that it can become a complete experience for Linux gamers as well. I am also hosting all the newest patches, so we could use that for the scripts if needed.
fleuryc Monday 20 January 2014 at 21:33


Is there a Up to date HowTO to install Civ IV with POL?

Concerning the script above, is it still up to date? 
How to run it exactly?

Sorry for my noobies questions, but it gets really frustrating...

hangingman Tuesday 21 January 2014 at 6:13

The script posted above in this thread worked for me.  A little time after I posted it an official POL interface script was added to the POL site.  This is the offical source.  I did not try it when it appeared.  I already was playing BTS from my own scripts installation and did not wish to damage the on-going game.  The posted cut and paste script works.  It has been a while but there may be an issue with resetting the screen resolution.  It is fixed on my system by "xrandr -s 1280x1024" on the close of the game.  A similar cut and paste script exists for Colonization.  It lacks the patch but otherwise works fine.