The forum

Unable to install World of Tanks

Author Replies
Klips Saturday 13 July 2013 at 15:10
KlipsAnonymous

Hello,
After trying out the installation of World of Tanks (WoT), I broke down and seek help from this forum.

System: Mac mini running Mac OSX 10.8.4 with PlayOnMac 4.2.1.
Issue: Wine Mono cannot be found nor installed
Symptoms: 
  1. PlayOnMac Wizard launches and gets stuck on 'Wine Mono Installer'. 
  2. At times, the download would not start and exit due to 'Unexpected checksum of downloaded file. Aborting installation of corrupted file'.
Both symptoms, however, does not break the WoT installation sequence - it went on to install IE8 etc. The installation wizard ended with another error - There is no WIndows program... this type of file". 

I have tried installing Mac-Mono runtime seperately, but the situation does not improve.

Thank you in advance for your assistance. Appreciate any inputs.


Edited by Klips

Ronin DUSETTE Saturday 13 July 2013 at 16:25
Ronin DUSETTE
Admin

Really, its sounding like the download is flat out failing, which wine-mono usually does.

You can get it here and manually install it if its still being grumpy.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Klips Sunday 14 July 2013 at 6:06
KlipsAnonymous

Hello,

I tried google for Wine-mono and installed. It did not work.

I went on to try installing .NET manually onto the WoT virtual disk and restart the WoT installation; it helps by not prompting for mono;

However, it breaks now when it tries to download WoT installer. The download looks like it did not happen. Any advise?

Thanks in advance for any assistance.

Ronin DUSETTE Sunday 14 July 2013 at 7:06
Ronin DUSETTE
Admin

You can't run mono and .net in the same virtual drive, because it breaks.

Just use the script to install. Don't add stuff on top of it.

So, first, as per forum rules, post up your debug output and all computer specs. Graphics card too. You can learn to do this via the stickies at the top of the forum.

Post that up. I think I may already know what is wrong.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Klips Sunday 14 July 2013 at 13:01
KlipsAnonymous

Hello,

Thanks again.

I log the logs into dropbox for easier access - here.
I am running these on a 2012 Mac Mini, i5 processor with 16GB RAM.

Appreciate any advise. Thank you.


Ronin DUSETTE Sunday 14 July 2013 at 19:07
Ronin DUSETTE
Admin

Sorry. Didnt see the debug output... checking.

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Sunday 14 July 2013 at 19:21
Ronin DUSETTE
Admin

I knew it

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

Quote


Newer versions of OSX do not come with Samba anymore, so you need to install it from here. After you install samba, restart your computer, COMPLETELY remove the virtual drive for WoT, and reinstall.

Without winbind, you will have issues with network stuff (without getting too technical), and that is making your installation fail because the downloads fail.

Ill be completely honest; WoT on OSX is our most problematic game for Mac. It really runs like crap or not at all on most peoples systems for random reasons.

Judging by the rest ofyour computers specs, you should be ok, as long as your graphics card's video memory is up to spec.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Sunday 14 July 2013 at 19:23
Ronin DUSETTE
Admin

Also, a lot of people pay no attention to the instructions that are given in the script. The script says to:

Attention: After installation is complete, the patcher will load. Please close the patcher before logging in or finish updating to complete the installation. After this, you can run "$TITLE" when setup is done

Quote


Make sure you do this, as the script will for SURE fail if this step is not followed. Literally, when the patcher pops up during install, close or cancel the patcher, and let PlayOnMac finish its thing. When PlayOnMac finishes, then run WoT and let it patch/update.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
sweavo Sunday 1 September 2013 at 10:37
sweavo

Hey there,

first I wanna say how I appreciate the effort that's gone into supporting PoM and WoT. It would be perfectly understandable if every thread here ended with "get a PC if you want to play games".

A small feedback to this topic; when I installed WoT/PoM I remember receiving this instruction, but I was not at all clear what "the patcher" would look like. ISTR I let it run for ages before thinking "woah, maybe THIS is the thing I'm supposed to abort!". So maybe the instruction to the end user could be made more clear.

Keep up the good work, especially DJYosha, who I've not seen lose his patience in all the posts I've read so far :-)


evidence beats assumptions every time! Post your whole log.
Ronin DUSETTE Tuesday 1 October 2013 at 20:25
Ronin DUSETTE
Admin

Well, I have a few times. :) lol. but I try not to.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts