The forum

Unable to run Steam games

Author Replies
jaewoong Tuesday 23 July 2013 at 6:21
jaewoongAnonymous

Hi there.

I installed the app today and quick-tried some of my windows-only steam games, but nothing worked. I tried <The Settlers: Rise of an Empire Gold Edition>, <Fez> and <Breath of Death VII> with windows version of steam. But when I run the game, the screen goes die to the black screen(settlers) or flashes with some random colors(fez) while the sound is played well.

I DO REALLY WANT TO PLAY THE SETTLERS 6. Is there any way?

Also, I've found that there are some user-made scripts. Can you please let me know how to make use of those scripts? I have absolutely no idea about the playonmac app and having some trouble finding an easy documentation for newbies like me. I don't think I even have a vague concept of the whole this thing right now.

Thank you for your reply in advance.
jaewoong Tuesday 23 July 2013 at 6:35
jaewoongAnonymous

In addition:

Version of PlayOnMac: 4.2.1
Wine version for the Steam(?): 1.5.25
My system: Mac OS 10.8.3(mountain lion) on MBP 13"(May 2010).

Please let me know if you need any additional information.

Ah, also, every after I quit the windows version of Steam by pressing cmd+q, there pops up a screen saying an error has occurred.

The message is:
     Error in main
     Steam crashed.
     Click on debug link to get more details.
and I cannot find any debug link.
Ronin DUSETTE Tuesday 23 July 2013 at 6:39
Ronin DUSETTE
Admin

All of the scripts are user-made. Only use the ones listed in PlayOnMac, as those are approved and tested to work.

You apparently did not read the stickies or rules at the top of the forum, telling you how to explain your issue and what we need to check. If you go back into the playonmac forum, you will see a few posts that say "READ BEFORE POSTING"..... Please do as they say, and post back with the proper information, and we can troubleshoot your problem.

Also, you might want to read:

http://www.playonmac.com/en/documentation.html

It was at the top of the screen. Reads the manual in there. It will explain a lot.

If you are curious about how this program works (trust me, it helps), you can read this, as well. It gives a really good, short explanation of what this app does.

http://wiki.winehq.org/PlayOnLinux

Read all of that, and post up according to the forum rules, and we will try to figure out whats going on. You are most likely missing some things that all of the games require, and once you post up that information and the debug output, we can get that figured out.

Welcome to Linux. :)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
jaewoong Tuesday 23 July 2013 at 9:31
jaewoongAnonymous

Hello again!
Thank you for your advice.

Here is the detailed procedure of how I get stuck when I try to run a game 'The Settlers: Rise of an Empire Gold Edition' with Steam for Windows.

1. Run Steam using POM.
2. Install and run the game.
3. Ask me to allow to change screen resolution, and I allow. (RandR mode)
4a. Screen goes black and there's no sound.
4b. Screen goes black and sounds seems to be played normal.
(either 4a or 4b happens randomly as I try, but mostly 4a happens)
5a. If I press any key, it beeps and nothing seems to work in any way.
5b. Pressing key seems to skip an opening movie of the game.
(4a is followed by 5a, and 4b is followed by 5b)
6. Press Cmd+Opt+A to restore the screen resolution.
7a. There is no game screen. Only Steam and POM are running. No mouse cursor.
7b. There is a letterboxed white blank screen.
(either 7a or 7b happens randomly as I try, but mostly 7a happens)
8. Press Cmd+Q to exit the game and Steam.
9. An error dialog box appears as I mentioned my second post.

I tried to capture the debugger log and here it is:
("run Steam -> run The Settlers -> quit" following all 'a courses' mentioned above)

[07/23/13 16:17:04] - Running wine-1.5.25 Steam.exe (Working directory : /Users/Jaewoong/Library/PlayOnMac/wineprefix/Steam/drive_c/Program Files/Steam)
[0723/161720:ERROR:network_change_notifier_win.cc(126)] WSALookupServiceBegin failed with: 8

[0723/161736:ERROR:network_change_notifier_win.cc(126)] WSALookupServiceBegin failed with: 8

[0723/161744:ERROR:network_change_notifier_win.cc(126)] WSALookupServiceBegin failed with: 8

X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 10 (X_UnmapWindow)
Resource id in failed request: 0x1200001
Serial number of failed request: 189
Current serial number in output stream: 192


I asked to install the XQuarts or X-something when installing POM, and I think the installation process was just good.
Maybe I need to try reinstalling POM after posting this.

Thank you and let me know if you need anything else I didn't write so far.
jaewoong Tuesday 23 July 2013 at 11:31
jaewoongAnonymous

More debugger log!
This is a whole log after reinstalling POM.
I reinstalled and launched Steam for Windows and The Settlers: Rise of an Empire Gold Edition.
The procedure was like 1-2-3-4b-5a-6-7b-5b-8 and no 9.

Can you please help me to figure out what is the problem with this?


Log:

[07/23/13 17:57:30] - Running wine-1.5.25 --version (Working directory : /Users/Jaewoong/Library/PlayOnMac/wine/gecko)
wine-1.5.25

PlayOnMac logfile
-------------------
Date: 07/23/13 17:57:29

> PlayOnMac Version
4.2.1
> uname -a
Darwin Jaewoong-2.local 12.3.0 Darwin Kernel Version 12.3.0: Sun Jan 6 22:37:10 PST 2013; root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64
> lsb_release -a

> wine --version
wine-1.5.25
> POL_WINEVERSION
1.5.25
> WINEPREFIX
/Users/Jaewoong/Library/PlayOnMac//wineprefix/Steam
> Distribution
Mountain Lion 10.8.3 (12.3.0)
> glxinfo \\| grep rendering
direct rendering: Yes
> glxinfo \\| grep renderer
OpenGL renderer string: NVIDIA GeForce 320M OpenGL Engine
> OpenGL libs (Direct rendering testing)



[07/23/13 17:59:09] - Running wine-1.5.25 cmd /c echo %ProgramFiles% (Working directory : /Users/Jaewoong/Library/PlayOnMac/wine/gecko)
C:\\Program Files

[07/23/13 17:59:22] - Running wine-1.5.25 msiexec /i SteamInstall.msi /q (Working directory : /Users/Jaewoong/Library/PlayOnMac/wineprefix/Steam/drive_c)
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut
fixme:hnetcfg:fw_app_put_ProcessImageFileName 0x169370, L"C:\\\\Program Files\\\\Steam\\\\Steam.exe"
fixme:hnetcfg:fw_app_put_Name 0x169370, L"Steam"
fixme:hnetcfg:fw_apps_Add 0x169328, 0x169370
fixme:service:SERV_QueryServiceObjectSecurity 0x169798 4 0x33f98c 512 0x33fbc0 - semi-stub
fixme:service:SetServiceObjectSecurity 0x169798 4 0x33fb8c
Steam Client Service install completed.[07/23/13 17:59:41] - Running wine-1.5.25 regedit /Users/Jaewoong/Library/PlayOnMac//tmp/regkey.reg (Working directory : /Users/Jaewoong/Library/PlayOnMac/winepr[07/23/13 17:59:41] - Content of /Users/Jaewoong/Library/PlayOnMac//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\\Software\\Wine\\Direct3D]
"VideoMemorySize"="256"
-----------
[07/23/13 17:59:46] - Running wine-1.5.25 regedit /Users/Jaewoong/Library/PlayOnMac//tmp/override-dll.reg (Working directory : /Users/Jaewoong/Library/PlayOnMac/wineprefix/Steam/drive_c)
[07/23/13 17:59:46] - Content of /Users/Jaewoong/Library/PlayOnMac//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\\Software\\Wine\\DllOverrides]
"*dwrite"=""
-----------
[07/23/13 18:00:02] - Running wine-1.5.25 Steam.exe (Working directory : /Users/Jaewoong/Library/PlayOnMac/wineprefix/Steam/drive_c/Program Files/Steam)
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".

ILocalize::AddFile() failed to load file "public/steambootstrapper_unknown.txt".

[2013-07-23 18:00:23] Startup


[2013-07-23 18:00:23] Verifying installation...


[2013-07-23 18:00:23] Downloading Update...


[2013-07-23 18:00:23] Checking for available update...


[2013-07-23 18:00:24] Package file strings_all.zip.4178350204feb8c5902fa92a156d9c30301eee01 missing or incorrect size




[2013-07-23 18:00:24] Package file resources_all.zip.be469e8af8dc3ce6147f7bad396108e18a1a20f6 missing or incorrect size




[2013-07-23 18:00:24] Package file tenfoot_all.zip.2f75dcb8b34d51a1455b26204516d9116e2323ee missing or incorrect size




[2013-07-23 18:00:24] Package file tenfoot_fonts_all.zip.1b6915a5c23a4cf6e406f67608e9f812ff0f39aa missing or incorrect size




[2013-07-23 18:00:24] Package file tenfoot_ambientsounds_all.zip.888b796633f8a81789aeb026bc1aa3292d04f989 missing or incorrect size




[2013-07-23 18:00:24] Package file tenfoot_sounds_all.zip.fc33941aff5fa6729661eb6c625c6498d371af06 missing or incorrect size




[2013-07-23 18:00:24] Package file tenfoot_images_all.zip.82176b5e83ca6810a331dedcaeb3bf9f051c5e2b missing or incorrect size




[2013-07-23 18:00:24] Package file public_all.zip.246876f1ae853b27ced389393ccb396345527748 missing or incorrect size




[2013-07-23 18:00:24] Package file bins_win32.zip.3417bfad6db098c79f6b7d2e1ad92a027f24e724 missing or incorrect size




[2013-07-23 18:00:24] Package file webkit_win32.zip.e52cd530b3c225f68b7988f91379434d9b4aea25 missing or incorrect size




[2013-07-23 18:00:24] Package file gamesforwindows_win32.zip.8a85da058a00e1d376c21c23939fb2555cbf691f missing or incorrect size




[2013-07-23 18:00:24] Package file backup_win32.zip.23a4b137fe59f37238ad710ebab075dc74f434a3 missing or incorrect size




[2013-07-23 18:00:24] Package file steam_win32.zip.9377e0adf3c2c7cc2da7b4cc6436379bd22dbeb1 missing or incorrect size




[2013-07-23 18:00:24] Downloading update (0 of 97,274 KB)...


[2013-07-23 18:00:29] Downloading update (392 of 97,274 KB)...


[2013-07-23 18:00:29] Downloading update (3,669 of 97,274 KB)...


[2013-07-23 18:00:30] Downloading update (4,980 of 97,274 KB)...


[2013-07-23 18:00:30] Downloading update (5,504 of 97,274 KB)...


[2013-07-23 18:00:31] Downloading update (6,028 of 97,274 KB)...


[2013-07-23 18:00:31] Downloading update (7,450 of 97,274 KB)...


[2013-07-23 18:00:31] Downloading update (10,203 of 97,274 KB)...


[2013-07-23 18:00:31] Downloading update (12,235 of 97,274 KB)...


[2013-07-23 18:00:32] Downloading update (13,545 of 97,274 KB)...


[2013-07-23 18:00:32] Downloading update (16,298 of 97,274 KB)...


[2013-07-23 18:00:32] Downloading update (18,132 of 97,274 KB)...


[2013-07-23 18:00:33] Downloading update (20,885 of 97,274 KB)...


[2013-07-23 18:00:33] Downloading update (28,093 of 97,274 KB)...


[2013-07-23 18:00:33] Downloading update (30,977 of 97,274 KB)...


[2013-07-23 18:00:34] Downloading update (34,627 of 97,274 KB)...


[2013-07-23 18:00:34] Downloading update (37,510 of 97,274 KB)...


[2013-07-23 18:00:39] Downloading update (39,786 of 97,274 KB)...


[2013-07-23 18:00:43] Downloading update (77,518 of 97,274 KB)...


[2013-07-23 18:00:48] Downloading update (83,857 of 97,274 KB)...


[2013-07-23 18:00:48] Downloading update (86,347 of 97,274 KB)...


[2013-07-23 18:00:49] Downloading update (86,698 of 97,274 KB)...


[2013-07-23 18:00:50] Downloading update (88,664 of 97,274 KB)...


[2013-07-23 18:00:50] Downloading update (89,057 of 97,274 KB)...


[2013-07-23 18:00:50] Downloading update (89,713 of 97,274 KB)...


[2013-07-23 18:00:50] Downloading update (90,237 of 97,274 KB)...


[2013-07-23 18:00:51] Downloading update (90,761 of 97,274 KB)...


[2013-07-23 18:00:51] Downloading update (91,417 of 97,274 KB)...


[2013-07-23 18:00:51] Downloading update (91,941 of 97,274 KB)...


[2013-07-23 18:00:51] Downloading update (92,859 of 97,274 KB)...


[2013-07-23 18:00:52] Downloading update (93,383 of 97,274 KB)...


[2013-07-23 18:00:52] Downloading update (94,169 of 97,274 KB)...


[2013-07-23 18:00:52] Downloading update (94,956 of 97,274 KB)...


[2013-07-23 18:00:52] Downloading update (95,218 of 97,274 KB)...


[2013-07-23 18:00:53] Downloading update (95,480 of 97,274 KB)...


[2013-07-23 18:00:53] Downloading update (96,733 of 97,274 KB)...


[2013-07-23 18:00:54] Downloading update (97,126 of 97,274 KB)...


[2013-07-23 18:01:00] Downloading update (97,274 of 97,274 KB)...


[2013-07-23 18:01:00] Download Complete.


[2013-07-23 18:01:00] uninstalled manifest found in C:\\Program Files\\Steam\\package\\steam_client_win32.




[2013-07-23 18:01:00] Extracting package...


[2013-07-23 18:01:22] Installing update...


[2013-07-23 18:01:29] Failed to clear up temporary update files used for rollback, continuing anyway


[2013-07-23 18:01:29] Cleaning up...


[2013-07-23 18:01:30] Update complete, launching...


[2013-07-23 18:01:30] Shutdown


ILocalize::AddFile() failed to load file "public/steambootstrapper_unknown.txt".

[2013-07-23 18:01:31] Startup - updater built Jul 9 2013 17:45:38

[2013-07-23 18:01:31] Verifying installation...

[2013-07-23 18:01:31] Unable to read and verify install manifest C:\\Program Files\\Steam\\package\\steam_client_win32.installed

[2013-07-23 18:01:31] Verification complete

[2013-07-23 18:01:31] Downloading update...

[2013-07-23 18:01:31] Checking for available updates...

[2013-07-23 18:01:33] Download complete.

[2013-07-23 18:01:33] uninstalled manifest found in C:\\Program Files\\Steam\\package\\steam_client_win32 (1).

[2013-07-23 18:01:33] Extracting package...

[2013-07-23 18:01:58] Installing update...

[2013-07-23 18:02:13] Failed to clean up after update, continuing...

[2013-07-23 18:02:13] Cleaning up...

[2013-07-23 18:02:13] Update complete, launching Steam...

[2013-07-23 18:02:13] Shutdown

[0723/180218:ERROR:network_change_notifier_win.cc(126)] WSALookupServiceBegin failed with: 8

[0723/180220:ERROR:network_change_notifier_win.cc(126)] WSALookupServiceBegin failed with: 8

[0723/180228:ERROR:network_change_notifier_win.cc(126)] WSALookupServiceBegin failed with: 8

[0723/180337:ERROR:network_change_notifier_win.cc(126)] WSALookupServiceBegin failed with: 8

XIO: fatal IO error 35 (Resource temporarily unavailable) on X server "/tmp/launch-eJiNEp/org.macosforge.xquartz:0"

after 282 requests (282 known processed) with 5 events remaining.

XIO: fatal IO error 35 (Resource temporarily unavailable) on X server "/tmp/launch-eJiNEp/org.macosforge.xquartz:0"

after 18135 requests (18135 known processed) with 0 events remaining.

XIO: fatal IO error 35 (Resource temporarily unavailable) on X server "/tmp/launch-eJiNEp/org.macosforge.xquartz:0"

after 305 requests (305 known processed) with 9 events remaining.

wine(3692,0x41040000) malloc: *** error for object 0x4028a080: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Ronin DUSETTE Tuesday 23 July 2013 at 17:39
Ronin DUSETTE
Admin

Gotta learn to be patient. We are a very small team. :)

Is this for all steam games? If so, then we are missing something in OSX or in the virtual drive.

It flat out looks like 2 things:

1 - It cannot connect to the internet correctly, so make sure that you installed Samba from that link above (for winbind).

2 - Install the most updated drivers from Nvidia's website and see if that helps.

Also, install IE6 into your virtual drive, as well as d3dx9 and lets see if that helps.

"VideoMemorySize"="256"

Quote


I checked the specs, and you are above the min. requirements.

Also, check to see what version of XQuartz youre running, as see if maybe updating it will help

http://xquartz.macosforge.org/landing/

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
jaewoong Tuesday 23 July 2013 at 18:58
jaewoongAnonymous

Thank you DJYoshaBYD!
I'm not pushing you to solve my problem asap, so please do not be bothered by me and sorry if I bugged you.

Okay.... these are some reports you may want to know:

First, "Fez" and "The Settlers" on Steam don't work and I think this would be true to all Steam games, although I haven't tried other games after reinstalling PlayOnMac.
But I did try running a GOG version game named "Treasure Adventure Game" which is not listed on Wine App DB, using "Install a non-listed program" function of POM. It had a locale problem and was unplayably slow but worked anyway, so the problem might not be laid on POM or OS itself, I guess?

Second, my graphics driver should be up to date because I'm using Mac and my OS is up to date. I tried to find most updated driver, only to find the fact that Mac OS does that automatically and I have no need/right to do that manually.

Third, my XQuartz version is 2.7.4(xorg-server 1.13.0) and it says it's up to date when I check for update.


And... can you please tell me the link regarding Samba again? I cannot find where's the link above :'(

I'll try what you said and report to here again if there's any progress.
And again, this is not a high-priority thing to me as well, so please don't mind much.
Thank you again in advance!
Ronin DUSETTE Tuesday 23 July 2013 at 19:05
Ronin DUSETTE
Admin

I guess the link didnt stick

https://www.macupdate.com/app/mac/41541/smbup

Also, all of the macbooks in 2010 that I can see all had Nividia cards, specifically an Nvidia 320m. Check Nvidia's website for the most recent driver. Its always best to check the manufacturers website, as opposed to relying on system updates. Plus, your system updates may only install the 64 bit libs, even though POM needs the 32 bit libs. Trust me. :) Its worth looking at.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
jaewoong Wednesday 24 July 2013 at 17:45
jaewoongAnonymous

Thank you, and this is today's report!

1. Internet Explorer
- Installed Internet Explorer 6 with POM.
- Changed its virtual drive to Steam.
- Internet Explorer itself runs well just as Steam.

2. Samba
- Downloaded SMBUp from your link and installed samba via SMBUp.

3. d3dx9
- I don't exactly know what this is and how to install this, but I think they're a bunch of dll files that Wine needs and I found d3dx9_24~43.dll from system32 folder in the virtual drive, so I did nothing.

4. Graphics Driver
- Just cannot check my current driver version! Even "System Information" do not have the information.
- Found some CUDA driver for mac( http://www.nvidia.com/object/macosx-cuda-5.0.61-driver.html ) but never tried installing it, because I'm quite afraid to mess things up if I do this not knowing well what I'm doing.
- Maybe I can try this later.

5. Test Result
- Nothing got better.
- Checked the debugger log, but it seems that errors are just the same as yesterday.

Please let me know if I did something wrong.
I'll do more, like installing totally different games with POM, when I have time and will write the result if anything seems notable.
jaewoong Wednesday 24 July 2013 at 18:32
jaewoongAnonymous

Oh, I found there's a install tab that allows me to install d3dx9 and internet explorer.
I might totally did it wrong.
I'll try this later :)
Ronin DUSETTE Wednesday 24 July 2013 at 20:20
Ronin DUSETTE
Admin

4. Graphics Driver
- Just cannot check my current driver version! Even "System Information" do not have the information.
- Found some CUDA driver for mac( http://www.nvidia.com/object/macosx-cuda-5.0.61-driver.html ) but never tried installing it, because I'm quite afraid to mess things up if I do this not knowing well what I'm doing.
- Maybe I can try this later.

Quote


wrong. DONT EVER INSTALL STUFF IF YOU DONT KNOW WHAT IT IS. Cuda hasnothing to do with this issue.

You need to get the Nvidia GRAPHICS CARD driver for your system. Google search your system and find out what video card it came with, go to Nvidia.com and download and install it.

Steam through Wine has been doing a lot of stuff, but what you are describing really sounds like your missing your graphics card drivers. That is the main thing we need to get checked.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Quentin PÂRIS Friday 18 July 2014 at 23:54
Quentin PÂRIS
Admin

Well, on Mac OS X there are no need to install drivers ;-)

petch Saturday 19 July 2014 at 0:25
petch
Developer

Or no way to install drivers, depending on your take...

Quentin PÂRIS Saturday 19 July 2014 at 1:27
Quentin PÂRIS
Admin

Basically, all the mac are nearly the same. Drivers are already integrated. If there are problems with OpenGL and XQuartz, wich seems to be the case here, I would recommend to install a wine version that does no longer need X11 (1.7.22 will be good)