The forum

Cannot install any game

stuck at steam?

Author Replies
cebollo Monday 29 July 2013 at 9:42
cebolloAnonymous

Hello, 

I am having issues with PlayOnMac 4.2.1,
Mac OS X 10.8.4

I have tried to install Mount&Blade Warband and Skyrim.

For Mount&Blade:

I get to the Download Wine 1.3.16 screen.
I get to the Extracting Wine screen.
I get a dialog that says Please choose installation method.
I choose Use Steam Store method.
It goes back to the Download Wine 1.3.16 screen.
I see the Extracting Wine screen.
I get an error that says:
 Error in POL_Wine

Wine seems to have crashed


If your program is running, just ignore this message


I click Next, and it starts Downloading Wine 1.3.16 again

It gets to the Extracting Wine screen.
A dialog box pops up that says File not Found.

It's the same thing for Skyrim.

Thanks in advance!


EDIT: this is what the log says.

2:49:56 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 12:49:56 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 12:50:46 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 12:50:46 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 12:50:46 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 12:50:46 - [POL_Wine] Message: Running wine-1.3.16 cmd /c echo %ProgramFiles% (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

07/29/13 12:50:46 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonmac.com/fr/page-26-Winemenubuilder.html

C:\\Program Files


07/29/13 12:51:31 - [POL_Wine] Message: Wine return: 0

07/29/13 12:51:34 - [POL_Call] Message: Calling POL_Install_mfc42

07/29/13 12:51:34 - [POL_Call] Message: ----- Starting function POL_Install_mfc42 -----

07/29/13 12:51:34 - [POL_GPG_auth_script] Message: Checking signature of POL_Install_mfc42

07/29/13 12:51:34 - [POL_GPG_install_key] Message: Importing PlayOnMac public key

07/29/13 12:51:34 - [POL_Source] Message: POL GPG : Good signature

07/29/13 12:51:34 - [POL_Download_Resource] Message: Downloading resource http://files.playonlinux.com/mfc42_dll.zip

07/29/13 12:51:35 - [POL_Download_Resource] Message: Resource already present

07/29/13 12:51:35 - [POL_Download_Resource] Message: Downloading resource http://files.playonlinux.com/mfc42u_dll.zip

07/29/13 12:51:35 - [POL_Download_Resource] Message: Resource already present

07/29/13 12:51:35 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 12:51:35 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 12:52:26 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 12:52:26 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 12:52:26 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 12:52:27 - [POL_Wine] Message: Running wine-1.3.16 regsvr32 mfc42.dll (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

07/29/13 12:52:27 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonmac.com/fr/page-26-Winemenubuilder.html

Successfully registered DLL mfc42.dll

07/29/13 12:52:28 - [POL_Wine] Message: Wine return: 0

07/29/13 12:52:28 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 12:52:28 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 12:53:15 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 12:53:15 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 12:53:15 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 12:53:15 - [POL_Wine] Message: Running wine-1.3.16 regsvr32 mfc42u.dll (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

Successfully registered DLL mfc42u.dll

07/29/13 12:53:16 - [POL_Wine] Message: Wine return: 0

07/29/13 12:53:16 - [POL_Call] Message: Calling POL_Function_OverrideDLL

07/29/13 12:53:16 - [POL_Call] Message: ----- Starting function POL_Function_OverrideDLL -----

07/29/13 12:53:16 - [POL_GPG_auth_script] Message: Checking signature of POL_Function_OverrideDLL

07/29/13 12:53:16 - [POL_GPG_install_key] Message: Importing PlayOnMac public key

07/29/13 12:53:17 - [POL_Source] Message: POL GPG : Good signature

07/29/13 12:53:17 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 12:53:17 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 12:54:03 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 12:54:03 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 12:54:03 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 12:54:03 - [POL_Wine] Message: Running wine-1.3.16 regedit /Users/Shao Old/Library/PlayOnMac//tmp/override-dll.reg (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

07/29/13 12:54:03 - [POL_Wine] Message: Wine return: 0

07/29/13 12:54:03 - [POL_Call] Message: ----- Ending function POL_Function_OverrideDLL -----

07/29/13 12:54:03 - [POL_Call] Message: ----- Ending function POL_Install_mfc42 -----

07/29/13 12:55:16 - [POL_SetupWindow_icon_menu] Message: icon_menu answer: Use Steam Store version

07/29/13 12:55:16 - [POL_SetupWindow_InstallMethod] Message: Install method: STEAM

07/29/13 12:55:16 - [POL_Call] Message: Calling POL_Install_steam

07/29/13 12:55:16 - [POL_Call] Message: ----- Starting function POL_Install_steam -----

07/29/13 12:55:16 - [POL_GPG_auth_script] Message: Checking signature of POL_Install_steam

07/29/13 12:55:16 - [POL_GPG_install_key] Message: Importing PlayOnMac public key

07/29/13 12:55:16 - [POL_Source] Message: POL GPG : Good signature

07/29/13 12:55:16 - [POL_LoadVar_PROGRAMFILES] Message: Getting Program Files name

07/29/13 12:55:16 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 12:55:16 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 12:56:17 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 12:56:17 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 12:56:17 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 12:56:17 - [POL_Wine] Message: Running wine-1.3.16 cmd /c echo %ProgramFiles% (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

C:\\Program Files


07/29/13 12:56:18 - [POL_Wine] Message: Wine return: 0

07/29/13 12:56:21 - [POL_Wine_InstallFonts] Message: Installing microsoft fonts

07/29/13 12:56:21 - [POL_Call] Message: Calling POL_Function_FontsSmoothRGB

07/29/13 12:56:21 - [POL_Call] Message: ----- Starting function POL_Function_FontsSmoothRGB -----

07/29/13 12:56:21 - [POL_GPG_auth_script] Message: Checking signature of POL_Function_FontsSmoothRGB

07/29/13 12:56:21 - [POL_GPG_install_key] Message: Importing PlayOnMac public key

07/29/13 12:56:21 - [POL_Source] Message: POL GPG : Good signature

07/29/13 12:56:22 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 12:56:22 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 12:57:18 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 12:57:18 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 12:57:18 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 12:57:18 - [POL_Wine] Message: Running wine-1.3.16 regedit /Users/Shao Old/Library/PlayOnMac//tmp/fontsaa.reg (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

07/29/13 12:57:19 - [POL_Wine] Message: Wine return: 0

07/29/13 12:57:19 - [POL_Call] Message: ----- Ending function POL_Function_FontsSmoothRGB -----

07/29/13 12:57:19 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 12:57:19 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 12:58:13 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 12:58:13 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 12:58:13 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 12:58:13 - [POL_Wine] Message: Running wine-1.3.16 msiexec /i SteamInstall.msi /q (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

07/29/13 12:58:23 - [POL_Wine] Error: Wine seems to have crashed\\n\\nIf your program is running, just ignore this message

07/29/13 13:07:00 - [POL_Wine] Message: Wine return: 2

07/29/13 13:07:00 - [POL_Wine_OverrideDLL] Message: Overriding DLLs

07/29/13 13:07:00 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 13:07:00 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 13:08:04 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 13:08:04 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 13:08:04 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 13:08:04 - [POL_Wine] Message: Running wine-1.3.16 regedit /Users/Shao Old/Library/PlayOnMac//tmp/override-dll.reg (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

07/29/13 13:08:04 - [POL_Wine] Message: Wine return: 0

07/29/13 13:08:04 - [POL_Call] Message: ----- Ending function POL_Install_steam -----

07/29/13 13:08:04 - [POL_Call] Message: Calling POL_Install_steam_flags

07/29/13 13:08:05 - [POL_Call] Message: ----- Starting function POL_Install_steam_flags -----

07/29/13 13:08:05 - [POL_GPG_auth_script] Message: Checking signature of POL_Install_steam_flags

07/29/13 13:08:05 - [POL_GPG_install_key] Message: Importing PlayOnMac public key

07/29/13 13:08:05 - [POL_Source] Message: POL GPG : Good signature

07/29/13 13:08:05 - [POL_Call] Message: ----- Ending function POL_Install_steam_flags -----

07/29/13 13:08:05 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

07/29/13 13:08:05 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.3.16, x86

07/29/13 13:08:53 - [POL_Wine_Install_gecko] Message: Installing gecko for wine 1.3.16 x86

07/29/13 13:08:53 - [POL_Wine_Install_gecko] Message: Linking gecko

07/29/13 13:08:53 - [POL_Wine_Install_gecko] Message: wine_gecko-1.2.0-x86.msi already installed. Skipping

07/29/13 13:08:53 - [POL_Wine] Message: Running wine-1.3.16 start /unix Steam.exe steam://install/48700 (Working directory : /Users/Shao Old/Library/PlayOnMac/wine/darwin-x86)

fixme:exec:SHELL_execute flags ignored: 0x00000100



Edited by cebollo

Ronin DUSETTE Wednesday 31 July 2013 at 8:53
Ronin DUSETTE
Admin

07/29/13 13:08:05 - [POL_Wine_SetVersionEnv] Message: Wine 1.3.16 not installed. Installing it

Quote


You get this error over and over, which means that Wine is not installing all of the way. Delete the virtual drive and try to reinstall it.

What exactly are you trying to run?

also, make sure that you have curl and winbind (samba) installed, as you will need those for POM to work.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Wednesday 31 July 2013 at 9:00
Ronin DUSETTE
Admin

Try to remove that version out of the list of installed wine versions. That could help. I think it half-ass downloaded, and got stuck. You can remove the wine 1.3.16 version and try again in PlayOnMac -> Tools -> Manage wine versions

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
cebollo Wednesday 31 July 2013 at 10:27
cebolloAnonymous

Thanks for the reply DJ.

I have deleted the virtual drive, and reinstalled it. I ran into the same issue while trying to install Mount&Blade:Warband, which is ultimately what I would like to run.

As it turns out, OS X Lion doesn't come with Samba, so I installed it via SMBUp

http://eduo.info/apps/smbup

However, this doesn't seem to have solved the problem as I have the same issue. Do I need to configure Samba in any way?

Also, when I go to Manage wine versions, it doesn't list any installed versions.

I should also note that I had previously installed wine via MacPorts. I think I deleted it, but I'm' not sure if there are any remnants left or if this has any efffect on POM.
Ronin DUSETTE Wednesday 31 July 2013 at 16:11
Ronin DUSETTE
Admin

No. The only reason that you need samba is to get winbind installed, and that was just a precaution.

Also, when I go to Manage wine versions, it doesn't list any installed versions.

Quote

Well, then choose 1.6 32 bit and click the arrow to install it (it will move 1.6 to the others side of the manage wine versions window). lol.

Thats why it wont work; you dont have any versions of wine installed, and POM will try to default to the system one, which you dont have, so it fails.

Even though Wine and POM-Wine-Builds are kept apart and act apart, you still need a system version of Wine installed on your system, but you never want to use the system version in POM, which is why we have the tool to download wine versions for use in POM.

So, in short, get wine 1.6 installed on your actual system, and then go to manage wine versions and get 1.6 32 bit installed in POM. Then try to run an install from:

POM -> Install -> Select game -> click Install and follow prompts.

Make sure no other internet-heavy apps are running on your network. If the wine download fails, it causes issues.

If this does not work, then you will need to FULLY delete POM and redownload and install it again. Its fairly common for OSX to partially download the POM package, as its a big file.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts